summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2025-04-01 16:40:39 -0700
committerKhem Raj <raj.khem@gmail.com>2025-04-01 21:59:45 -0700
commitafe1c610c5538d4f3541c4167bee6b135e5985e6 (patch)
tree4d5fd6d1a0eb81b033d52859ad7c1a6f13b00536
parentc86c9fa882ea0f49d11aa6424b4d99bd9390fd8f (diff)
downloadmeta-openembedded-afe1c610c5538d4f3541c4167bee6b135e5985e6.tar.gz
python3-lief: Upgrade to latest on tip of trunk
Adds new dependency on typing-inspection module Fix build with GCC-15 while here Signed-off-by: Khem Raj <raj.khem@gmail.com>
-rw-r--r--meta-python/recipes-devtools/python/python3-lief/0001-Add-cstdio-include.patch134
-rw-r--r--meta-python/recipes-devtools/python/python3-lief_0.16.4.bb (renamed from meta-python/recipes-devtools/python/python3-lief_0.16.3.bb)5
2 files changed, 138 insertions, 1 deletions
diff --git a/meta-python/recipes-devtools/python/python3-lief/0001-Add-cstdio-include.patch b/meta-python/recipes-devtools/python/python3-lief/0001-Add-cstdio-include.patch
new file mode 100644
index 0000000000..396e935ddd
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-lief/0001-Add-cstdio-include.patch
@@ -0,0 +1,134 @@
1From a9b7a9f5c5572fc839d05457da073dc817722ace Mon Sep 17 00:00:00 2001
2From: Khem Raj <raj.khem@gmail.com>
3Date: Tue, 1 Apr 2025 17:27:46 -0700
4Subject: [PATCH] Add cstdio include
5
6This is needed for uintXX_t types, GCC-15 is defauling to C23 and will error
7about it.
8
9e.g.
10
11include/LIEF/PE/LoadConfigurations/VolatileMetadata.hpp:145:3: note: 'uint32_t' is defined in header '<cstdint>'; this is probably fixable by adding '#include <cstdint>'
12
13Upstream-Status: Submitted [https://github.com/lief-project/LIEF/pull/1184]
14Signed-off-by: Khem Raj <raj.khem@gmail.com>
15---
16 include/LIEF/DWARF/Scope.hpp | 1 +
17 include/LIEF/ObjC/Method.hpp | 1 +
18 include/LIEF/PDB/PublicSymbol.hpp | 1 +
19 include/LIEF/PDB/types/Attribute.hpp | 1 +
20 include/LIEF/PE/LoadConfigurations/VolatileMetadata.hpp | 1 +
21 include/LIEF/PE/Relocation.hpp | 1 +
22 include/LIEF/PE/signature/attributes/PKCS9AtSequenceNumber.hpp | 1 +
23 include/LIEF/PE/signature/attributes/SpcRelaxedPeMarkerCheck.hpp | 1 +
24 src/MachO/TrieNode.hpp | 1 +
25 9 files changed, 9 insertions(+)
26
27diff --git a/include/LIEF/DWARF/Scope.hpp b/include/LIEF/DWARF/Scope.hpp
28index 78752847..61977c21 100644
29--- a/include/LIEF/DWARF/Scope.hpp
30+++ b/include/LIEF/DWARF/Scope.hpp
31@@ -15,6 +15,7 @@
32 #ifndef LIEF_DWARF_SCOPE_H
33 #define LIEF_DWARF_SCOPE_H
34
35+#include <cstdint>
36 #include <memory>
37 #include <string>
38
39diff --git a/include/LIEF/ObjC/Method.hpp b/include/LIEF/ObjC/Method.hpp
40index b4e82c6e..b9f37288 100644
41--- a/include/LIEF/ObjC/Method.hpp
42+++ b/include/LIEF/ObjC/Method.hpp
43@@ -16,6 +16,7 @@
44 #define LIEF_OBJC_METHOD_H
45 #include <LIEF/visibility.h>
46
47+#include <cstdint>
48 #include <memory>
49 #include <string>
50
51diff --git a/include/LIEF/PDB/PublicSymbol.hpp b/include/LIEF/PDB/PublicSymbol.hpp
52index b8904a5b..0e105435 100644
53--- a/include/LIEF/PDB/PublicSymbol.hpp
54+++ b/include/LIEF/PDB/PublicSymbol.hpp
55@@ -14,6 +14,7 @@
56 */
57 #ifndef LIEF_PDB_PUBLIC_SYMBOL_H
58 #define LIEF_PDB_PUBLIC_SYMBOL_H
59+#include <cstdint>
60 #include <memory>
61 #include <string>
62 #include <ostream>
63diff --git a/include/LIEF/PDB/types/Attribute.hpp b/include/LIEF/PDB/types/Attribute.hpp
64index a41270c0..fc961be5 100644
65--- a/include/LIEF/PDB/types/Attribute.hpp
66+++ b/include/LIEF/PDB/types/Attribute.hpp
67@@ -17,6 +17,7 @@
68
69 #include "LIEF/visibility.h"
70
71+#include <cstdint>
72 #include <string>
73 #include <memory>
74
75diff --git a/include/LIEF/PE/LoadConfigurations/VolatileMetadata.hpp b/include/LIEF/PE/LoadConfigurations/VolatileMetadata.hpp
76index 41b9e36b..073ccabc 100644
77--- a/include/LIEF/PE/LoadConfigurations/VolatileMetadata.hpp
78+++ b/include/LIEF/PE/LoadConfigurations/VolatileMetadata.hpp
79@@ -15,6 +15,7 @@
80 */
81 #ifndef LIEF_PE_LOAD_CONFIGURATION_VOLATILE_METADATA_H
82 #define LIEF_PE_LOAD_CONFIGURATION_VOLATILE_METADATA_H
83+#include <cstdint>
84 #include <memory>
85 #include <string>
86 #include <vector>
87diff --git a/include/LIEF/PE/Relocation.hpp b/include/LIEF/PE/Relocation.hpp
88index a4cd2e96..cd81bf68 100644
89--- a/include/LIEF/PE/Relocation.hpp
90+++ b/include/LIEF/PE/Relocation.hpp
91@@ -15,6 +15,7 @@
92 */
93 #ifndef LIEF_PE_RELOCATION_H
94 #define LIEF_PE_RELOCATION_H
95+#include <cstdint>
96 #include <vector>
97 #include <ostream>
98 #include <memory>
99diff --git a/include/LIEF/PE/signature/attributes/PKCS9AtSequenceNumber.hpp b/include/LIEF/PE/signature/attributes/PKCS9AtSequenceNumber.hpp
100index a89901fa..32db1470 100644
101--- a/include/LIEF/PE/signature/attributes/PKCS9AtSequenceNumber.hpp
102+++ b/include/LIEF/PE/signature/attributes/PKCS9AtSequenceNumber.hpp
103@@ -15,6 +15,7 @@
104 */
105 #ifndef LIEF_PE_ATTRIBUTES_PKCS9_AT_SEQUENCE_NUMBER_H
106 #define LIEF_PE_ATTRIBUTES_PKCS9_AT_SEQUENCE_NUMBER_H
107+#include <cstdint>
108
109 #include "LIEF/visibility.h"
110 #include "LIEF/PE/signature/Attribute.hpp"
111diff --git a/include/LIEF/PE/signature/attributes/SpcRelaxedPeMarkerCheck.hpp b/include/LIEF/PE/signature/attributes/SpcRelaxedPeMarkerCheck.hpp
112index f84fbcbf..5cce98b4 100644
113--- a/include/LIEF/PE/signature/attributes/SpcRelaxedPeMarkerCheck.hpp
114+++ b/include/LIEF/PE/signature/attributes/SpcRelaxedPeMarkerCheck.hpp
115@@ -15,6 +15,7 @@
116 */
117 #ifndef LIEF_PE_ATTRIBUTES_SPC_RELAXED_PE_MARKER_CHECK_H
118 #define LIEF_PE_ATTRIBUTES_SPC_RELAXED_PE_MARKER_CHECK_H
119+#include <cstdint>
120
121 #include "LIEF/visibility.h"
122 #include "LIEF/PE/signature/Attribute.hpp"
123diff --git a/src/MachO/TrieNode.hpp b/src/MachO/TrieNode.hpp
124index f6c411b8..6bdde9ec 100644
125--- a/src/MachO/TrieNode.hpp
126+++ b/src/MachO/TrieNode.hpp
127@@ -15,6 +15,7 @@
128 */
129 #ifndef LIEF_MACHO_TRIE_NODE_H_
130 #define LIEF_MACHO_TRIE_NODE_H_
131+#include <cstdint>
132 #include <string>
133 #include <vector>
134 #include <memory>
diff --git a/meta-python/recipes-devtools/python/python3-lief_0.16.3.bb b/meta-python/recipes-devtools/python/python3-lief_0.16.4.bb
index 925baa655c..294f8fd1ad 100644
--- a/meta-python/recipes-devtools/python/python3-lief_0.16.3.bb
+++ b/meta-python/recipes-devtools/python/python3-lief_0.16.4.bb
@@ -9,8 +9,10 @@ SRC_URI = " \
9 git://github.com/lief-project/LIEF.git;protocol=https;branch=main \ 9 git://github.com/lief-project/LIEF.git;protocol=https;branch=main \
10 file://0001-build-requirements.txt-Allow-newer-versions.patch \ 10 file://0001-build-requirements.txt-Allow-newer-versions.patch \
11 file://0002-api-python-config-default.toml-Debug.patch \ 11 file://0002-api-python-config-default.toml-Debug.patch \
12 file://0001-Add-cstdio-include.patch \
12" 13"
13SRCREV = "646af9f6ced8e827916648f26617998de834db78" 14SRCREV = "1e9b12bd14cbe087d52355b8b9af578f1b04d8ca"
15
14PV .= "+git" 16PV .= "+git"
15 17
16S = "${WORKDIR}/git" 18S = "${WORKDIR}/git"
@@ -27,6 +29,7 @@ DEPENDS += "\
27 python3-pydantic-native \ 29 python3-pydantic-native \
28 ninja-native \ 30 ninja-native \
29 ccache-native \ 31 ccache-native \
32 python3-typing-inspection \
30" 33"
31# https://github.com/lief-project/LIEF/commit/3def579f75965aa19c021d840a759bce2afc0a31#r152197203 34# https://github.com/lief-project/LIEF/commit/3def579f75965aa19c021d840a759bce2afc0a31#r152197203
32COMPATIBLE_HOST:x86 = "null" 35COMPATIBLE_HOST:x86 = "null"