summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorBelal, Awais <Awais_Belal@mentor.com>2014-12-12 12:21:51 +0500
committerMartin Jansa <Martin.Jansa@gmail.com>2014-12-19 20:10:56 +0100
commitaf8ff37714da2f9b231014bbf1d5be30536ddc1d (patch)
tree8daea4d071d2567a6d92694b601e0cad77aa2a8b
parente2f8425e2d806e511489694ec338c6299eddcddd (diff)
downloadmeta-openembedded-af8ff37714da2f9b231014bbf1d5be30536ddc1d.tar.gz
iperf: fix out of tree configuration
The configure step uses a package header to check for support of types/declares, this package header encapsulates all the required system headers for providing the needed resources. When configured from an out of tree directory the package header is not found due to the hard path. We now make the path for package header relative to 'srcdir' so it is found appropriately. Signed-off-by: Awais Belal <awais_belal@mentor.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
-rw-r--r--meta-oe/recipes-benchmark/iperf/iperf-2.0.5/0001-fix-out-of-tree-config.patch52
-rw-r--r--meta-oe/recipes-benchmark/iperf/iperf_2.0.5.bb1
2 files changed, 53 insertions, 0 deletions
diff --git a/meta-oe/recipes-benchmark/iperf/iperf-2.0.5/0001-fix-out-of-tree-config.patch b/meta-oe/recipes-benchmark/iperf/iperf-2.0.5/0001-fix-out-of-tree-config.patch
new file mode 100644
index 000000000..e8a029790
--- /dev/null
+++ b/meta-oe/recipes-benchmark/iperf/iperf-2.0.5/0001-fix-out-of-tree-config.patch
@@ -0,0 +1,52 @@
1iperf: fix out of tree configuration
2
3The configure step uses a package header to check for support of types/declares,
4this package header encapsulates all the required system header for providing
5the needed resources. When configured from an out of tree directory the package
6header is not found due to the hard path.
7We now make the path for package header relative to our 'srcdir' so it is
8found appropriately.
9
10Signed-off-by: Awais Belal <awais_belal@mentor.com>
11---
12diff --git a/configure.ac b/configure.ac
13index 2b3fd20..d420f9e 100644
14--- a/configure.ac
15+++ b/configure.ac
16@@ -176,8 +176,8 @@ dnl Check for system services
17
18 dnl check for multicast
19 if test "$ac_cv_multicast" != no; then
20- AC_CHECK_TYPES(struct ip_mreq,,,[#include "compat/headers_slim.h"])
21- AC_CHECK_DECLS(IP_ADD_MEMBERSHIP,,,[#include "compat/headers_slim.h"])
22+ AC_CHECK_TYPES(struct ip_mreq,,,[#include "${srcdir}/compat/headers_slim.h"])
23+ AC_CHECK_DECLS(IP_ADD_MEMBERSHIP,,,[#include "${srcdir}/compat/headers_slim.h"])
24 AC_MSG_CHECKING(for multicast support)
25 ac_cv_multicast=no
26 if test "$ac_cv_have_decl_IP_ADD_MEMBERSHIP" = yes; then
27@@ -193,9 +193,9 @@ fi
28
29 dnl check for IPv6
30 if test "$ac_cv_have_ipv6" != no; then
31- AC_CHECK_TYPES(struct sockaddr_storage,,,[#include "compat/headers_slim.h"])
32- AC_CHECK_TYPES(struct sockaddr_in6,,,[#include "compat/headers_slim.h"])
33- AC_CHECK_DECLS(AF_INET6,,,[#include "compat/headers_slim.h"])
34+ AC_CHECK_TYPES(struct sockaddr_storage,,,[#include "${srcdir}/compat/headers_slim.h"])
35+ AC_CHECK_TYPES(struct sockaddr_in6,,,[#include "${srcdir}/compat/headers_slim.h"])
36+ AC_CHECK_DECLS(AF_INET6,,,[#include "${srcdir}/compat/headers_slim.h"])
37 AC_MSG_CHECKING(for IPv6 headers and structures)
38 ac_cv_have_ipv6=no
39 if test "$ac_cv_type_struct_sockaddr_storage" = yes; then
40@@ -211,9 +211,9 @@ fi
41
42 if test "$ac_cv_have_ipv6" = yes; then
43 if test "$ac_cv_multicast" = yes; then
44- AC_CHECK_TYPES(struct ipv6_mreq,,,[#include "compat/headers_slim.h"])
45- AC_CHECK_DECLS(IPV6_ADD_MEMBERSHIP,,,[#include "compat/headers_slim.h"])
46- AC_CHECK_DECLS(IPV6_MULTICAST_HOPS,,,[#include "compat/headers_slim.h"])
47+ AC_CHECK_TYPES(struct ipv6_mreq,,,[#include "${srcdir}/compat/headers_slim.h"])
48+ AC_CHECK_DECLS(IPV6_ADD_MEMBERSHIP,,,[#include "${srcdir}/compat/headers_slim.h"])
49+ AC_CHECK_DECLS(IPV6_MULTICAST_HOPS,,,[#include "${srcdir}/compat/headers_slim.h"])
50 AC_MSG_CHECKING(for IPv6 multicast support)
51 ac_cv_have_ipv6_multicast=no
52 if test "$ac_cv_type_struct_ipv6_mreq" = yes; then
diff --git a/meta-oe/recipes-benchmark/iperf/iperf_2.0.5.bb b/meta-oe/recipes-benchmark/iperf/iperf_2.0.5.bb
index 1bd554bc9..20adc0db9 100644
--- a/meta-oe/recipes-benchmark/iperf/iperf_2.0.5.bb
+++ b/meta-oe/recipes-benchmark/iperf/iperf_2.0.5.bb
@@ -6,6 +6,7 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=e8478eae9f479e39bc34975193360298"
6 6
7SRC_URI = " ${SOURCEFORGE_MIRROR}/iperf/${BP}.tar.gz \ 7SRC_URI = " ${SOURCEFORGE_MIRROR}/iperf/${BP}.tar.gz \
8 file://iperf-2.0.5_ManPage.patch \ 8 file://iperf-2.0.5_ManPage.patch \
9 file://0001-fix-out-of-tree-config.patch \
9 " 10 "
10 11
11SRC_URI[md5sum] = "44b5536b67719f4250faed632a3cd016" 12SRC_URI[md5sum] = "44b5536b67719f4250faed632a3cd016"