summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorDerek Straka <derek@asterius.io>2025-01-10 22:31:31 +0000
committerKhem Raj <raj.khem@gmail.com>2025-01-10 16:53:47 -0800
commitaf70edb33aa1d31afea32231cd7802d83e2f868f (patch)
tree242b0e6b67179ef2e3e402b3137e7d8024ba26a6
parent38e61c5c8e866990dcba7242b8e8857a3a25128c (diff)
downloadmeta-openembedded-af70edb33aa1d31afea32231cd7802d83e2f868f.tar.gz
python3-simpleeval: update recipe to use the ptest-python-pytest class
Signed-off-by: Derek Straka <derek@asterius.io> Signed-off-by: Khem Raj <raj.khem@gmail.com>
-rw-r--r--meta-python/recipes-devtools/python/python3-simpleeval/run-ptest3
-rw-r--r--meta-python/recipes-devtools/python/python3-simpleeval_1.0.3.bb11
2 files changed, 2 insertions, 12 deletions
diff --git a/meta-python/recipes-devtools/python/python3-simpleeval/run-ptest b/meta-python/recipes-devtools/python/python3-simpleeval/run-ptest
deleted file mode 100644
index 8d2017d39c..0000000000
--- a/meta-python/recipes-devtools/python/python3-simpleeval/run-ptest
+++ /dev/null
@@ -1,3 +0,0 @@
1#!/bin/sh
2
3pytest --automake
diff --git a/meta-python/recipes-devtools/python/python3-simpleeval_1.0.3.bb b/meta-python/recipes-devtools/python/python3-simpleeval_1.0.3.bb
index 4537645c73..b4dc82bfb3 100644
--- a/meta-python/recipes-devtools/python/python3-simpleeval_1.0.3.bb
+++ b/meta-python/recipes-devtools/python/python3-simpleeval_1.0.3.bb
@@ -5,21 +5,14 @@ LIC_FILES_CHKSUM = "file://LICENCE;md5=83843c8f0f3beb18af2f282faecbdebe"
5 5
6SRC_URI[sha256sum] = "67bbf246040ac3b57c29cf048657b9cf31d4e7b9d6659684daa08ca8f1e45829" 6SRC_URI[sha256sum] = "67bbf246040ac3b57c29cf048657b9cf31d4e7b9d6659684daa08ca8f1e45829"
7 7
8inherit pypi python_setuptools_build_meta python_hatchling ptest 8inherit pypi python_setuptools_build_meta python_hatchling ptest-python-pytest
9 9
10BBCLASSEXTEND = "native nativesdk" 10BBCLASSEXTEND = "native nativesdk"
11 11
12SRC_URI += "file://run-ptest"
13
14RDEPENDS:${PN} += " \ 12RDEPENDS:${PN} += " \
15 python3-math \ 13 python3-math \
16" 14"
17 15
18RDEPENDS:${PN}-ptest += " \ 16do_install_ptest:append() {
19 python3-pytest \
20 python3-unittest-automake-output \
21"
22
23do_install_ptest() {
24 cp -f ${S}/test_simpleeval.py ${D}${PTEST_PATH}/ 17 cp -f ${S}/test_simpleeval.py ${D}${PTEST_PATH}/
25} 18}