summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMing Liu <peter.x.liu@external.atlascopco.com>2016-09-27 08:44:48 +0200
committerMartin Jansa <Martin.Jansa@gmail.com>2016-10-03 19:19:57 +0200
commitaba02d72d6985a2921e55f67e4898353505afc7c (patch)
tree8678118cf0a46662e6bd1f7a09b399c6ecb7cc5d
parent08b315e1f564203666ecde95190f59547375b491 (diff)
downloadmeta-openembedded-aba02d72d6985a2921e55f67e4898353505afc7c.tar.gz
libnet: fixes musl libc build
This patch is back ported from libnet upstream. Signed-off-by: Ming Liu <peter.x.liu@external.atlascopco.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
-rw-r--r--meta-oe/recipes-connectivity/libnet/libnet/0001-Support-musl-libc-remove-support-for-glibc-2.1.patch58
-rw-r--r--meta-oe/recipes-connectivity/libnet/libnet_1.2-rc3.bb4
2 files changed, 61 insertions, 1 deletions
diff --git a/meta-oe/recipes-connectivity/libnet/libnet/0001-Support-musl-libc-remove-support-for-glibc-2.1.patch b/meta-oe/recipes-connectivity/libnet/libnet/0001-Support-musl-libc-remove-support-for-glibc-2.1.patch
new file mode 100644
index 000000000..98008dba9
--- /dev/null
+++ b/meta-oe/recipes-connectivity/libnet/libnet/0001-Support-musl-libc-remove-support-for-glibc-2.1.patch
@@ -0,0 +1,58 @@
1From ffd7fab744a9ad2893169a8fb6244074604d5d0d Mon Sep 17 00:00:00 2001
2From: rofl0r <retnyg@gmx.net>
3Date: Tue, 12 Aug 2014 21:51:39 +0200
4Subject: [PATCH] Support musl libc, remove support for glibc < 2.1
5
6Upstream-Status: Backport
7
8The workarounds for glibc < 2.1 (was released february 1999) break the
9build with musl libc.
10
11It is very unlikely that 2.0 or earlier is still in use, and if so,
121) that's a big security hole
132) code wouldnt compile anyway since noone tested build in the last decade
143) user of it wouldn't expect anyway to get bleeding edge sw built on it,
15 so he would just use the latest version that works for him.
16
17Closes #52
18
19Signed-off-by: rofl0r <retnyg@gmx.net>
20Signed-off-by: Ming Liu <peter.x.liu@external.atlascopco.com>
21---
22 libnet/src/libnet_link_linux.c | 11 -----------
23 1 file changed, 11 deletions(-)
24
25diff --git a/src/libnet_link_linux.c b/src/libnet_link_linux.c
26index 054458d..3c6df3c 100644
27--- a/src/libnet_link_linux.c
28+++ b/src/libnet_link_linux.c
29@@ -30,26 +30,15 @@
30 #include <sys/time.h>
31
32 #include <net/if.h>
33-#if (__GLIBC__)
34 #include <netinet/if_ether.h>
35 #include <net/if_arp.h>
36-#else
37-#include <linux/if_arp.h>
38-#include <linux/if_ether.h>
39-#endif
40
41 #if (HAVE_PACKET_SOCKET)
42 #ifndef SOL_PACKET
43 #define SOL_PACKET 263
44 #endif /* SOL_PACKET */
45-#if __GLIBC__ >= 2 && __GLIBC_MINOR >= 1
46 #include <netpacket/packet.h>
47 #include <net/ethernet.h> /* the L2 protocols */
48-#else
49-#include <asm/types.h>
50-#include <linux/if_packet.h>
51-#include <linux/if_ether.h> /* The L2 protocols */
52-#endif
53 #endif /* HAVE_PACKET_SOCKET */
54
55 #include "../include/libnet.h"
56--
571.9.1
58
diff --git a/meta-oe/recipes-connectivity/libnet/libnet_1.2-rc3.bb b/meta-oe/recipes-connectivity/libnet/libnet_1.2-rc3.bb
index a558e8096..dfc204960 100644
--- a/meta-oe/recipes-connectivity/libnet/libnet_1.2-rc3.bb
+++ b/meta-oe/recipes-connectivity/libnet/libnet_1.2-rc3.bb
@@ -8,7 +8,9 @@ DEPENDS = "libpcap"
8# There are major API changes beween libnet v1.0 and libnet v1.1 8# There are major API changes beween libnet v1.0 and libnet v1.1
9PROVIDES = "libnet-1.2rc2" 9PROVIDES = "libnet-1.2rc2"
10 10
11SRC_URI = "${SOURCEFORGE_MIRROR}/libnet-dev/${BPN}-${PV}.tar.gz" 11SRC_URI = "${SOURCEFORGE_MIRROR}/libnet-dev/${BPN}-${PV}.tar.gz \
12 file://0001-Support-musl-libc-remove-support-for-glibc-2.1.patch \
13 "
12 14
13SRC_URI[md5sum] = "f051e6e5bdecddb90f77c701c2ca1804" 15SRC_URI[md5sum] = "f051e6e5bdecddb90f77c701c2ca1804"
14SRC_URI[sha256sum] = "72c380785ad44183005e654b47cc12485ee0228d7fa6b0a87109ff7614be4a63" 16SRC_URI[sha256sum] = "72c380785ad44183005e654b47cc12485ee0228d7fa6b0a87109ff7614be4a63"