summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMartin Jansa <Martin.Jansa@gmail.com>2012-08-13 15:27:52 +0200
committerMartin Jansa <Martin.Jansa@gmail.com>2012-08-20 09:58:08 +0200
commitab19e33a9d9c77074def6e74ac72e84439cd0bee (patch)
tree68e8e91b89418f910ce4c4eff3b20d06ba548871
parent7c28fa0c71de1b487d05695b8401333140bc76b5 (diff)
downloadmeta-openembedded-ab19e33a9d9c77074def6e74ac72e84439cd0bee.tar.gz
python-efl: introduce recipes for 1.6.99-alpha release and add negative D_P to svn recipes
Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
-rw-r--r--meta-efl/conf/distro/include/efl-from-svn-recipes.inc7
-rw-r--r--meta-efl/recipes-devtools/python/python-ecore.inc5
-rw-r--r--meta-efl/recipes-devtools/python/python-ecore_1.6.99-alpha.bb6
-rw-r--r--meta-efl/recipes-devtools/python/python-ecore_svn.bb11
-rw-r--r--meta-efl/recipes-devtools/python/python-edbus.inc6
-rw-r--r--meta-efl/recipes-devtools/python/python-edbus_1.6.99-alpha.bb6
-rw-r--r--meta-efl/recipes-devtools/python/python-edbus_svn.bb12
-rw-r--r--meta-efl/recipes-devtools/python/python-edje.inc5
-rw-r--r--meta-efl/recipes-devtools/python/python-edje_1.6.99-alpha.bb7
-rw-r--r--meta-efl/recipes-devtools/python/python-edje_svn.bb11
-rw-r--r--meta-efl/recipes-devtools/python/python-efl.inc9
-rw-r--r--meta-efl/recipes-devtools/python/python-elementary.inc5
-rw-r--r--meta-efl/recipes-devtools/python/python-elementary_1.6.99-alpha.bb6
-rw-r--r--meta-efl/recipes-devtools/python/python-elementary_svn.bb11
-rw-r--r--meta-efl/recipes-devtools/python/python-emotion.inc5
-rw-r--r--meta-efl/recipes-devtools/python/python-emotion_1.6.99-alpha.bb6
-rw-r--r--meta-efl/recipes-devtools/python/python-emotion_svn.bb11
-rw-r--r--meta-efl/recipes-devtools/python/python-evas.inc4
-rw-r--r--meta-efl/recipes-devtools/python/python-evas_1.6.99-alpha.bb6
-rw-r--r--meta-efl/recipes-devtools/python/python-evas_svn.bb10
20 files changed, 116 insertions, 33 deletions
diff --git a/meta-efl/conf/distro/include/efl-from-svn-recipes.inc b/meta-efl/conf/distro/include/efl-from-svn-recipes.inc
index b703b4190..4625b1972 100644
--- a/meta-efl/conf/distro/include/efl-from-svn-recipes.inc
+++ b/meta-efl/conf/distro/include/efl-from-svn-recipes.inc
@@ -29,3 +29,10 @@ PREFERRED_VERSION_eio-native ?= "${EFL_PREFERRED_VERSION}"
29PREFERRED_VERSION_emotion ?= "${EFL_PREFERRED_VERSION}" 29PREFERRED_VERSION_emotion ?= "${EFL_PREFERRED_VERSION}"
30PREFERRED_VERSION_ethumb ?= "${EFL_PREFERRED_VERSION}" 30PREFERRED_VERSION_ethumb ?= "${EFL_PREFERRED_VERSION}"
31PREFERRED_VERSION_elementary ?= "${EFL_PREFERRED_VERSION}" 31PREFERRED_VERSION_elementary ?= "${EFL_PREFERRED_VERSION}"
32
33PREFERRED_VERSION_python-elementary ?= "${EFL_PREFERRED_VERSION}"
34PREFERRED_VERSION_python-ecore ?= "${EFL_PREFERRED_VERSION}"
35PREFERRED_VERSION_python-edbus ?= "${EFL_PREFERRED_VERSION}"
36PREFERRED_VERSION_python-edje ?= "${EFL_PREFERRED_VERSION}"
37PREFERRED_VERSION_python-emotion ?= "${EFL_PREFERRED_VERSION}"
38PREFERRED_VERSION_python-evas ?= "${EFL_PREFERRED_VERSION}"
diff --git a/meta-efl/recipes-devtools/python/python-ecore.inc b/meta-efl/recipes-devtools/python/python-ecore.inc
new file mode 100644
index 000000000..79aaeeccd
--- /dev/null
+++ b/meta-efl/recipes-devtools/python/python-ecore.inc
@@ -0,0 +1,5 @@
1require python-efl.inc
2LICENSE = "LGPLv2.1"
3LIC_FILES_CHKSUM = "file://COPYING;md5=fbc093901857fcd118f065f900982c24"
4DEPENDS += "python-evas ecore"
5RDEPENDS_${PN} += "python-evas"
diff --git a/meta-efl/recipes-devtools/python/python-ecore_1.6.99-alpha.bb b/meta-efl/recipes-devtools/python/python-ecore_1.6.99-alpha.bb
new file mode 100644
index 000000000..a76c44f5c
--- /dev/null
+++ b/meta-efl/recipes-devtools/python/python-ecore_1.6.99-alpha.bb
@@ -0,0 +1,6 @@
1require ${BPN}.inc
2PR = "${INC_PR}.0"
3SRCVER = "1.7.0-alpha"
4
5SRC_URI[md5sum] = "86ba753726881b9bfcaa0fdc0827cd1e"
6SRC_URI[sha256sum] = "b47a155c0bfad6fad68bc0f925c54a8736a61ca72f6a71bd5138ea3298a35c95"
diff --git a/meta-efl/recipes-devtools/python/python-ecore_svn.bb b/meta-efl/recipes-devtools/python/python-ecore_svn.bb
index a6ec5e604..a0298e859 100644
--- a/meta-efl/recipes-devtools/python/python-ecore_svn.bb
+++ b/meta-efl/recipes-devtools/python/python-ecore_svn.bb
@@ -1,7 +1,8 @@
1require python-efl.inc 1require ${BPN}.inc
2LICENSE = "LGPLv2.1"
3LIC_FILES_CHKSUM = "file://COPYING;md5=fbc093901857fcd118f065f900982c24"
4PR = "${INC_PR}.0" 2PR = "${INC_PR}.0"
5SRCREV = "${EFL_SRCREV}" 3SRCREV = "${EFL_SRCREV}"
6DEPENDS += "python-evas ecore" 4PV = "1.6.99+svnr${SRCPV}"
7RDEPENDS_${PN} += "python-evas" 5DEFAULT_PREFERENCE = "-1"
6
7SRC_URI = "${E_SVN}/trunk/BINDINGS/python;module=${SRCNAME};protocol=http"
8S = "${WORKDIR}/${SRCNAME}"
diff --git a/meta-efl/recipes-devtools/python/python-edbus.inc b/meta-efl/recipes-devtools/python/python-edbus.inc
new file mode 100644
index 000000000..86ae77343
--- /dev/null
+++ b/meta-efl/recipes-devtools/python/python-edbus.inc
@@ -0,0 +1,6 @@
1require python-efl.inc
2LICENSE = "LGPLv2.1"
3LIC_FILES_CHKSUM = "file://COPYING;md5=fbc093901857fcd118f065f900982c24"
4DEPENDS += "edbus python-dbus"
5RDEPENDS_${PN} += "python-dbus"
6SRCNAME = "python-e_dbus"
diff --git a/meta-efl/recipes-devtools/python/python-edbus_1.6.99-alpha.bb b/meta-efl/recipes-devtools/python/python-edbus_1.6.99-alpha.bb
new file mode 100644
index 000000000..c643141ef
--- /dev/null
+++ b/meta-efl/recipes-devtools/python/python-edbus_1.6.99-alpha.bb
@@ -0,0 +1,6 @@
1require ${BPN}.inc
2PR = "${INC_PR}.0"
3SRCVER = "1.7.0-alpha"
4
5SRC_URI[md5sum] = "bd68e260e1a23fc14313afa48e70bebd"
6SRC_URI[sha256sum] = "63e823c8366f293db1940524ac76d6f91109a7202cf38ad6407d414d15e09aca"
diff --git a/meta-efl/recipes-devtools/python/python-edbus_svn.bb b/meta-efl/recipes-devtools/python/python-edbus_svn.bb
index 518f7c210..a0298e859 100644
--- a/meta-efl/recipes-devtools/python/python-edbus_svn.bb
+++ b/meta-efl/recipes-devtools/python/python-edbus_svn.bb
@@ -1,8 +1,8 @@
1require python-efl.inc 1require ${BPN}.inc
2LICENSE = "LGPLv2.1"
3LIC_FILES_CHKSUM = "file://COPYING;md5=fbc093901857fcd118f065f900982c24"
4PR = "${INC_PR}.0" 2PR = "${INC_PR}.0"
5SRCREV = "${EFL_SRCREV}" 3SRCREV = "${EFL_SRCREV}"
6DEPENDS += "edbus python-dbus" 4PV = "1.6.99+svnr${SRCPV}"
7RDEPENDS_${PN} += "python-dbus" 5DEFAULT_PREFERENCE = "-1"
8SRCNAME = "python-e_dbus" 6
7SRC_URI = "${E_SVN}/trunk/BINDINGS/python;module=${SRCNAME};protocol=http"
8S = "${WORKDIR}/${SRCNAME}"
diff --git a/meta-efl/recipes-devtools/python/python-edje.inc b/meta-efl/recipes-devtools/python/python-edje.inc
new file mode 100644
index 000000000..473b92e87
--- /dev/null
+++ b/meta-efl/recipes-devtools/python/python-edje.inc
@@ -0,0 +1,5 @@
1require python-efl.inc
2LICENSE = "LGPLv2.1"
3LIC_FILES_CHKSUM = "file://COPYING;md5=fbc093901857fcd118f065f900982c24"
4DEPENDS += "edje python-evas evas"
5RDEPENDS_${PN} += "python-evas"
diff --git a/meta-efl/recipes-devtools/python/python-edje_1.6.99-alpha.bb b/meta-efl/recipes-devtools/python/python-edje_1.6.99-alpha.bb
new file mode 100644
index 000000000..1d7bb069f
--- /dev/null
+++ b/meta-efl/recipes-devtools/python/python-edje_1.6.99-alpha.bb
@@ -0,0 +1,7 @@
1require ${BPN}.inc
2PR = "${INC_PR}.0"
3SRCVER = "1.7.0-alpha"
4SRC_URI += "file://0001-fix-unicode-conversion.patch"
5
6SRC_URI[md5sum] = "fbe5105abb5b2d3de71302ff3973945a"
7SRC_URI[sha256sum] = "f5004d9b784b0ca37436daacff7f4f21bb3094b9fdfc5abc95f8e57e90ecb242"
diff --git a/meta-efl/recipes-devtools/python/python-edje_svn.bb b/meta-efl/recipes-devtools/python/python-edje_svn.bb
index a6b376c2c..3d392d0ff 100644
--- a/meta-efl/recipes-devtools/python/python-edje_svn.bb
+++ b/meta-efl/recipes-devtools/python/python-edje_svn.bb
@@ -1,9 +1,10 @@
1require python-efl.inc 1require ${BPN}.inc
2LICENSE = "LGPLv2.1"
3LIC_FILES_CHKSUM = "file://COPYING;md5=fbc093901857fcd118f065f900982c24"
4PR = "${INC_PR}.0" 2PR = "${INC_PR}.0"
5SRCREV = "${EFL_SRCREV}" 3SRCREV = "${EFL_SRCREV}"
6DEPENDS += "edje python-evas evas" 4PV = "1.6.99+svnr${SRCPV}"
7RDEPENDS_${PN} += "python-evas" 5DEFAULT_PREFERENCE = "-1"
6
7SRC_URI = "${E_SVN}/trunk/BINDINGS/python;module=${SRCNAME};protocol=http"
8S = "${WORKDIR}/${SRCNAME}"
8 9
9SRC_URI += "file://0001-fix-unicode-conversion.patch" 10SRC_URI += "file://0001-fix-unicode-conversion.patch"
diff --git a/meta-efl/recipes-devtools/python/python-efl.inc b/meta-efl/recipes-devtools/python/python-efl.inc
index 498c3be65..77d4114ca 100644
--- a/meta-efl/recipes-devtools/python/python-efl.inc
+++ b/meta-efl/recipes-devtools/python/python-efl.inc
@@ -6,7 +6,6 @@ AUTHOR = "Gustavo Sverzut Barbieri <barbieri@gmail.com>"
6# the extension modules. 6# the extension modules.
7DEPENDS = "python-cython-native python-pyrex-native python-numeric eina" 7DEPENDS = "python-cython-native python-pyrex-native python-numeric eina"
8RDEPENDS_${PN} += "python-lang" 8RDEPENDS_${PN} += "python-lang"
9PV = "1.6.99+svnr${SRCPV}"
10INC_PR = "r0" 9INC_PR = "r0"
11 10
12# necessary to let the call for python-config succeed 11# necessary to let the call for python-config succeed
@@ -15,8 +14,12 @@ export HOST_SYS
15 14
16inherit e-base autotools pkgconfig distutils-base 15inherit e-base autotools pkgconfig distutils-base
17 16
18SRC_URI = "${E_SVN}/trunk/BINDINGS/python;module=${SRCNAME};protocol=http" 17SRCVER = "${PV}"
19S = "${WORKDIR}/${SRCNAME}" 18
19SRC_URI = "\
20 ${E_MIRROR}/BINDINGS/python/${SRCNAME}-${SRCVER}.tar.bz2 \
21"
22S = "${WORKDIR}/${SRCNAME}-${SRCVER}"
20 23
21 24
22do_configure_prepend() { 25do_configure_prepend() {
diff --git a/meta-efl/recipes-devtools/python/python-elementary.inc b/meta-efl/recipes-devtools/python/python-elementary.inc
new file mode 100644
index 000000000..3f1d123c3
--- /dev/null
+++ b/meta-efl/recipes-devtools/python/python-elementary.inc
@@ -0,0 +1,5 @@
1require python-efl.inc
2LICENSE = "LGPLv3"
3LIC_FILES_CHKSUM = "file://COPYING;md5=6a6a8e020838b23406c81b19c1d46df6"
4DEPENDS += "elementary python-evas"
5RDEPENDS_${PN} += "python-evas python-ecore python-edje"
diff --git a/meta-efl/recipes-devtools/python/python-elementary_1.6.99-alpha.bb b/meta-efl/recipes-devtools/python/python-elementary_1.6.99-alpha.bb
new file mode 100644
index 000000000..8ed363e50
--- /dev/null
+++ b/meta-efl/recipes-devtools/python/python-elementary_1.6.99-alpha.bb
@@ -0,0 +1,6 @@
1require ${BPN}.inc
2PR = "${INC_PR}.0"
3SRCVER = "1.7.0-alpha"
4
5SRC_URI[md5sum] = "bad3bd52e79aeea1ee9ffa0ab8a54855"
6SRC_URI[sha256sum] = "32ded2fb4e66aa543ae9274076d031f8465167a0cc1af3fcd26bcda85b2e7094"
diff --git a/meta-efl/recipes-devtools/python/python-elementary_svn.bb b/meta-efl/recipes-devtools/python/python-elementary_svn.bb
index ffb6d5e7c..a0298e859 100644
--- a/meta-efl/recipes-devtools/python/python-elementary_svn.bb
+++ b/meta-efl/recipes-devtools/python/python-elementary_svn.bb
@@ -1,7 +1,8 @@
1require python-efl.inc 1require ${BPN}.inc
2LICENSE = "LGPLv3"
3LIC_FILES_CHKSUM = "file://COPYING;md5=6a6a8e020838b23406c81b19c1d46df6"
4PR = "${INC_PR}.0" 2PR = "${INC_PR}.0"
5SRCREV = "${EFL_SRCREV}" 3SRCREV = "${EFL_SRCREV}"
6DEPENDS += "elementary python-evas" 4PV = "1.6.99+svnr${SRCPV}"
7RDEPENDS_${PN} += "python-evas python-ecore python-edje" 5DEFAULT_PREFERENCE = "-1"
6
7SRC_URI = "${E_SVN}/trunk/BINDINGS/python;module=${SRCNAME};protocol=http"
8S = "${WORKDIR}/${SRCNAME}"
diff --git a/meta-efl/recipes-devtools/python/python-emotion.inc b/meta-efl/recipes-devtools/python/python-emotion.inc
new file mode 100644
index 000000000..ac64676f0
--- /dev/null
+++ b/meta-efl/recipes-devtools/python/python-emotion.inc
@@ -0,0 +1,5 @@
1require python-efl.inc
2LICENSE = "LGPLv2.1"
3LIC_FILES_CHKSUM = "file://COPYING;md5=fbc093901857fcd118f065f900982c24"
4DEPENDS += "emotion python-evas"
5RDEPENDS_${PN} += "python-ecore"
diff --git a/meta-efl/recipes-devtools/python/python-emotion_1.6.99-alpha.bb b/meta-efl/recipes-devtools/python/python-emotion_1.6.99-alpha.bb
new file mode 100644
index 000000000..a2ad30377
--- /dev/null
+++ b/meta-efl/recipes-devtools/python/python-emotion_1.6.99-alpha.bb
@@ -0,0 +1,6 @@
1require ${BPN}.inc
2PR = "${INC_PR}.0"
3SRCVER = "1.7.0-alpha"
4
5SRC_URI[md5sum] = "34249ce9ee6602205ede16e311c2712c"
6SRC_URI[sha256sum] = "f121a801c213d5014cde17df49107407bd60be362f98bab3530c14c9c8a54e03"
diff --git a/meta-efl/recipes-devtools/python/python-emotion_svn.bb b/meta-efl/recipes-devtools/python/python-emotion_svn.bb
index 89002c3b7..a0298e859 100644
--- a/meta-efl/recipes-devtools/python/python-emotion_svn.bb
+++ b/meta-efl/recipes-devtools/python/python-emotion_svn.bb
@@ -1,7 +1,8 @@
1require python-efl.inc 1require ${BPN}.inc
2LICENSE = "LGPLv2.1"
3LIC_FILES_CHKSUM = "file://COPYING;md5=fbc093901857fcd118f065f900982c24"
4PR = "${INC_PR}.0" 2PR = "${INC_PR}.0"
5SRCREV = "${EFL_SRCREV}" 3SRCREV = "${EFL_SRCREV}"
6DEPENDS += "emotion python-evas" 4PV = "1.6.99+svnr${SRCPV}"
7RDEPENDS_${PN} += "python-ecore" 5DEFAULT_PREFERENCE = "-1"
6
7SRC_URI = "${E_SVN}/trunk/BINDINGS/python;module=${SRCNAME};protocol=http"
8S = "${WORKDIR}/${SRCNAME}"
diff --git a/meta-efl/recipes-devtools/python/python-evas.inc b/meta-efl/recipes-devtools/python/python-evas.inc
new file mode 100644
index 000000000..3211b1441
--- /dev/null
+++ b/meta-efl/recipes-devtools/python/python-evas.inc
@@ -0,0 +1,4 @@
1require python-efl.inc
2LICENSE = "LGPLv2.1"
3LIC_FILES_CHKSUM = "file://COPYING;md5=fbc093901857fcd118f065f900982c24"
4DEPENDS += "evas"
diff --git a/meta-efl/recipes-devtools/python/python-evas_1.6.99-alpha.bb b/meta-efl/recipes-devtools/python/python-evas_1.6.99-alpha.bb
new file mode 100644
index 000000000..8fa82dad5
--- /dev/null
+++ b/meta-efl/recipes-devtools/python/python-evas_1.6.99-alpha.bb
@@ -0,0 +1,6 @@
1require ${BPN}.inc
2PR = "${INC_PR}.0"
3SRCVER = "1.7.0-alpha"
4
5SRC_URI[md5sum] = "c3e02d8e897508db2d6365dc3b83ae20"
6SRC_URI[sha256sum] = "5af43a770e0edaf01c679c8eaecef38c747c8801980f1d9423d040cf36220d76"
diff --git a/meta-efl/recipes-devtools/python/python-evas_svn.bb b/meta-efl/recipes-devtools/python/python-evas_svn.bb
index 79844beb5..a0298e859 100644
--- a/meta-efl/recipes-devtools/python/python-evas_svn.bb
+++ b/meta-efl/recipes-devtools/python/python-evas_svn.bb
@@ -1,6 +1,8 @@
1require python-efl.inc 1require ${BPN}.inc
2LICENSE = "LGPLv2.1"
3LIC_FILES_CHKSUM = "file://COPYING;md5=fbc093901857fcd118f065f900982c24"
4PR = "${INC_PR}.0" 2PR = "${INC_PR}.0"
5SRCREV = "${EFL_SRCREV}" 3SRCREV = "${EFL_SRCREV}"
6DEPENDS += "evas" 4PV = "1.6.99+svnr${SRCPV}"
5DEFAULT_PREFERENCE = "-1"
6
7SRC_URI = "${E_SVN}/trunk/BINDINGS/python;module=${SRCNAME};protocol=http"
8S = "${WORKDIR}/${SRCNAME}"