diff options
author | Lukas Bulwahn <lukas.bulwahn@oss.bmw-carit.de> | 2015-10-23 08:01:16 +0200 |
---|---|---|
committer | Martin Jansa <Martin.Jansa@gmail.com> | 2015-10-26 21:37:37 +0100 |
commit | aaf7140847f33b85dbe6382d4084e44e3247e34c (patch) | |
tree | 07d7ab7c0ed4360a49ca4bf41c23e37a448d03b7 | |
parent | 5b8bd1633263bf9a346453f50fde7d78690d1996 (diff) | |
download | meta-openembedded-aaf7140847f33b85dbe6382d4084e44e3247e34c.tar.gz |
libeigen: patch to install the find cmake script
This commit is needed for the pcl-ros 1.3.0 recipe in the
meta-ros layer, which detects the Eigen library with the provided
cmake script.
Signed-off-by: Lukas Bulwahn <lukas.bulwahn@oss.bmw-carit.de>
Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
-rw-r--r-- | meta-oe/recipes-support/libeigen/libeigen/0001-CMakeLists.txt-install-FindEigen3.cmake-script.patch | 28 | ||||
-rw-r--r-- | meta-oe/recipes-support/libeigen/libeigen_3.2.6.bb | 4 |
2 files changed, 31 insertions, 1 deletions
diff --git a/meta-oe/recipes-support/libeigen/libeigen/0001-CMakeLists.txt-install-FindEigen3.cmake-script.patch b/meta-oe/recipes-support/libeigen/libeigen/0001-CMakeLists.txt-install-FindEigen3.cmake-script.patch new file mode 100644 index 000000000..761dadbc3 --- /dev/null +++ b/meta-oe/recipes-support/libeigen/libeigen/0001-CMakeLists.txt-install-FindEigen3.cmake-script.patch | |||
@@ -0,0 +1,28 @@ | |||
1 | From fd8bc66efac1059c1068f804746b01b90177c333 Mon Sep 17 00:00:00 2001 | ||
2 | From: Lukas Bulwahn <lukas.bulwahn@oss.bmw-carit.de> | ||
3 | Date: Sun, 18 Oct 2015 16:52:25 +0200 | ||
4 | Subject: [PATCH] CMakeLists.txt: install FindEigen3.cmake script | ||
5 | |||
6 | Upstream-Status: Pending | ||
7 | |||
8 | Signed-off-by: Lukas Bulwahn <lukas.bulwahn@oss.bmw-carit.de> | ||
9 | --- | ||
10 | CMakeLists.txt | 2 ++ | ||
11 | 1 file changed, 2 insertions(+) | ||
12 | |||
13 | diff --git a/CMakeLists.txt b/CMakeLists.txt | ||
14 | index 76a11b9..ec6c6ea 100644 | ||
15 | --- a/CMakeLists.txt | ||
16 | +++ b/CMakeLists.txt | ||
17 | @@ -342,6 +342,8 @@ if(EIGEN_BUILD_PKGCONFIG) | ||
18 | ) | ||
19 | endif(EIGEN_BUILD_PKGCONFIG) | ||
20 | |||
21 | +install(FILES "${PROJECT_SOURCE_DIR}/cmake/FindEigen3.cmake" DESTINATION "${CMAKE_INSTALL_PREFIX}/share/cmake/Modules") | ||
22 | + | ||
23 | add_subdirectory(Eigen) | ||
24 | |||
25 | add_subdirectory(doc EXCLUDE_FROM_ALL) | ||
26 | -- | ||
27 | 1.9.3 | ||
28 | |||
diff --git a/meta-oe/recipes-support/libeigen/libeigen_3.2.6.bb b/meta-oe/recipes-support/libeigen/libeigen_3.2.6.bb index 4d7359756..89a25a9a3 100644 --- a/meta-oe/recipes-support/libeigen/libeigen_3.2.6.bb +++ b/meta-oe/recipes-support/libeigen/libeigen_3.2.6.bb | |||
@@ -4,7 +4,8 @@ HOMEPAGE = "http://eigen.tuxfamily.org/" | |||
4 | LICENSE = "MPL-2.0" | 4 | LICENSE = "MPL-2.0" |
5 | LIC_FILES_CHKSUM = "file://COPYING.MPL2;md5=815ca599c9df247a0c7f619bab123dad" | 5 | LIC_FILES_CHKSUM = "file://COPYING.MPL2;md5=815ca599c9df247a0c7f619bab123dad" |
6 | 6 | ||
7 | SRC_URI = "http://bitbucket.org/eigen/eigen/get/${PV}.tar.bz2" | 7 | SRC_URI = "http://bitbucket.org/eigen/eigen/get/${PV}.tar.bz2 \ |
8 | file://0001-CMakeLists.txt-install-FindEigen3.cmake-script.patch" | ||
8 | SRC_URI[md5sum] = "87274966745d2d3e7964fcc654d0a24b" | 9 | SRC_URI[md5sum] = "87274966745d2d3e7964fcc654d0a24b" |
9 | SRC_URI[sha256sum] = "8a3352f9a5361fe90e451a7305fb1896fc7f771dc16cc0edd8e6b157f52c343e" | 10 | SRC_URI[sha256sum] = "8a3352f9a5361fe90e451a7305fb1896fc7f771dc16cc0edd8e6b157f52c343e" |
10 | 11 | ||
@@ -15,6 +16,7 @@ inherit cmake | |||
15 | EXTRA_OECMAKE += "-Dpkg_config_libdir=${libdir}" | 16 | EXTRA_OECMAKE += "-Dpkg_config_libdir=${libdir}" |
16 | 17 | ||
17 | FILES_${PN} = "${includedir} ${libdir}" | 18 | FILES_${PN} = "${includedir} ${libdir}" |
19 | FILES_${PN}-dev = "${datadir}/cmake/Modules" | ||
18 | 20 | ||
19 | # ${PN} is empty so we need to tweak -dev and -dbg package dependencies | 21 | # ${PN} is empty so we need to tweak -dev and -dbg package dependencies |
20 | RDEPENDS_${PN}-dev = "" | 22 | RDEPENDS_${PN}-dev = "" |