summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorFabio Estevam <festevam@denx.de>2023-02-27 16:27:16 -0300
committerKhem Raj <raj.khem@gmail.com>2023-02-27 13:39:56 -0800
commita9b2d1303b6eada3119407e0a53c335b2e5a1b61 (patch)
tree00f6a5711f81cd18700f3e49c3cd1f6959b9d5f2
parentdafc2f5d213cbcd78f23357fa0e4cdd289840462 (diff)
downloadmeta-openembedded-a9b2d1303b6eada3119407e0a53c335b2e5a1b61.tar.gz
glmark2: Update to 2023.01
Update to the 2023.01 version: glmark2 2023.01 (20230119) ========================== * Add gbm-gl/glesv2 flavors for GBM offscreen rendering. * Add x11-gl-egl flavor that uses EGL under X11. * Implement SwapInterval 0 for the DRM backend. * Support multisampled configs in --visual-config. * Support explicitly specifying the config id in --visual-config. * Add CPU time and shader compilation time to available results. * Add --results to specify which kind of results to report. * Add --results-file to export results to XML or CSV. * Add --version command-line option. Remove 0001-libmatrix-Include-missing-utility-header.patch, which has been upstreamed and refresh 0002-run-dispmanx-fullscreen.patch to avoid fuzz warnings. Signed-off-by: Fabio Estevam <festevam@denx.de> Signed-off-by: Khem Raj <raj.khem@gmail.com>
-rw-r--r--meta-oe/recipes-benchmark/glmark2/files/0001-libmatrix-Include-missing-utility-header.patch24
-rw-r--r--meta-oe/recipes-benchmark/glmark2/files/0002-run-dispmanx-fullscreen.patch10
-rw-r--r--meta-oe/recipes-benchmark/glmark2/glmark2_git.bb5
3 files changed, 8 insertions, 31 deletions
diff --git a/meta-oe/recipes-benchmark/glmark2/files/0001-libmatrix-Include-missing-utility-header.patch b/meta-oe/recipes-benchmark/glmark2/files/0001-libmatrix-Include-missing-utility-header.patch
deleted file mode 100644
index 959a18e5e..000000000
--- a/meta-oe/recipes-benchmark/glmark2/files/0001-libmatrix-Include-missing-utility-header.patch
+++ /dev/null
@@ -1,24 +0,0 @@
1From 45cb02332b38b2059e7e44369c3d8684492a7def Mon Sep 17 00:00:00 2001
2From: Khem Raj <raj.khem@gmail.com>
3Date: Tue, 12 Apr 2022 11:41:41 -0700
4Subject: [PATCH] libmatrix: Include missing <utility> header
5
6Fixes build with gcc12
7| ../git/src/libmatrix/program.h:43:21: error: 'exchange' is not a member of 'std' | 43 | ready_(std::exchange(shader.ready_, false)), | | ^~~~~~~~
8
9Upstream-Status: Submitted [https://github.com/glmark2/glmark2/pull/174]
10Signed-off-by: Khem Raj <raj.khem@gmail.com>
11---
12 src/libmatrix/program.h | 1 +
13 1 file changed, 1 insertion(+)
14
15--- a/src/libmatrix/program.h
16+++ b/src/libmatrix/program.h
17@@ -13,6 +13,7 @@
18 #define PROGRAM_H_
19
20 #include <string>
21+#include <utility>
22 #include <vector>
23 #include <map>
24 #include "mat.h"
diff --git a/meta-oe/recipes-benchmark/glmark2/files/0002-run-dispmanx-fullscreen.patch b/meta-oe/recipes-benchmark/glmark2/files/0002-run-dispmanx-fullscreen.patch
index 0cb22fd56..05a074cf5 100644
--- a/meta-oe/recipes-benchmark/glmark2/files/0002-run-dispmanx-fullscreen.patch
+++ b/meta-oe/recipes-benchmark/glmark2/files/0002-run-dispmanx-fullscreen.patch
@@ -13,10 +13,10 @@ Signed-off-by: Trevor Woerner <twoerner@gmail.com>
13 1 file changed, 5 insertions(+) 13 1 file changed, 5 insertions(+)
14 14
15diff --git a/src/main.cpp b/src/main.cpp 15diff --git a/src/main.cpp b/src/main.cpp
16index 677962e..273a217 100644 16index d1077fe..d717cd4 100644
17--- a/src/main.cpp 17--- a/src/main.cpp
18+++ b/src/main.cpp 18+++ b/src/main.cpp
19@@ -164,6 +164,11 @@ main(int argc, char *argv[]) 19@@ -202,6 +202,11 @@ main(int argc, char *argv[])
20 Options::size = std::pair<int,int>(800, 600); 20 Options::size = std::pair<int,int>(800, 600);
21 } 21 }
22 22
@@ -26,5 +26,7 @@ index 677962e..273a217 100644
26+#endif 26+#endif
27+ 27+
28 // Create the canvas 28 // Create the canvas
29 #if GLMARK2_USE_X11 29 #if GLMARK2_USE_EGL
30 NativeStateX11 native_state; 30 GLStateEGL gl_state;
31--
322.25.1
diff --git a/meta-oe/recipes-benchmark/glmark2/glmark2_git.bb b/meta-oe/recipes-benchmark/glmark2/glmark2_git.bb
index 2a3e74f02..a2d5b152f 100644
--- a/meta-oe/recipes-benchmark/glmark2/glmark2_git.bb
+++ b/meta-oe/recipes-benchmark/glmark2/glmark2_git.bb
@@ -11,15 +11,14 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=d32239bcb673463ab874e80d47fae504 \
11DEPENDS = "libpng jpeg udev" 11DEPENDS = "libpng jpeg udev"
12DEPENDS:append = " ${@bb.utils.contains('DISTRO_FEATURES', 'wayland', 'wayland-native wayland-protocols', '', d)}" 12DEPENDS:append = " ${@bb.utils.contains('DISTRO_FEATURES', 'wayland', 'wayland-native wayland-protocols', '', d)}"
13 13
14PV = "2021.12" 14PV = "2023.01"
15 15
16SRC_URI = " \ 16SRC_URI = " \
17 git://github.com/glmark2/glmark2.git;protocol=https;branch=master \ 17 git://github.com/glmark2/glmark2.git;protocol=https;branch=master \
18 file://0001-fix-dispmanx-build.patch \ 18 file://0001-fix-dispmanx-build.patch \
19 file://0002-run-dispmanx-fullscreen.patch \ 19 file://0002-run-dispmanx-fullscreen.patch \
20 file://0001-libmatrix-Include-missing-utility-header.patch \
21" 20"
22SRCREV = "0858b450cd88c84a15b99dda9698d44e7f7e8c70" 21SRCREV = "42e3d8fe3aa88743ef90348138f643f7b04a9237"
23 22
24S = "${WORKDIR}/git" 23S = "${WORKDIR}/git"
25 24