diff options
author | Leon Anavi <leon.anavi@konsulko.com> | 2020-06-11 12:08:58 +0300 |
---|---|---|
committer | Khem Raj <raj.khem@gmail.com> | 2020-06-11 21:58:29 -0700 |
commit | a8c58b17e5d8583e3e047fc4142624316d233893 (patch) | |
tree | bdb068520ba756149c2cb65972d3ee8299d3a61d | |
parent | 639eae8901467c0bf79a05b6b6e6cda94a937ae9 (diff) | |
download | meta-openembedded-a8c58b17e5d8583e3e047fc4142624316d233893.tar.gz |
python3-pika: Consolidate in a single file
Consolidate inc and bb files into a single bb file.
Signed-off-by: Leon Anavi <leon.anavi@konsulko.com>
Acked-by: Trevor Gamblin <trevor.gamblin@windriver.com>
Signed-off-by: Khem Raj <raj.khem@gmail.com>
-rw-r--r-- | meta-python/recipes-devtools/python/python-pika.inc | 22 | ||||
-rw-r--r-- | meta-python/recipes-devtools/python/python3-pika_1.1.0.bb | 24 |
2 files changed, 22 insertions, 24 deletions
diff --git a/meta-python/recipes-devtools/python/python-pika.inc b/meta-python/recipes-devtools/python/python-pika.inc deleted file mode 100644 index bde154fe7..000000000 --- a/meta-python/recipes-devtools/python/python-pika.inc +++ /dev/null | |||
@@ -1,22 +0,0 @@ | |||
1 | SUMMARY = "Pika is a RabbitMQ (AMQP 0-9-1) client library for Python." | ||
2 | DESCRIPTION = " \ | ||
3 | Pika is a pure-Python implementation of the AMQP 0-9-1 protocol \ | ||
4 | including RabbitMQ’s extensions. \ | ||
5 | " | ||
6 | SECTION = "devel/python" | ||
7 | HOMEPAGE = "https://pika.readthedocs.io" | ||
8 | LICENSE = "BSD-3-Clause" | ||
9 | LIC_FILES_CHKSUM = "file://LICENSE;md5=535836bf0a5de515a7bfee026075701d" | ||
10 | |||
11 | SRC_URI[md5sum] = "6002400cdd33bf85ec8680ece72910d4" | ||
12 | SRC_URI[sha256sum] = "9fa76ba4b65034b878b2b8de90ff8660a59d925b087c5bb88f8fdbb4b64a1dbf" | ||
13 | |||
14 | inherit pypi | ||
15 | |||
16 | PYPI_PACKAGE = "pika" | ||
17 | |||
18 | RDEPENDS_${PN} += " \ | ||
19 | ${PYTHON_PN}-logging \ | ||
20 | ${PYTHON_PN}-tornado \ | ||
21 | ${PYTHON_PN}-twisted \ | ||
22 | " | ||
diff --git a/meta-python/recipes-devtools/python/python3-pika_1.1.0.bb b/meta-python/recipes-devtools/python/python3-pika_1.1.0.bb index a1515881f..c61d47c47 100644 --- a/meta-python/recipes-devtools/python/python3-pika_1.1.0.bb +++ b/meta-python/recipes-devtools/python/python3-pika_1.1.0.bb | |||
@@ -1,2 +1,22 @@ | |||
1 | inherit setuptools3 | 1 | SUMMARY = "Pika is a RabbitMQ (AMQP 0-9-1) client library for Python." |
2 | require python-pika.inc | 2 | DESCRIPTION = " \ |
3 | Pika is a pure-Python implementation of the AMQP 0-9-1 protocol \ | ||
4 | including RabbitMQ’s extensions. \ | ||
5 | " | ||
6 | SECTION = "devel/python" | ||
7 | HOMEPAGE = "https://pika.readthedocs.io" | ||
8 | LICENSE = "BSD-3-Clause" | ||
9 | LIC_FILES_CHKSUM = "file://LICENSE;md5=535836bf0a5de515a7bfee026075701d" | ||
10 | |||
11 | SRC_URI[md5sum] = "6002400cdd33bf85ec8680ece72910d4" | ||
12 | SRC_URI[sha256sum] = "9fa76ba4b65034b878b2b8de90ff8660a59d925b087c5bb88f8fdbb4b64a1dbf" | ||
13 | |||
14 | inherit pypi setuptools3 | ||
15 | |||
16 | PYPI_PACKAGE = "pika" | ||
17 | |||
18 | RDEPENDS_${PN} += " \ | ||
19 | ${PYTHON_PN}-logging \ | ||
20 | ${PYTHON_PN}-tornado \ | ||
21 | ${PYTHON_PN}-twisted \ | ||
22 | " | ||