summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2018-09-06 19:30:07 -0700
committerKhem Raj <raj.khem@gmail.com>2018-09-09 10:46:29 -0700
commita883fca429f23245885111a9366a6d7b148c54fe (patch)
treedfa03bf5b0f2688706ad5ca0145b9952d306e8f2
parent24383588ea361fa32d4d66cf904bc06300fb45de (diff)
downloadmeta-openembedded-a883fca429f23245885111a9366a6d7b148c54fe.tar.gz
openhpi: Upgrade to 3.8.0
* Add patches to fix build with OpenSSL 1.1.x * Forward patches and drop ones not needed anymore * openhpi: Fix build with musl Signed-off-by: Khem Raj <raj.khem@gmail.com>
-rw-r--r--meta-networking/recipes-daemons/openhpi/files/0001-Do-not-poke-at-build-host-s-etc-os-release.patch27
-rw-r--r--meta-networking/recipes-daemons/openhpi/files/0001-Fix-build-failures-with-gcc7.patch49
-rw-r--r--meta-networking/recipes-daemons/openhpi/files/0001-include-iostream-for-cout.patch41
-rw-r--r--meta-networking/recipes-daemons/openhpi/files/0001-ipmidirect-Replace-__STRING.patch31
-rw-r--r--meta-networking/recipes-daemons/openhpi/files/0001-plugins-Check-for-PTHREAD_RECURSIVE_MUTEX_INITIALIZE.patch47
-rw-r--r--meta-networking/recipes-daemons/openhpi/files/c++11.patch24
-rw-r--r--meta-networking/recipes-daemons/openhpi/files/clang-c++11.patch17
-rw-r--r--meta-networking/recipes-daemons/openhpi/files/cross_899198.patch98
-rw-r--r--meta-networking/recipes-daemons/openhpi/files/no-md2.patch37
-rw-r--r--meta-networking/recipes-daemons/openhpi/files/openhpi-3.6.1-ssl.patch20
-rw-r--r--meta-networking/recipes-daemons/openhpi/files/openhpi-hpi-shell-thread-fix.patch29
-rw-r--r--meta-networking/recipes-daemons/openhpi/files/openhpi-libxml2-cross-compile.patch23
-rw-r--r--meta-networking/recipes-daemons/openhpi/files/openhpi-netsnmp-cross-compile.patch25
-rw-r--r--meta-networking/recipes-daemons/openhpi/files/openhpi-use-serial-tests-config-needed-by-ptest.patch19
-rw-r--r--meta-networking/recipes-daemons/openhpi/openhpi_3.8.0.bb (renamed from meta-networking/recipes-daemons/openhpi/openhpi_3.6.1.bb)19
15 files changed, 291 insertions, 215 deletions
diff --git a/meta-networking/recipes-daemons/openhpi/files/0001-Do-not-poke-at-build-host-s-etc-os-release.patch b/meta-networking/recipes-daemons/openhpi/files/0001-Do-not-poke-at-build-host-s-etc-os-release.patch
new file mode 100644
index 000000000..ab9b25fed
--- /dev/null
+++ b/meta-networking/recipes-daemons/openhpi/files/0001-Do-not-poke-at-build-host-s-etc-os-release.patch
@@ -0,0 +1,27 @@
1From 2bc5c6367a7f70ca5bff177ec95bcad3b1c2b66b Mon Sep 17 00:00:00 2001
2From: Khem Raj <raj.khem@gmail.com>
3Date: Thu, 6 Sep 2018 18:15:10 -0700
4Subject: [PATCH] Do not poke at build host's /etc/os-release
5
6During cross compile we are interested in target distro and not host
7distro therefore do not check for it.
8
9Upstream-Status: Inappropriate [Cross compile specific]
10
11Signed-off-by: Khem Raj <raj.khem@gmail.com>
12---
13 configure.ac | 2 +-
14 1 file changed, 1 insertion(+), 1 deletion(-)
15
16Index: openhpi-3.8.0/configure.ac
17===================================================================
18--- openhpi-3.8.0.orig/configure.ac
19+++ openhpi-3.8.0/configure.ac
20@@ -194,7 +194,6 @@ AC_SUBST(JSON_C_LIB)
21 AC_SUBST(JSON_C_INCLUDE)
22 AC_CHECK_LIB([rabbitmq],[amqp_new_connection],[RABBITMQ_LIB=-lrabbitmq],[RABBITMQ_LIB=])
23 AC_SUBST(RABBITMQ_LIB)
24-AC_CHECK_FILE([/etc/os-release],[DISTRO=`grep "^ID=" /etc/os-release | awk -F"\"" '{ print $2 }'`])
25
26 AC_CHECK_HEADERS([amqp.h],[have_rabbitmq=yes],[have_rabbitmq=no])
27
diff --git a/meta-networking/recipes-daemons/openhpi/files/0001-Fix-build-failures-with-gcc7.patch b/meta-networking/recipes-daemons/openhpi/files/0001-Fix-build-failures-with-gcc7.patch
deleted file mode 100644
index 4f493f7b8..000000000
--- a/meta-networking/recipes-daemons/openhpi/files/0001-Fix-build-failures-with-gcc7.patch
+++ /dev/null
@@ -1,49 +0,0 @@
1From 398c6db66c643ed6133cc2b028ab1e27a17c5295 Mon Sep 17 00:00:00 2001
2From: Khem Raj <raj.khem@gmail.com>
3Date: Mon, 1 May 2017 19:10:09 +0000
4Subject: [PATCH] Fix build failures with gcc7
5
6Signed-off-by: Khem Raj <raj.khem@gmail.com>
7---
8 plugins/ipmidirect/ipmi_mc_vendor.cpp | 2 +-
9 plugins/ipmidirect/ipmi_resource.cpp | 4 ++--
10 2 files changed, 3 insertions(+), 3 deletions(-)
11
12diff --git a/plugins/ipmidirect/ipmi_mc_vendor.cpp b/plugins/ipmidirect/ipmi_mc_vendor.cpp
13index 2c6c090..557771c 100644
14--- a/plugins/ipmidirect/ipmi_mc_vendor.cpp
15+++ b/plugins/ipmidirect/ipmi_mc_vendor.cpp
16@@ -322,7 +322,7 @@ cIpmiMcVendor::CreateResources( cIpmiDomain *domain, cIpmiMc *source_mc, cIpmiSd
17 if ( addr.m_channel != source_mc->GetChannel() )
18 stdlog << "WARNING : SDR channel " << addr.m_channel << " NOT equal to MC channel " << source_mc->GetChannel() << "\n";
19
20- if ( FindOrCreateResource( domain, source_mc, fru_id, sdr, sdrs ) == false ) {
21+ if ( !FindOrCreateResource( domain, source_mc, fru_id, sdr, sdrs ) ) {
22 return false;
23 }
24 }
25diff --git a/plugins/ipmidirect/ipmi_resource.cpp b/plugins/ipmidirect/ipmi_resource.cpp
26index c438e74..2552673 100644
27--- a/plugins/ipmidirect/ipmi_resource.cpp
28+++ b/plugins/ipmidirect/ipmi_resource.cpp
29@@ -73,7 +73,7 @@ cIpmiResource::SendCommandReadLock( const cIpmiMsg &msg, cIpmiMsg &rsp,
30
31 domain->ReadLock();
32
33- if ( domain->VerifyResource( resource ) == false )
34+ if ( !domain->VerifyResource( resource ) )
35 return SA_ERR_HPI_NOT_PRESENT;
36
37 return rv;
38@@ -91,7 +91,7 @@ cIpmiResource::SendCommandReadLock( cIpmiRdr *rdr, const cIpmiMsg &msg, cIpmiMsg
39
40 domain->ReadLock();
41
42- if ( domain->VerifyRdr( rdr ) == false )
43+ if ( !domain->VerifyRdr( rdr ) )
44 return SA_ERR_HPI_NOT_PRESENT;
45
46 return rv;
47--
481.9.1
49
diff --git a/meta-networking/recipes-daemons/openhpi/files/0001-include-iostream-for-cout.patch b/meta-networking/recipes-daemons/openhpi/files/0001-include-iostream-for-cout.patch
new file mode 100644
index 000000000..c78ec28de
--- /dev/null
+++ b/meta-networking/recipes-daemons/openhpi/files/0001-include-iostream-for-cout.patch
@@ -0,0 +1,41 @@
1From 8f47adc3b9085d589e62cb5eb560dd23a703036a Mon Sep 17 00:00:00 2001
2From: Khem Raj <raj.khem@gmail.com>
3Date: Sat, 8 Sep 2018 12:47:49 -0700
4Subject: [PATCH] include iostream for cout
5
6End cout with endl
7
8Fixes
9plugins/dynamic_simulator/thread.cpp:241:3: error: 'cout' was not declared in this scope
10 cout<<"PTHREAD_RECURSIVE_MUTEX_INITIALIZER_NP is Defined"
11 ^~~~
12
13Upstream-Status: Pending
14
15Signed-off-by: Khem Raj <raj.khem@gmail.com>
16---
17 plugins/dynamic_simulator/thread.cpp | 4 ++--
18 1 file changed, 2 insertions(+), 2 deletions(-)
19
20diff --git a/plugins/dynamic_simulator/thread.cpp b/plugins/dynamic_simulator/thread.cpp
21index b971502..61eaf42 100644
22--- a/plugins/dynamic_simulator/thread.cpp
23+++ b/plugins/dynamic_simulator/thread.cpp
24@@ -26,7 +26,7 @@
25 */
26
27 #include "thread.h"
28-#include <stdio.h>
29+#include <iostream>
30 #include <sys/time.h>
31 #include <errno.h>
32
33@@ -238,7 +238,7 @@ cThreadLock::cThreadLock()
34 pthread_mutexattr_settype( &attr, PTHREAD_MUTEX_RECURSIVE );
35 pthread_mutex_init( &m_lock, &attr );
36 pthread_mutexattr_destroy( &attr );
37- cout<<"PTHREAD_RECURSIVE_MUTEX_INITIALIZER_NP is Defined"
38+ std::cout<<"PTHREAD_RECURSIVE_MUTEX_INITIALIZER_NP is Defined"<<std::endl;
39 }
40 #else
41 static pthread_mutex_t lock_tmpl = PTHREAD_RECURSIVE_MUTEX_INITIALIZER_NP;
diff --git a/meta-networking/recipes-daemons/openhpi/files/0001-ipmidirect-Replace-__STRING.patch b/meta-networking/recipes-daemons/openhpi/files/0001-ipmidirect-Replace-__STRING.patch
deleted file mode 100644
index 4d56f6535..000000000
--- a/meta-networking/recipes-daemons/openhpi/files/0001-ipmidirect-Replace-__STRING.patch
+++ /dev/null
@@ -1,31 +0,0 @@
1From be40b3f11460cf495bbbef45692e7763afda0c2b Mon Sep 17 00:00:00 2001
2From: Khem Raj <raj.khem@gmail.com>
3Date: Thu, 14 Sep 2017 17:56:31 -0700
4Subject: [PATCH] ipmidirect: Replace __STRING
5
6__STRING is not universally available e.g.
7musl does not define it
8
9Signed-off-by: Khem Raj <raj.khem@gmail.com>
10---
11Upstream-Status: Pending
12
13 plugins/ipmidirect/t/test.h | 2 +-
14 1 file changed, 1 insertion(+), 1 deletion(-)
15
16diff --git a/plugins/ipmidirect/t/test.h b/plugins/ipmidirect/t/test.h
17index 8d71381..978d5ff 100644
18--- a/plugins/ipmidirect/t/test.h
19+++ b/plugins/ipmidirect/t/test.h
20@@ -22,7 +22,7 @@ TestFunction( const char *str, const char *file, int line, bool expr )
21 }
22
23
24-#define Test(expr) TestFunction( __STRING(expr), __FILE__, __LINE__, expr )
25+#define Test(expr) TestFunction( #expr, __FILE__, __LINE__, expr )
26
27
28 static int
29--
302.14.1
31
diff --git a/meta-networking/recipes-daemons/openhpi/files/0001-plugins-Check-for-PTHREAD_RECURSIVE_MUTEX_INITIALIZE.patch b/meta-networking/recipes-daemons/openhpi/files/0001-plugins-Check-for-PTHREAD_RECURSIVE_MUTEX_INITIALIZE.patch
deleted file mode 100644
index 0f033ac85..000000000
--- a/meta-networking/recipes-daemons/openhpi/files/0001-plugins-Check-for-PTHREAD_RECURSIVE_MUTEX_INITIALIZE.patch
+++ /dev/null
@@ -1,47 +0,0 @@
1From be665d9513cca7e8b64c79ae424cf44ac166b052 Mon Sep 17 00:00:00 2001
2From: Khem Raj <raj.khem@gmail.com>
3Date: Thu, 14 Sep 2017 17:07:58 -0700
4Subject: [PATCH] plugins: Check for PTHREAD_RECURSIVE_MUTEX_INITIALIZER_NP
5 before use
6
7musl does not define PTHREAD_RECURSIVE_MUTEX_INITIALIZER_NP
8so we can not assume that all Linux systems support PTHREAD_RECURSIVE_MUTEX_INITIALIZER_NP
9its a glibc specific define so check for it being defined before using it
10
11Signed-off-by: Khem Raj <raj.khem@gmail.com>
12---
13Upstream-Status: Pending
14
15 plugins/dynamic_simulator/thread.cpp | 2 +-
16 plugins/ipmidirect/thread.cpp | 2 +-
17 2 files changed, 2 insertions(+), 2 deletions(-)
18
19diff --git a/plugins/dynamic_simulator/thread.cpp b/plugins/dynamic_simulator/thread.cpp
20index d663be0..9210fd7 100644
21--- a/plugins/dynamic_simulator/thread.cpp
22+++ b/plugins/dynamic_simulator/thread.cpp
23@@ -229,7 +229,7 @@ cThread::Exit( void *rv )
24 /**
25 * Constructor
26 **/
27-#if ( defined(__sun) && defined(__SVR4) ) || defined(__FreeBSD__)
28+#ifndef PTHREAD_RECURSIVE_MUTEX_INITIALIZER_NP
29 cThreadLock::cThreadLock()
30 {
31 pthread_mutexattr_t attr;
32diff --git a/plugins/ipmidirect/thread.cpp b/plugins/ipmidirect/thread.cpp
33index 5c52557..48e83fa 100644
34--- a/plugins/ipmidirect/thread.cpp
35+++ b/plugins/ipmidirect/thread.cpp
36@@ -167,7 +167,7 @@ cThread::Exit( void *rv )
37 // cThreadLock
38 //////////////////////////////////////////////////
39
40-#if ( defined(__sun) && defined(__SVR4) ) || defined(__FreeBSD__)
41+#ifndef PTHREAD_RECURSIVE_MUTEX_INITIALIZER_NP
42 cThreadLock::cThreadLock()
43 {
44 pthread_mutexattr_t attr;
45--
462.14.1
47
diff --git a/meta-networking/recipes-daemons/openhpi/files/c++11.patch b/meta-networking/recipes-daemons/openhpi/files/c++11.patch
index 0549d5977..5eff86b4d 100644
--- a/meta-networking/recipes-daemons/openhpi/files/c++11.patch
+++ b/meta-networking/recipes-daemons/openhpi/files/c++11.patch
@@ -1,11 +1,21 @@
1Index: openhpi-3.6.1/configure.ac 1From ed51168dfd6844deeaebf7d5f6c65898aafb6299 Mon Sep 17 00:00:00 2001
2=================================================================== 2From: Khem Raj <raj.khem@gmail.com>
3--- openhpi-3.6.1.orig/configure.ac 3Date: Sun, 27 Aug 2017 12:12:04 -0700
4+++ openhpi-3.6.1/configure.ac 4
5@@ -44,6 +44,7 @@ AC_PROG_CPP 5Upstream-Status: Pending
6 AC_PROG_INSTALL 6Signed-off-by: Khem Raj <raj.khem@gmail.com>
7 AC_PROG_LN_S 7---
8 configure.ac | 1 +
9 1 file changed, 1 insertion(+)
10
11diff --git a/configure.ac b/configure.ac
12index c29a31f..f7fe0f7 100644
13--- a/configure.ac
14+++ b/configure.ac
15@@ -46,6 +46,7 @@ AC_PROG_LN_S
8 AC_PROG_MAKE_SET 16 AC_PROG_MAKE_SET
17 AC_PROG_AWK
18 AC_PROG_GREP
9+AX_CXX_COMPILE_STDCXX_11([noext],[mandatory]) 19+AX_CXX_COMPILE_STDCXX_11([noext],[mandatory])
10 20
11 enabled_non32bit="no" 21 enabled_non32bit="no"
diff --git a/meta-networking/recipes-daemons/openhpi/files/clang-c++11.patch b/meta-networking/recipes-daemons/openhpi/files/clang-c++11.patch
index 9b35a0cce..7958a07c6 100644
--- a/meta-networking/recipes-daemons/openhpi/files/clang-c++11.patch
+++ b/meta-networking/recipes-daemons/openhpi/files/clang-c++11.patch
@@ -1,3 +1,7 @@
1Support build with Clang
2
3Upstream-Status: Pending
4Signed-off-by: Khem Raj <raj.khem@gmail.com>
1Index: openhpi-3.6.1/plugins/dynamic_simulator/new_sim.cpp 5Index: openhpi-3.6.1/plugins/dynamic_simulator/new_sim.cpp
2=================================================================== 6===================================================================
3--- openhpi-3.6.1.orig/plugins/dynamic_simulator/new_sim.cpp 7--- openhpi-3.6.1.orig/plugins/dynamic_simulator/new_sim.cpp
@@ -1273,16 +1277,3 @@ Index: openhpi-3.6.1/plugins/ipmidirect/ipmi.cpp
1273 1277
1274 static SaErrorT 1278 static SaErrorT
1275 IpmiResetWatchdog(void *hnd, 1279 IpmiResetWatchdog(void *hnd,
1276Index: openhpi-3.6.1/plugins/ipmidirect/ipmi_auth.h
1277===================================================================
1278--- openhpi-3.6.1.orig/plugins/ipmidirect/ipmi_auth.h
1279+++ openhpi-3.6.1/plugins/ipmidirect/ipmi_auth.h
1280@@ -32,7 +32,7 @@ class cIpmiAuthSg
1281 {
1282 public:
1283 void *data; /* NULL to terminate. */
1284- int len;
1285+ unsigned int len;
1286 };
1287
1288
diff --git a/meta-networking/recipes-daemons/openhpi/files/cross_899198.patch b/meta-networking/recipes-daemons/openhpi/files/cross_899198.patch
new file mode 100644
index 000000000..3161140df
--- /dev/null
+++ b/meta-networking/recipes-daemons/openhpi/files/cross_899198.patch
@@ -0,0 +1,98 @@
1From: Helmut Grohne <helmut@subdivi.de>
2Subject: fix cross compilation
3
4The OH_SET_SIZES macro relies on the usual autoconf sizeof cache variables
5during cross compilation, but it never ensure that they are initialized.
6
7pkg-config must be called with $ac_tool_prefix and PKG_PROG_PKG_CONFIG takes
8care of that. Setting PKG_CONFIG_PATH breaks the pkg-config-cross-wrapper.
9Don't do that.
10
11Upstream-Status: Pending
12Signed-off-by: Khem Raj <raj.khem@gmail.com>
13
14Index: openhpi-3.8.0/acinclude.m4
15===================================================================
16--- openhpi-3.8.0.orig/acinclude.m4
17+++ openhpi-3.8.0/acinclude.m4
18@@ -22,30 +22,39 @@ AC_DEFUN([OH_SET_SIZES],
19
20 if test "x$cross_compiling" != "xno"; then
21 if test "x$OH_SIZEOF_UCHAR" = x; then
22+ AC_CHECK_SIZEOF([unsigned char])
23 OH_SIZEOF_UCHAR=$ac_cv_sizeof_uchar
24 fi
25 if test "x$OH_SIZEOF_USHORT" = x; then
26+ AC_CHECK_SIZEOF([unsigned short])
27 OH_SIZEOF_USHORT=$ac_cv_sizeof_ushort
28 fi
29 if test "x$OH_SIZEOF_UINT" = x; then
30+ AC_CHECK_SIZEOF([unsigned int])
31 OH_SIZEOF_UINT=$ac_cv_sizeof_uint
32 fi
33 if test "x$OH_SIZEOF_CHAR" = x; then
34+ AC_CHECK_SIZEOF([char])
35 OH_SIZEOF_CHAR=$ac_cv_sizeof_char
36 fi
37 if test "x$OH_SIZEOF_SHORT" = x; then
38+ AC_CHECK_SIZEOF([short])
39 OH_SIZEOF_SHORT=$ac_cv_sizeof_short
40 fi
41 if test "x$OH_SIZEOF_INT" = x; then
42+ AC_CHECK_SIZEOF([int])
43 OH_SIZEOF_INT=$ac_cv_sizeof_int
44 fi
45 if test "x$OH_SIZEOF_LLONG" = x; then
46+ AC_CHECK_SIZEOF([long long])
47 OH_SIZEOF_LLONG=$ac_cv_sizeof_longlong
48 fi
49 if test "x$OH_SIZEOF_FLOAT" = x; then
50+ AC_CHECK_SIZEOF([float])
51 OH_SIZEOF_FLOAT=$ac_cv_sizeof_float
52 fi
53 if test "x$OH_SIZEOF_DOUBLE" = x; then
54+ AC_CHECK_SIZEOF([double])
55 OH_SIZEOF_DOUBLE=$ac_cv_sizeof_double
56 fi
57 else
58Index: openhpi-3.8.0/configure.ac
59===================================================================
60--- openhpi-3.8.0.orig/configure.ac
61+++ openhpi-3.8.0/configure.ac
62@@ -87,9 +87,9 @@ have_rtas_lib=no
63
64 dnl Check for GLIB
65
66-AC_CHECK_PROG([found_pkg_config],[pkg-config],[yes])
67+PKG_PROG_PKG_CONFIG
68
69-if test "x$found_pkg_config" != "xyes"; then
70+if test "x$PKG_CONFIG" = "x"; then
71 OH_CHECK_FAIL(pkg-config,pkg-config)
72 fi
73 PKG_CFG_SETPATH
74@@ -105,7 +105,7 @@ GLIB=glib-2.0
75 GTHREAD=gthread-2.0
76 GMODULE=gmodule-2.0
77
78-if pkg-config --atleast-version $GLIB_REQUIRED_VERSION $GLIB; then
79+if $PKG_CONFIG --atleast-version $GLIB_REQUIRED_VERSION $GLIB; then
80 :
81 else
82 AC_MSG_ERROR([
83@@ -268,12 +268,12 @@ dnl
84 dnl We really need to make ipmi enablement be contigent on OpenIPMI
85 dnl
86
87-if PKG_CONFIG_PATH=$PKG_CONFIG_PATH:/usr/local/lib/pkgconfig pkg-config --atleast-version 1.4.20 OpenIPMI; then
88+if $PKG_CONFIG --atleast-version 1.4.20 OpenIPMI; then
89 have_openipmi=yes
90 AC_CHECK_LIB([OpenIPMI], [ipmi_smi_setup_con], [have_openipmi=yes])
91- OPENIPMI_CFLAGS=`PKG_CONFIG_PATH=$PKG_CONFIG_PATH:/usr/local/lib/pkgconfig pkg-config --cflags OpenIPMI`
92+ OPENIPMI_CFLAGS=`$PKG_CONFIG --cflags OpenIPMI`
93 AC_SUBST(OPENIPMI_CFLAGS)
94- OPENIPMI_LIBS=`PKG_CONFIG_PATH=$PKG_CONFIG_PATH:/usr/local/lib/pkgconfig pkg-config --libs OpenIPMI`
95+ OPENIPMI_LIBS=`$PKG_CONFIG --libs OpenIPMI`
96 AC_SUBST(OPENIPMI_LIBS)
97 fi
98
diff --git a/meta-networking/recipes-daemons/openhpi/files/no-md2.patch b/meta-networking/recipes-daemons/openhpi/files/no-md2.patch
new file mode 100644
index 000000000..c4dd23e79
--- /dev/null
+++ b/meta-networking/recipes-daemons/openhpi/files/no-md2.patch
@@ -0,0 +1,37 @@
1Description: Fix FTBFS with OpenSSL 1.1 by honouring OPENSSL_NO_MD2
2Author: Adrian Bunk <bunk@debian.org>
3Bug-Debian: https://bugs.debian.org/859543
4
5Upstream-Status: Pending
6Signed-off-by: Khem Raj <raj.khem@gmail.com>
7
8Index: openhpi-3.8.0/plugins/ipmidirect/ipmi_auth.cpp
9===================================================================
10--- openhpi-3.8.0.orig/plugins/ipmidirect/ipmi_auth.cpp
11+++ openhpi-3.8.0/plugins/ipmidirect/ipmi_auth.cpp
12@@ -21,6 +21,7 @@
13 #include "ipmi_auth.h"
14 #include <string.h>
15 #include <errno.h>
16+#include <openssl/opensslconf.h>
17
18
19 cIpmiAuth *
20@@ -32,7 +33,7 @@ IpmiAuthFactory( tIpmiAuthType type )
21 return new cIpmiAuthNone;
22
23 case eIpmiAuthTypeMd2:
24-#ifdef HAVE_OPENSSL_MD2_H
25+#if defined(HAVE_OPENSSL_MD2_H) && !defined(OPENSSL_NO_MD2)
26 return new cIpmiAuthMd2;
27 #else
28 break;
29@@ -78,7 +79,7 @@ cIpmiAuthNone::Check( cIpmiAuthSg /*d*/[
30 }
31
32
33-#ifdef HAVE_OPENSSL_MD2_H
34+#if defined(HAVE_OPENSSL_MD2_H) && !defined(OPENSSL_NO_MD2)
35 #include <openssl/md2.h>
36
37
diff --git a/meta-networking/recipes-daemons/openhpi/files/openhpi-3.6.1-ssl.patch b/meta-networking/recipes-daemons/openhpi/files/openhpi-3.6.1-ssl.patch
new file mode 100644
index 000000000..ca522bcc6
--- /dev/null
+++ b/meta-networking/recipes-daemons/openhpi/files/openhpi-3.6.1-ssl.patch
@@ -0,0 +1,20 @@
1Link with libssl
2
3fixed build with openssl-1.1.x
4
5Taken from Fedora
6https://src.fedoraproject.org/rpms/openhpi/c/be77f5484b0206f8946a85b29424ea10bf863063
7
8Signed-off-by: Khem Raj <raj.khem@gmail.com>
9Upstream-Status: Unknown
10
11diff -up openhpi-3.6.1/ssl/Makefile.am.than openhpi-3.6.1/ssl/Makefile.am
12--- openhpi-3.6.1/ssl/Makefile.am.than 2017-02-21 12:21:12.114814698 -0500
13+++ openhpi-3.6.1/ssl/Makefile.am 2017-02-21 12:22:44.576454262 -0500
14@@ -19,5 +19,5 @@ lib_LTLIBRARIES = libopenhpi_ssl.la
15 libopenhpi_ssl_la_SOURCES = oh_ssl.c oh_ssl.h
16
17 libopenhpi_ssl_la_LDFLAGS = -version-info @HPI_LIB_VERSION@
18-libopenhpi_ssl_la_LIBADD = @CRYPTO_LIB@
19+libopenhpi_ssl_la_LIBADD = -lssl @CRYPTO_LIB@
20
diff --git a/meta-networking/recipes-daemons/openhpi/files/openhpi-hpi-shell-thread-fix.patch b/meta-networking/recipes-daemons/openhpi/files/openhpi-hpi-shell-thread-fix.patch
deleted file mode 100644
index cc21ff8c7..000000000
--- a/meta-networking/recipes-daemons/openhpi/files/openhpi-hpi-shell-thread-fix.patch
+++ /dev/null
@@ -1,29 +0,0 @@
1commit e9f9a73c9dba8dd59f3d6c3acd9988ec8361d55a
2Author: Aws Ismail <aws.ismail@windriver.com>
3Date: Mon Dec 17 16:23:45 2012 -0500
4
5 Correct dangling g_thread_exit in session.c
6
7 hpi_shell's session.c has its progress_bar
8 thread created using pthread_create but
9 exited using g_thread_exit. Use pthread_exit
10 instead to avoid unpredictable GLIB thread
11 errors.
12
13 Upstream-Status: Pending
14
15 Signed-off-by: Aws Ismail <aws.ismail@windriver.com>
16
17Index: openhpi-3.6.1/hpi_shell/session.c
18===================================================================
19--- openhpi-3.6.1.orig/hpi_shell/session.c
20+++ openhpi-3.6.1/hpi_shell/session.c
21@@ -73,7 +73,7 @@ static void* progress_bar(void *unused)
22 if (i < (PROGRESS_BUF_SIZE - mes_len - 1)) i++;
23 t++;
24 };
25- g_thread_exit(0);
26+ pthread_exit(0);
27 return (void *)1;
28 }
29
diff --git a/meta-networking/recipes-daemons/openhpi/files/openhpi-libxml2-cross-compile.patch b/meta-networking/recipes-daemons/openhpi/files/openhpi-libxml2-cross-compile.patch
index c848b3502..160eeede6 100644
--- a/meta-networking/recipes-daemons/openhpi/files/openhpi-libxml2-cross-compile.patch
+++ b/meta-networking/recipes-daemons/openhpi/files/openhpi-libxml2-cross-compile.patch
@@ -1,4 +1,7 @@
1Fix libxml2 for cross-compiling 1From afe545e77f9d841b7777d859e7e8108492fece96 Mon Sep 17 00:00:00 2001
2From: Jackie Huang <jackie.huang@windriver.com>
3Date: Wed, 26 Apr 2017 16:22:00 +0800
4Subject: [PATCH] Fix libxml2 for cross-compiling
2 5
3Use proper XML2_INCLUDE path when cross-compiling 6Use proper XML2_INCLUDE path when cross-compiling
4 7
@@ -6,16 +9,20 @@ Upstream-Status: Pending
6 9
7Signed-of-by: Aws Ismail <aws.ismail@windriver.com> 10Signed-of-by: Aws Ismail <aws.ismail@windriver.com>
8 11
9Index: openhpi-3.6.1/configure.ac 12---
10=================================================================== 13 configure.ac | 2 +-
11--- openhpi-3.6.1.orig/configure.ac 14 1 file changed, 1 insertion(+), 1 deletion(-)
12+++ openhpi-3.6.1/configure.ac 15
13@@ -177,7 +177,7 @@ AC_CHECK_HEADERS([openssl/md2.h openssl/ 16diff --git a/configure.ac b/configure.ac
17index 6242cbf..4fb6b69 100644
18--- a/configure.ac
19+++ b/configure.ac
20@@ -179,7 +179,7 @@ AC_CHECK_HEADERS([openssl/md2.h openssl/md5.h openssl/bio.h openssl/ssl.h openss
14 21
15 dnl xml is used for XML-based communication in ilo2_ribcl and oa_soap 22 dnl xml is used for XML-based communication in ilo2_ribcl and oa_soap
16 AC_CHECK_LIB([xml2],[xmlParseMemory],[XML2_LIB=-lxml2],[XML2_LIB=]) 23 AC_CHECK_LIB([xml2],[xmlParseMemory],[XML2_LIB=-lxml2],[XML2_LIB=])
17-AC_CHECK_HEADERS([libxml2/libxml/xmlexports.h],[XML2_INCLUDE="-I/usr/include/libxml2"],[XML2_INCLUDE]) 24-AC_CHECK_HEADERS([libxml2/libxml/xmlexports.h],[XML2_INCLUDE="-I/usr/include/libxml2"],[XML2_INCLUDE=])
18+AC_CHECK_HEADERS([libxml2/libxml/xmlexports.h],[XML2_INCLUDE="$XML2_INCLUDE"],[XML2_INCLUDE]) 25+AC_CHECK_HEADERS([libxml2/libxml/xmlexports.h],[XML2_INCLUDE="$XML2_INCLUDE"],[XML2_INCLUDE=])
19 AC_SUBST(XML2_LIB) 26 AC_SUBST(XML2_LIB)
20 AC_SUBST(XML2_INCLUDE) 27 AC_SUBST(XML2_INCLUDE)
21 28
diff --git a/meta-networking/recipes-daemons/openhpi/files/openhpi-netsnmp-cross-compile.patch b/meta-networking/recipes-daemons/openhpi/files/openhpi-netsnmp-cross-compile.patch
index 95b0abc91..293c8d91f 100644
--- a/meta-networking/recipes-daemons/openhpi/files/openhpi-netsnmp-cross-compile.patch
+++ b/meta-networking/recipes-daemons/openhpi/files/openhpi-netsnmp-cross-compile.patch
@@ -13,36 +13,33 @@ Signed-off-by: Wenzong Fan <wenzong.fan@windriver.com>
13 configure | 4 ++-- 13 configure | 4 ++--
14 2 files changed, 4 insertions(+), 4 deletions(-) 14 2 files changed, 4 insertions(+), 4 deletions(-)
15 15
16diff --git a/acinclude.m4 b/acinclude.m4 16Index: openhpi-3.8.0/acinclude.m4
17index 82c33f6..727e461 100644 17===================================================================
18--- a/acinclude.m4 18--- openhpi-3.8.0.orig/acinclude.m4
19+++ b/acinclude.m4 19+++ openhpi-3.8.0/acinclude.m4
20@@ -160,8 +160,8 @@ AC_DEFUN([OH_CHECK_NETSNMP], 20@@ -160,8 +160,8 @@ AC_DEFUN([OH_CHECK_NETSNMP],
21 ], 21 ],
22 [ 22 [
23 have_netsnmp=yes 23 have_netsnmp=yes
24- SNMPFLAGS=`${net_snmp_config:-net-snmp-config} --cflags | perl -p -e 's/-O\S*//g'` 24- SNMPFLAGS=`${net_snmp_config:-net-snmp-config} --cflags | perl -p -e 's/ -O\S*//g'`
25- SNMPLIBS=`${net_snmp_config:-net-snmp-config} --libs` 25- SNMPLIBS=`${net_snmp_config:-net-snmp-config} --libs`
26+ SNMPFLAGS="" 26+ SNMPFLAGS=""
27+ SNMPLIBS="" 27+ SNMPLIBS=""
28 AC_MSG_RESULT(yes) 28 AC_MSG_RESULT(yes)
29 ], 29 ],
30 [AC_MSG_RESULT(no. No SNMP based plugins can be built!)]) 30 [AC_MSG_RESULT(no. No SNMP based plugins can be built!)])
31diff --git a/configure b/configure 31Index: openhpi-3.8.0/configure
32index 00067bc..36b913c 100755 32===================================================================
33--- a/configure 33--- openhpi-3.8.0.orig/configure
34+++ b/configure 34+++ openhpi-3.8.0/configure
35@@ -15949,8 +15949,8 @@ _ACEOF 35@@ -16062,8 +16062,8 @@ _ACEOF
36 if ac_fn_c_try_link "$LINENO"; then : 36 if ac_fn_c_try_link "$LINENO"; then :
37 37
38 have_netsnmp=yes 38 have_netsnmp=yes
39- SNMPFLAGS=`${net_snmp_config:-net-snmp-config} --cflags | perl -p -e 's/-O\S*//g'` 39- SNMPFLAGS=`${net_snmp_config:-net-snmp-config} --cflags | perl -p -e 's/ -O\S*//g'`
40- SNMPLIBS=`${net_snmp_config:-net-snmp-config} --libs` 40- SNMPLIBS=`${net_snmp_config:-net-snmp-config} --libs`
41+ SNMPFLAGS="" 41+ SNMPFLAGS=""
42+ SNMPLIBS="" 42+ SNMPLIBS=""
43 { $as_echo "$as_me:${as_lineno-$LINENO}: result: yes" >&5 43 { $as_echo "$as_me:${as_lineno-$LINENO}: result: yes" >&5
44 $as_echo "yes" >&6; } 44 $as_echo "yes" >&6; }
45 45
46--
471.9.1
48
diff --git a/meta-networking/recipes-daemons/openhpi/files/openhpi-use-serial-tests-config-needed-by-ptest.patch b/meta-networking/recipes-daemons/openhpi/files/openhpi-use-serial-tests-config-needed-by-ptest.patch
index 3e09180d4..472318b80 100644
--- a/meta-networking/recipes-daemons/openhpi/files/openhpi-use-serial-tests-config-needed-by-ptest.patch
+++ b/meta-networking/recipes-daemons/openhpi/files/openhpi-use-serial-tests-config-needed-by-ptest.patch
@@ -1,4 +1,4 @@
1From 36fbaa27e7299f63c1324b0ad22b970e9365d6a7 Mon Sep 17 00:00:00 2001 1From 5e0ae172586f5aeb270a8f9b012dd3e36536a2a9 Mon Sep 17 00:00:00 2001
2From: Jackie Huang <jackie.huang@windriver.com> 2From: Jackie Huang <jackie.huang@windriver.com>
3Date: Wed, 24 Dec 2014 10:54:59 +0800 3Date: Wed, 24 Dec 2014 10:54:59 +0800
4Subject: [PATCH] openhpi: use serial-tests config needed by ptest 4Subject: [PATCH] openhpi: use serial-tests config needed by ptest
@@ -9,17 +9,18 @@ serial-tests is required to generate those targets.
9Upstream-Status: Inappropriate [default automake behavior incompatible with ptest] 9Upstream-Status: Inappropriate [default automake behavior incompatible with ptest]
10 10
11Signed-off-by: Jackie Huang <jackie.huang@windriver.com> 11Signed-off-by: Jackie Huang <jackie.huang@windriver.com>
12
12--- 13---
13 configure.ac | 2 +- 14 configure.ac | 2 +-
14 1 files changed, 1 insertions(+), 1 deletions(-) 15 1 file changed, 1 insertion(+), 1 deletion(-)
15 16
16Index: openhpi-3.6.1/configure.ac 17diff --git a/configure.ac b/configure.ac
17=================================================================== 18index 89d8104..c29a31f 100644
18--- openhpi-3.6.1.orig/configure.ac 19--- a/configure.ac
19+++ openhpi-3.6.1/configure.ac 20+++ b/configure.ac
20@@ -7,7 +7,7 @@ dnl various hacks by Sean Dague <http: 21@@ -7,7 +7,7 @@ dnl various hacks by Sean Dague <http://dague.net/sean> 4/23/03
21 AC_PREREQ(2.57) 22 AC_PREREQ(2.57)
22 AC_INIT(openhpi, 3.6.1) 23 AC_INIT(openhpi, 3.8.0)
23 AC_CONFIG_SRCDIR(openhpi.spec.in) 24 AC_CONFIG_SRCDIR(openhpi.spec.in)
24-AM_INIT_AUTOMAKE([1.8]) 25-AM_INIT_AUTOMAKE([1.8])
25+AM_INIT_AUTOMAKE([1.8 serial-tests]) 26+AM_INIT_AUTOMAKE([1.8 serial-tests])
diff --git a/meta-networking/recipes-daemons/openhpi/openhpi_3.6.1.bb b/meta-networking/recipes-daemons/openhpi/openhpi_3.8.0.bb
index 596578e11..c4b3309f7 100644
--- a/meta-networking/recipes-daemons/openhpi/openhpi_3.6.1.bb
+++ b/meta-networking/recipes-daemons/openhpi/openhpi_3.8.0.bb
@@ -20,7 +20,8 @@ SECTION = "net"
20LICENSE = "BSD" 20LICENSE = "BSD"
21LIC_FILES_CHKSUM = "file://COPYING;md5=e3c772a32386888ccb5ae1c0ba95f1a4" 21LIC_FILES_CHKSUM = "file://COPYING;md5=e3c772a32386888ccb5ae1c0ba95f1a4"
22 22
23DEPENDS = "net-snmp libxml2 ncurses openssl glib-2.0 popt e2fsprogs autoconf-archive-native" 23DEPENDS = "net-snmp libxml2 ncurses openssl glib-2.0 popt e2fsprogs \
24 autoconf-archive-native os-release"
24 25
25SRC_URI = "${SOURCEFORGE_MIRROR}/${BPN}/${BP}.tar.gz \ 26SRC_URI = "${SOURCEFORGE_MIRROR}/${BPN}/${BP}.tar.gz \
26 file://openhpi.init \ 27 file://openhpi.init \
@@ -32,23 +33,23 @@ SRC_URI = "${SOURCEFORGE_MIRROR}/${BPN}/${BP}.tar.gz \
32 file://openhpi-glib-cross-compile.patch \ 33 file://openhpi-glib-cross-compile.patch \
33 file://openhpi-linkfix.patch \ 34 file://openhpi-linkfix.patch \
34 file://openhpi-fix-host-gcc.patch \ 35 file://openhpi-fix-host-gcc.patch \
35 file://openhpi-hpi-shell-thread-fix.patch \
36 file://openhpi-fix-testfail-errors.patch \ 36 file://openhpi-fix-testfail-errors.patch \
37 file://openhpi-add-libnetsnmp-when-link.patch \ 37 file://openhpi-add-libnetsnmp-when-link.patch \
38 file://openhpi-invalide-session.patch \ 38 file://openhpi-invalide-session.patch \
39 file://openhpi-use-serial-tests-config-needed-by-ptest.patch \ 39 file://openhpi-use-serial-tests-config-needed-by-ptest.patch \
40 file://openhpi-fix-alignment-issue.patch \ 40 file://openhpi-fix-alignment-issue.patch \
41 file://0001-Fix-build-failures-with-gcc7.patch \
42 file://c++11.patch \ 41 file://c++11.patch \
43 file://clang-c++11.patch \ 42 file://clang-c++11.patch \
44 file://fix-narrowing-warning.patch \ 43 file://fix-narrowing-warning.patch \
45 file://0001-plugins-Check-for-PTHREAD_RECURSIVE_MUTEX_INITIALIZE.patch \
46 file://0001-ipmidirect-Replace-__STRING.patch \
47 file://0001-session-close-socket.patch \ 44 file://0001-session-close-socket.patch \
45 file://openhpi-3.6.1-ssl.patch \
46 file://0001-Do-not-poke-at-build-host-s-etc-os-release.patch \
47 file://cross_899198.patch \
48 file://no-md2.patch \
49 file://0001-include-iostream-for-cout.patch \
48 " 50 "
49 51SRC_URI[md5sum] = "fffda3deea8a0d3671a72eea9d13a4df"
50SRC_URI[md5sum] = "4718b16e0f749b5ad214a9b04f45dd23" 52SRC_URI[sha256sum] = "c94332a29160dd75cb799c027e614690c00263b0fabed87417707bec04c38723"
51SRC_URI[sha256sum] = "e0a810cb401c4bdcfc9551f2e6afd5a8ca4b411f5ee3bc60c19f82fd6e84a3dc"
52 53
53inherit autotools pkgconfig ptest update-rc.d systemd 54inherit autotools pkgconfig ptest update-rc.d systemd
54 55
@@ -64,6 +65,8 @@ PACKAGECONFIG[sysfs] = "--enable-sysfs,--disable-sysfs,sysfsutils,"
64PACKAGECONFIG[libgcrypt] = "--enable-encryption,--disable-encryption,libgcrypt," 65PACKAGECONFIG[libgcrypt] = "--enable-encryption,--disable-encryption,libgcrypt,"
65PACKAGECONFIG[non32bit] = "--enable-non32bit-int,--disable-non32bit-int,," 66PACKAGECONFIG[non32bit] = "--enable-non32bit-int,--disable-non32bit-int,,"
66 67
68export DISTRO
69
67do_install_append () { 70do_install_append () {
68 install -m 0755 -d ${D}${sysconfdir}/${BPN} 71 install -m 0755 -d ${D}${sysconfdir}/${BPN}
69 install -m 0755 ${S}/openhpiclient.conf.example ${D}${sysconfdir}/${BPN}/openhpiclient.conf 72 install -m 0755 ${S}/openhpiclient.conf.example ${D}${sysconfdir}/${BPN}/openhpiclient.conf