summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorPierre-Jean Texier <pjtexier@koncepto.io>2020-04-03 21:42:39 +0200
committerKhem Raj <raj.khem@gmail.com>2020-04-03 14:45:54 -0700
commita5a9abf0fc2cf530cf198875b3dba5bb80fbc435 (patch)
tree4f118bec66f454548f1a3aaf73cd4bd2ee513b26
parent519b86c549a7e62e0f9779402567571c96a35d40 (diff)
downloadmeta-openembedded-a5a9abf0fc2cf530cf198875b3dba5bb80fbc435.tar.gz
python-pyroute2: consolidate into a single file
For details see [1] [1] - https://lists.openembedded.org/g/openembedded-devel/topic/72718415 Suggested-by: Tim Orling <ticotimo@gmail.com> Signed-off-by: Pierre-Jean Texier <pjtexier@koncepto.io> Signed-off-by: Khem Raj <raj.khem@gmail.com>
-rw-r--r--meta-python/recipes-devtools/python/python-pyroute2.inc25
-rw-r--r--meta-python/recipes-devtools/python/python3-pyroute2_0.5.9.bb25
2 files changed, 23 insertions, 27 deletions
diff --git a/meta-python/recipes-devtools/python/python-pyroute2.inc b/meta-python/recipes-devtools/python/python-pyroute2.inc
deleted file mode 100644
index add7b7bee..000000000
--- a/meta-python/recipes-devtools/python/python-pyroute2.inc
+++ /dev/null
@@ -1,25 +0,0 @@
1SUMMARY = "A pure Python netlink and Linux network configuration library"
2LICENSE = "GPLv2 & Apache-2.0"
3LIC_FILES_CHKSUM = "file://LICENSE.GPL.v2;md5=b234ee4d69f5fce4486a80fdaf4a4263 \
4 file://LICENSE.Apache.v2;md5=34281e312165f843a2b7d1f114fe65ce"
5
6SRC_URI[md5sum] = "4ee568832c98c39253230293a2ca3d59"
7SRC_URI[sha256sum] = "240ed116fabef02c284cc40d27986e629f02aa788311a8059905b8988752d5b7"
8
9FILESEXTRAPATHS_prepend := "${THISDIR}/python-pyroute2:"
10
11inherit pypi
12
13RDEPENDS_${PN} += " \
14 ${PYTHON_PN}-ctypes \
15 ${PYTHON_PN}-distutils \
16 ${PYTHON_PN}-io \
17 ${PYTHON_PN}-json \
18 ${PYTHON_PN}-logging \
19 ${PYTHON_PN}-multiprocessing \
20 ${PYTHON_PN}-pickle \
21 ${PYTHON_PN}-pkgutil \
22 ${PYTHON_PN}-pprint \
23 ${PYTHON_PN}-shell \
24 ${PYTHON_PN}-unixadmin \
25"
diff --git a/meta-python/recipes-devtools/python/python3-pyroute2_0.5.9.bb b/meta-python/recipes-devtools/python/python3-pyroute2_0.5.9.bb
index a23e72c4a..90d9486aa 100644
--- a/meta-python/recipes-devtools/python/python3-pyroute2_0.5.9.bb
+++ b/meta-python/recipes-devtools/python/python3-pyroute2_0.5.9.bb
@@ -1,2 +1,23 @@
1require python-pyroute2.inc 1SUMMARY = "A pure Python netlink and Linux network configuration library"
2inherit setuptools3 2LICENSE = "GPLv2 & Apache-2.0"
3LIC_FILES_CHKSUM = "file://LICENSE.GPL.v2;md5=b234ee4d69f5fce4486a80fdaf4a4263 \
4 file://LICENSE.Apache.v2;md5=34281e312165f843a2b7d1f114fe65ce"
5
6SRC_URI[md5sum] = "4ee568832c98c39253230293a2ca3d59"
7SRC_URI[sha256sum] = "240ed116fabef02c284cc40d27986e629f02aa788311a8059905b8988752d5b7"
8
9inherit setuptools3 pypi
10
11RDEPENDS_${PN} += " \
12 ${PYTHON_PN}-ctypes \
13 ${PYTHON_PN}-distutils \
14 ${PYTHON_PN}-io \
15 ${PYTHON_PN}-json \
16 ${PYTHON_PN}-logging \
17 ${PYTHON_PN}-multiprocessing \
18 ${PYTHON_PN}-pickle \
19 ${PYTHON_PN}-pkgutil \
20 ${PYTHON_PN}-pprint \
21 ${PYTHON_PN}-shell \
22 ${PYTHON_PN}-unixadmin \
23"