summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2022-04-23 18:04:05 -0700
committerKhem Raj <raj.khem@gmail.com>2022-04-25 10:44:13 -0700
commita47c833126334404fcad459cc683e304fee54595 (patch)
tree249469704567a9ed882124f1150dde90e329041f
parentd69c0da9d2ad86a5d57e7359eaba8fe26c1ed820 (diff)
downloadmeta-openembedded-a47c833126334404fcad459cc683e304fee54595.tar.gz
ufw: Fix build with usrmerge distro feature
Signed-off-by: Khem Raj <raj.khem@gmail.com>
-rw-r--r--meta-networking/recipes-connectivity/ufw/ufw_0.36.1.bb7
1 files changed, 7 insertions, 0 deletions
diff --git a/meta-networking/recipes-connectivity/ufw/ufw_0.36.1.bb b/meta-networking/recipes-connectivity/ufw/ufw_0.36.1.bb
index 70216a85e..6dca784bf 100644
--- a/meta-networking/recipes-connectivity/ufw/ufw_0.36.1.bb
+++ b/meta-networking/recipes-connectivity/ufw/ufw_0.36.1.bb
@@ -38,6 +38,13 @@ RRECOMMENDS:${PN} = " \
38 kernel-module-nf-recent \ 38 kernel-module-nf-recent \
39" 39"
40 40
41
42do_configure:prepend() {
43 if ${@bb.utils.contains('DISTRO_FEATURES','usrmerge','true','false',d)}; then
44 sed -i -e 's|/lib|${nonarch_base_libdir}|' ${S}/setup.py
45 fi
46}
47
41do_install:append() { 48do_install:append() {
42 install -d ${D}${systemd_unitdir}/system/ 49 install -d ${D}${systemd_unitdir}/system/
43 install -m 0644 ${S}/doc/systemd.example ${D}${systemd_unitdir}/system/ufw.service 50 install -m 0644 ${S}/doc/systemd.example ${D}${systemd_unitdir}/system/ufw.service