diff options
author | Khem Raj <raj.khem@gmail.com> | 2024-08-29 14:25:52 -0700 |
---|---|---|
committer | Khem Raj <raj.khem@gmail.com> | 2024-08-29 20:59:16 -0700 |
commit | a32ae2f7d65ed744ed34b550ced1fbb725e454b5 (patch) | |
tree | fc5bb2f97b0f01695f2bd2e4d9ca2057e8999831 | |
parent | d40cf9d9caf9c26f8f18396ff3619e8851d76cfe (diff) | |
download | meta-openembedded-a32ae2f7d65ed744ed34b550ced1fbb725e454b5.tar.gz |
mpv: Upgrade to 0.38.0 release
https://github.com/mpv-player/mpv/releases
migrate to using meson build system
Signed-off-by: Khem Raj <raj.khem@gmail.com>
-rw-r--r-- | meta-oe/recipes-multimedia/mplayer/mpv/0001-file2string-Avoid-emitting-absolute-filepaths-into-g.patch | 33 | ||||
-rw-r--r-- | meta-oe/recipes-multimedia/mplayer/mpv_0.38.0.bb (renamed from meta-oe/recipes-multimedia/mplayer/mpv_0.35.1.bb) | 79 |
2 files changed, 68 insertions, 44 deletions
diff --git a/meta-oe/recipes-multimedia/mplayer/mpv/0001-file2string-Avoid-emitting-absolute-filepaths-into-g.patch b/meta-oe/recipes-multimedia/mplayer/mpv/0001-file2string-Avoid-emitting-absolute-filepaths-into-g.patch new file mode 100644 index 000000000..b96ec5d4c --- /dev/null +++ b/meta-oe/recipes-multimedia/mplayer/mpv/0001-file2string-Avoid-emitting-absolute-filepaths-into-g.patch | |||
@@ -0,0 +1,33 @@ | |||
1 | From 9878681df9919d28da3e4c6cc706e264abd9df92 Mon Sep 17 00:00:00 2001 | ||
2 | From: Khem Raj <raj.khem@gmail.com> | ||
3 | Date: Thu, 29 Aug 2024 17:54:15 -0700 | ||
4 | Subject: [PATCH] file2string: Avoid emitting absolute filepaths into generated | ||
5 | sources | ||
6 | |||
7 | These sources are bundled into src packages to be distributed and leaking | ||
8 | buildpaths results in violating reproducibility norms. | ||
9 | |||
10 | Upstream-Status: Submitted [https://github.com/mpv-player/mpv/pull/14763] | ||
11 | |||
12 | Signed-off-by: Khem Raj <raj.khem@gmail.com> | ||
13 | --- | ||
14 | TOOLS/file2string.py | 4 ++-- | ||
15 | 1 file changed, 2 insertions(+), 2 deletions(-) | ||
16 | |||
17 | diff --git a/TOOLS/file2string.py b/TOOLS/file2string.py | ||
18 | index 5b1c4a95d1..39c1122a35 100755 | ||
19 | --- a/TOOLS/file2string.py | ||
20 | +++ b/TOOLS/file2string.py | ||
21 | @@ -22,10 +22,10 @@ | ||
22 | # License along with mpv. If not, see <http://www.gnu.org/licenses/>. | ||
23 | # | ||
24 | |||
25 | -import sys | ||
26 | +import os, sys | ||
27 | |||
28 | def file2string(infilename, infile, outfile): | ||
29 | - outfile.write("// Generated from %s\n\n" % infilename) | ||
30 | + outfile.write("// Generated from %s\n\n" % os.path.basename(infilename)) | ||
31 | |||
32 | conv = ["\\%03o" % c for c in range(256)] | ||
33 | safe_chars = "ABCDEFGHIJKLMNOPQRSTUVWXYZabcdefghijklmnopqrstuvwxyz" \ | ||
diff --git a/meta-oe/recipes-multimedia/mplayer/mpv_0.35.1.bb b/meta-oe/recipes-multimedia/mplayer/mpv_0.38.0.bb index 0f50a6e8f..e9384e88d 100644 --- a/meta-oe/recipes-multimedia/mplayer/mpv_0.35.1.bb +++ b/meta-oe/recipes-multimedia/mplayer/mpv_0.38.0.bb | |||
@@ -9,20 +9,20 @@ DEPENDS = " \ | |||
9 | jpeg \ | 9 | jpeg \ |
10 | libv4l \ | 10 | libv4l \ |
11 | libass \ | 11 | libass \ |
12 | libplacebo \ | ||
12 | " | 13 | " |
13 | 14 | ||
14 | LICENSE = "GPL-2.0-or-later" | 15 | LICENSE = "GPL-2.0-or-later" |
15 | LIC_FILES_CHKSUM = "file://LICENSE.GPL;md5=b234ee4d69f5fce4486a80fdaf4a4263" | 16 | LIC_FILES_CHKSUM = "file://LICENSE.GPL;md5=b234ee4d69f5fce4486a80fdaf4a4263" |
16 | 17 | ||
17 | SRCREV_mpv = "140ec21c89d671d392877a7f3b91d67e7d7b9239" | 18 | SRCREV_mpv = "02254b92dd237f03aa0a151c2a68778c4ea848f9" |
18 | SRC_URI = "git://github.com/mpv-player/mpv;name=mpv;branch=release/0.35;protocol=https \ | 19 | SRC_URI = "git://github.com/mpv-player/mpv;name=mpv;branch=release/0.38;protocol=https \ |
19 | https://waf.io/waf-2.0.25;name=waf;subdir=git \ | 20 | file://0001-file2string-Avoid-emitting-absolute-filepaths-into-g.patch \ |
20 | " | 21 | " |
21 | SRC_URI[waf.sha256sum] = "21199cd220ccf60434133e1fd2ab8c8e5217c3799199c82722543970dc8e38d5" | ||
22 | 22 | ||
23 | S = "${WORKDIR}/git" | 23 | S = "${WORKDIR}/git" |
24 | 24 | ||
25 | inherit waf pkgconfig mime-xdg | 25 | inherit meson pkgconfig mime-xdg |
26 | 26 | ||
27 | LDFLAGS:append:riscv64 = " -latomic" | 27 | LDFLAGS:append:riscv64 = " -latomic" |
28 | 28 | ||
@@ -42,59 +42,55 @@ PACKAGECONFIG ??= " \ | |||
42 | ${@bb.utils.filter('DISTRO_FEATURES', 'opengl', d)} \ | 42 | ${@bb.utils.filter('DISTRO_FEATURES', 'opengl', d)} \ |
43 | " | 43 | " |
44 | 44 | ||
45 | PACKAGECONFIG[x11] = "--enable-x11,--disable-x11,virtual/libx11 xsp libxv libxscrnsaver libxinerama libxpresent libxext" | 45 | PACKAGECONFIG[x11] = "-Dx11=enabled,-Dx11=diabled,virtual/libx11 xsp libxv libxscrnsaver libxinerama libxpresent libxext" |
46 | PACKAGECONFIG[xv] = "--enable-xv,--disable-xv,libxv" | 46 | PACKAGECONFIG[xv] = "-Dxv=enabled,-Dxv=disabled,libxv" |
47 | PACKAGECONFIG[opengl] = "--enable-gl,--disable-gl,virtual/libgl" | 47 | PACKAGECONFIG[opengl] = "-Dgl=enabled,-Dgl=disabled,virtual/libgl" |
48 | PACKAGECONFIG[egl] = "--enable-egl,--disable-egl,virtual/egl" | 48 | PACKAGECONFIG[egl] = "-Degl=enabled,-Degl-disabled,virtual/egl" |
49 | PACKAGECONFIG[drm] = "--enable-drm,--disable-drm,libdrm" | 49 | PACKAGECONFIG[drm] = "-Ddrm=enabled,-Ddrm=disabled,libdrm" |
50 | PACKAGECONFIG[gbm] = "--enable-gbm,--disable-gbm,virtual/libgbm" | 50 | PACKAGECONFIG[gbm] = "-Dgbm=enabled,-Dgbm=disabled,virtual/libgbm" |
51 | PACKAGECONFIG[lua] = "--enable-lua,--disable-lua,lua luajit" | 51 | PACKAGECONFIG[lua] = "-Dlua=luajit,-Dlua=disabled,lua luajit" |
52 | PACKAGECONFIG[libarchive] = "--enable-libarchive,--disable-libarchive,libarchive" | 52 | PACKAGECONFIG[libarchive] = "-Dlibarchive=enabled,-Dlibarchive=disabled,libarchive" |
53 | PACKAGECONFIG[jack] = "--enable-jack, --disable-jack, jack" | 53 | PACKAGECONFIG[jack] = "-Djack=enabled,-Djack=disabled,jack" |
54 | PACKAGECONFIG[vaapi] = "--enable-vaapi,--disable-vaapi,libva" | 54 | PACKAGECONFIG[vaapi] = "-Dvaapi=enabled,-Dvaapi=disabled,libva" |
55 | PACKAGECONFIG[vdpau] = "--enable-vdpau,--disable-vdpau,libvdpau" | 55 | PACKAGECONFIG[vdpau] = "-Dvdpau=enabled,-Dvdpau=disabled,libvdpau" |
56 | PACKAGECONFIG[wayland] = "--enable-wayland,--disable-wayland,wayland wayland-native libxkbcommon" | 56 | PACKAGECONFIG[wayland] = "-Dwayland=enabled,-Dwayland=disabled,wayland wayland-native libxkbcommon" |
57 | 57 | ||
58 | python __anonymous() { | 58 | python __anonymous() { |
59 | packageconfig = (d.getVar("PACKAGECONFIG") or "").split() | 59 | packageconfig = (d.getVar("PACKAGECONFIG") or "").split() |
60 | extras = [] | 60 | extras = [] |
61 | if "x11" in packageconfig and "opengl" in packageconfig: | 61 | if "x11" in packageconfig and "opengl" in packageconfig: |
62 | extras.append(" --enable-gl-x11") | 62 | extras.append(" -Dgl-x11=enabled") |
63 | if "x11" in packageconfig and "egl" in packageconfig: | 63 | if "x11" in packageconfig and "egl" in packageconfig: |
64 | extras.append(" --enable-egl-x11") | 64 | extras.append(" -Degl-x11=enabled") |
65 | if "egl" in packageconfig and "drm" in packageconfig: | 65 | if "egl" in packageconfig and "drm" in packageconfig: |
66 | extras.append(" --enable-egl-drm") | 66 | extras.append(" -Degl-drm=enabled") |
67 | if "vaapi" in packageconfig and "x11" in packageconfig: | 67 | if "vaapi" in packageconfig and "x11" in packageconfig: |
68 | extras.append(" --enable-vaapi-x11") | 68 | extras.append(" -Dvaapi-x11=enabled") |
69 | if "vaapi" in packageconfig and "drm" in packageconfig: | 69 | if "vaapi" in packageconfig and "drm" in packageconfig: |
70 | extras.append(" --enable-vaapi-drm") | 70 | extras.append(" -Dvaapi-drm=enabled") |
71 | if "vaapi" in packageconfig and "x11" in packageconfig and "egl" in packageconfig: | 71 | if "vaapi" in packageconfig and "x11" in packageconfig and "egl" in packageconfig: |
72 | extras.append(" --enable-vaapi-x-egl") | 72 | extras.append(" -Dvaapi-x-egl=enabled") |
73 | if "vdpau" in packageconfig and "opengl" in packageconfig and "x11" in packageconfig: | 73 | if "vdpau" in packageconfig and "opengl" in packageconfig and "x11" in packageconfig: |
74 | extras.append(" --enable-vdpau-gl-x11") | 74 | extras.append(" -Dvdpau-gl-x11=enabled") |
75 | if "wayland" in packageconfig and "opengl" in packageconfig: | 75 | if "wayland" in packageconfig and "opengl" in packageconfig: |
76 | extras.append(" --enable-gl-wayland") | 76 | extras.append(" -Dgl-wayland=enabled") |
77 | if "wayland" in packageconfig and "vaapi" in packageconfig: | 77 | if "wayland" in packageconfig and "vaapi" in packageconfig: |
78 | extras.append(" --enable-vaapi-wayland") | 78 | extras.append(" -Dvaapi-wayland=enabled") |
79 | if extras: | 79 | if extras: |
80 | d.appendVar("EXTRA_OECONF", "".join(extras)) | 80 | d.appendVar("EXTRA_OECONF", "".join(extras)) |
81 | } | 81 | } |
82 | 82 | ||
83 | SIMPLE_TARGET_SYS = "${@'${TARGET_SYS}'.replace('${TARGET_VENDOR}', '')}" | 83 | #SIMPLE_TARGET_SYS = "${@'${TARGET_SYS}'.replace('${TARGET_VENDOR}', '')}" |
84 | 84 | ||
85 | EXTRA_OECONF = " \ | 85 | EXTRA_OECONF = " \ |
86 | --prefix=${prefix} \ | 86 | -Dmanpage-build=disabled \ |
87 | --target=${SIMPLE_TARGET_SYS} \ | 87 | -Dlibbluray=disabled \ |
88 | --confdir=${sysconfdir} \ | 88 | -Ddvdnav=disabled \ |
89 | --datadir=${datadir} \ | 89 | -Dcdda=disabled \ |
90 | --disable-manpage-build \ | 90 | -Duchardet=disabled \ |
91 | --disable-libbluray \ | 91 | -Drubberband=disabled \ |
92 | --disable-dvdnav \ | 92 | -Dlcms2=disabled \ |
93 | --disable-cdda \ | 93 | -Dvapoursynth=disabled \ |
94 | --disable-uchardet \ | ||
95 | --disable-rubberband \ | ||
96 | --disable-lcms2 \ | ||
97 | --disable-vapoursynth \ | ||
98 | ${PACKAGECONFIG_CONFARGS} \ | 94 | ${PACKAGECONFIG_CONFARGS} \ |
99 | " | 95 | " |
100 | 96 | ||
@@ -102,11 +98,6 @@ do_configure:append() { | |||
102 | sed -i -e 's#${WORKDIR}#<WORKDIR>#g' ${B}/config.h | 98 | sed -i -e 's#${WORKDIR}#<WORKDIR>#g' ${B}/config.h |
103 | } | 99 | } |
104 | 100 | ||
105 | link_waf() { | ||
106 | ln -s waf-2.0.25 ${S}/waf | ||
107 | } | ||
108 | do_unpack[postfuncs] += "link_waf" | ||
109 | |||
110 | FILES:${PN} += " \ | 101 | FILES:${PN} += " \ |
111 | ${datadir}/icons \ | 102 | ${datadir}/icons \ |
112 | ${datadir}/zsh \ | 103 | ${datadir}/zsh \ |