diff options
author | Khem Raj <raj.khem@gmail.com> | 2017-07-13 22:40:07 -0700 |
---|---|---|
committer | Martin Jansa <Martin.Jansa@gmail.com> | 2017-07-24 18:57:35 +0200 |
commit | 9dfececc96801e2e06d6140848bf21c92db1d2f9 (patch) | |
tree | dc6d9ff0191fe7e53dbd67572a4348607731149b | |
parent | ecd60444b50b06f6fd234fea33c614c23950d5bc (diff) | |
download | meta-openembedded-9dfececc96801e2e06d6140848bf21c92db1d2f9.tar.gz |
libgtop: Fix build with musl
Signed-off-by: Khem Raj <raj.khem@gmail.com>
Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
-rw-r--r-- | meta-gnome/recipes-gnome/libgtop/libgtop/0001-netload-Include-libc-net-headers-unconditionally.patch | 46 | ||||
-rw-r--r-- | meta-gnome/recipes-gnome/libgtop/libgtop_2.30.0.bb | 3 |
2 files changed, 49 insertions, 0 deletions
diff --git a/meta-gnome/recipes-gnome/libgtop/libgtop/0001-netload-Include-libc-net-headers-unconditionally.patch b/meta-gnome/recipes-gnome/libgtop/libgtop/0001-netload-Include-libc-net-headers-unconditionally.patch new file mode 100644 index 000000000..c4f7da4bf --- /dev/null +++ b/meta-gnome/recipes-gnome/libgtop/libgtop/0001-netload-Include-libc-net-headers-unconditionally.patch | |||
@@ -0,0 +1,46 @@ | |||
1 | From 3c6f70e50cb586ac4add4dea627c316242691040 Mon Sep 17 00:00:00 2001 | ||
2 | From: Khem Raj <raj.khem@gmail.com> | ||
3 | Date: Thu, 13 Jul 2017 09:17:29 -0700 | ||
4 | Subject: [PATCH] netload: Include libc net headers unconditionally | ||
5 | |||
6 | This fixes compile with musl, and this conditional | ||
7 | is not needed now a days if we are still using glibc < 1.0 | ||
8 | we have other bigger problems | ||
9 | |||
10 | Signed-off-by: Khem Raj <raj.khem@gmail.com> | ||
11 | --- | ||
12 | sysdeps/linux/netload.c | 11 ----------- | ||
13 | 1 file changed, 11 deletions(-) | ||
14 | |||
15 | diff --git a/sysdeps/linux/netload.c b/sysdeps/linux/netload.c | ||
16 | index c275db2..446bddd 100644 | ||
17 | --- a/sysdeps/linux/netload.c | ||
18 | +++ b/sysdeps/linux/netload.c | ||
19 | @@ -34,8 +34,6 @@ | ||
20 | #include <sys/socket.h> | ||
21 | #include <sys/ioctl.h> | ||
22 | |||
23 | -#if !defined (_LIBC) && defined (__GNU_LIBRARY__) && __GNU_LIBRARY__ > 1 | ||
24 | -/* GNU LibC */ | ||
25 | #include <net/if.h> | ||
26 | #include <netinet/ip_icmp.h> | ||
27 | #include <netinet/in.h> | ||
28 | @@ -43,15 +41,6 @@ | ||
29 | #include <netinet/tcp.h> | ||
30 | #include <netinet/udp.h> | ||
31 | #include <net/if.h> | ||
32 | -#else /* Libc 5 */ | ||
33 | -#include <linux/if.h> | ||
34 | -#include <linux/in.h> | ||
35 | -#include <linux/ip.h> | ||
36 | -#include <linux/icmp.h> | ||
37 | -#include <linux/tcp.h> | ||
38 | -#include <linux/udp.h> | ||
39 | -#endif | ||
40 | - | ||
41 | |||
42 | #ifdef HAVE_IFADDRS_H | ||
43 | /* needed for IPV6 support */ | ||
44 | -- | ||
45 | 2.13.2 | ||
46 | |||
diff --git a/meta-gnome/recipes-gnome/libgtop/libgtop_2.30.0.bb b/meta-gnome/recipes-gnome/libgtop/libgtop_2.30.0.bb index d79b9e5d4..946d11845 100644 --- a/meta-gnome/recipes-gnome/libgtop/libgtop_2.30.0.bb +++ b/meta-gnome/recipes-gnome/libgtop/libgtop_2.30.0.bb | |||
@@ -6,6 +6,9 @@ inherit gnomebase lib_package gtk-doc distro_features_check gobject-introspectio | |||
6 | # depends on libxau | 6 | # depends on libxau |
7 | REQUIRED_DISTRO_FEATURES = "x11" | 7 | REQUIRED_DISTRO_FEATURES = "x11" |
8 | 8 | ||
9 | SRC_URI = "${GNOME_MIRROR}/${GNOMEBN}/${@gnome_verdir("${PV}")}/${GNOMEBN}-${PV}.tar.${GNOME_COMPRESS_TYPE};name=archive \ | ||
10 | file://0001-netload-Include-libc-net-headers-unconditionally.patch \ | ||
11 | " | ||
9 | SRC_URI[archive.md5sum] = "ee29a9ef60659ebf4b075ac281f71cb2" | 12 | SRC_URI[archive.md5sum] = "ee29a9ef60659ebf4b075ac281f71cb2" |
10 | SRC_URI[archive.sha256sum] = "463bcbe5737b1b93f3345ee34abf601e8eb864f507c49ff1921c2737abafc1e5" | 13 | SRC_URI[archive.sha256sum] = "463bcbe5737b1b93f3345ee34abf601e8eb864f507c49ff1921c2737abafc1e5" |
11 | 14 | ||