diff options
author | Khem Raj <raj.khem@gmail.com> | 2020-08-23 23:43:32 -0700 |
---|---|---|
committer | Khem Raj <raj.khem@gmail.com> | 2020-08-24 13:04:03 -0700 |
commit | 9949d2714dfb674482d69c78de421b47adef7732 (patch) | |
tree | ba646b598b8f7a3b447e3302d7af6ef2a65acc96 | |
parent | 5efb06176add13c4b8287c9972651dcac94adf79 (diff) | |
download | meta-openembedded-9949d2714dfb674482d69c78de421b47adef7732.tar.gz |
kernel-selftest: Disable vm tests for mips/arm
Include lib and kernel subdirs as vm tests need headers from it in 5.8+
(test_hmm_uapi.h) see [1]
It now uses tests which are not compatible on arm starting with 5.8+
[1] https://lkml.org/lkml/2020/4/22/1654
Signed-off-by: Khem Raj <raj.khem@gmail.com>
-rw-r--r-- | meta-oe/recipes-kernel/kernel-selftest/kernel-selftest.bb | 12 |
1 files changed, 8 insertions, 4 deletions
diff --git a/meta-oe/recipes-kernel/kernel-selftest/kernel-selftest.bb b/meta-oe/recipes-kernel/kernel-selftest/kernel-selftest.bb index 2a41aec23..2b5ebcc27 100644 --- a/meta-oe/recipes-kernel/kernel-selftest/kernel-selftest.bb +++ b/meta-oe/recipes-kernel/kernel-selftest/kernel-selftest.bb | |||
@@ -4,7 +4,7 @@ LICENSE = "GPLv2" | |||
4 | 4 | ||
5 | LIC_FILES_CHKSUM = "file://../COPYING;md5=bbea815ee2795b2f4230826c0c6b8814" | 5 | LIC_FILES_CHKSUM = "file://../COPYING;md5=bbea815ee2795b2f4230826c0c6b8814" |
6 | 6 | ||
7 | DEPENDS = "rsync-native llvm-native libhugetlbfs" | 7 | DEPENDS = "rsync-native llvm-native" |
8 | 8 | ||
9 | # for musl libc | 9 | # for musl libc |
10 | SRC_URI_append_libc-musl = "\ | 10 | SRC_URI_append_libc-musl = "\ |
@@ -20,15 +20,16 @@ SRC_URI += "file://run-ptest \ | |||
20 | # if you have older kernel than that you need to remove it from PACKAGECONFIG | 20 | # if you have older kernel than that you need to remove it from PACKAGECONFIG |
21 | PACKAGECONFIG ??= "bpf firmware vm" | 21 | PACKAGECONFIG ??= "bpf firmware vm" |
22 | PACKAGECONFIG_remove_x86 = "bpf" | 22 | PACKAGECONFIG_remove_x86 = "bpf" |
23 | PACKAGECONFIG_remove_arm = "bpf" | 23 | PACKAGECONFIG_remove_arm = "bpf vm" |
24 | # host ptrace.h is used to compile BPF target but mips ptrace.h is needed | 24 | # host ptrace.h is used to compile BPF target but mips ptrace.h is needed |
25 | # progs/loop1.c:21:9: error: incomplete definition of type 'struct user_pt_regs' | 25 | # progs/loop1.c:21:9: error: incomplete definition of type 'struct user_pt_regs' |
26 | # m = PT_REGS_RC(ctx); | 26 | # m = PT_REGS_RC(ctx); |
27 | PACKAGECONFIG_remove_qemumips = "bpf" | 27 | # vm tests need libhugetlbfs starting 5.8+ (https://lkml.org/lkml/2020/4/22/1654) |
28 | PACKAGECONFIG_remove_qemumips = "bpf vm" | ||
28 | 29 | ||
29 | PACKAGECONFIG[bpf] = ",,elfutils libcap libcap-ng rsync-native," | 30 | PACKAGECONFIG[bpf] = ",,elfutils libcap libcap-ng rsync-native," |
30 | PACKAGECONFIG[firmware] = ",,libcap, bash" | 31 | PACKAGECONFIG[firmware] = ",,libcap, bash" |
31 | PACKAGECONFIG[vm] = ",,libcap,libgcc bash" | 32 | PACKAGECONFIG[vm] = ",,libcap libhugetlbfs,libgcc bash" |
32 | 33 | ||
33 | do_patch[depends] += "virtual/kernel:do_shared_workdir" | 34 | do_patch[depends] += "virtual/kernel:do_shared_workdir" |
34 | 35 | ||
@@ -49,10 +50,13 @@ EXTRA_OEMAKE = '\ | |||
49 | AR="${AR}" \ | 50 | AR="${AR}" \ |
50 | LD="${LD}" \ | 51 | LD="${LD}" \ |
51 | DESTDIR="${D}" \ | 52 | DESTDIR="${D}" \ |
53 | MACHINE="${ARCH}" \ | ||
52 | ' | 54 | ' |
53 | 55 | ||
54 | KERNEL_SELFTEST_SRC ?= "Makefile \ | 56 | KERNEL_SELFTEST_SRC ?= "Makefile \ |
55 | include \ | 57 | include \ |
58 | kernel \ | ||
59 | lib \ | ||
56 | tools \ | 60 | tools \ |
57 | scripts \ | 61 | scripts \ |
58 | arch \ | 62 | arch \ |