summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2022-09-14 21:29:10 -0700
committerKhem Raj <raj.khem@gmail.com>2022-09-14 21:33:38 -0700
commit98998755aac2a8294d7658f93f70f87f50509714 (patch)
tree2badc16348b5c6b325b0ff42878f0ac397ac49d3
parent5ce4505210b2431586206ec1c57c9786046e2058 (diff)
downloadmeta-openembedded-98998755aac2a8294d7658f93f70f87f50509714.tar.gz
sqlite: Drop sqlite2 recipe
Last update was in 2005, nothing in meta-openembedded layers need it Signed-off-by: Khem Raj <raj.khem@gmail.com>
-rw-r--r--meta-oe/recipes-core/packagegroups/packagegroup-meta-oe.bb1
-rw-r--r--meta-oe/recipes-dbs/sqlite/sqlite-2.8.17/0001-shell.c-Fix-format-not-a-string-literal-warning.patch32
-rw-r--r--meta-oe/recipes-dbs/sqlite/sqlite-2.8.17/mainmk_build_dynamic.patch32
-rw-r--r--meta-oe/recipes-dbs/sqlite/sqlite-2.8.17/mainmk_no_tcl.patch20
-rw-r--r--meta-oe/recipes-dbs/sqlite/sqlite-2.8.17/sqlite.pc12
-rw-r--r--meta-oe/recipes-dbs/sqlite/sqlite_2.8.17.bb61
6 files changed, 0 insertions, 158 deletions
diff --git a/meta-oe/recipes-core/packagegroups/packagegroup-meta-oe.bb b/meta-oe/recipes-core/packagegroups/packagegroup-meta-oe.bb
index 756ba46e3..cd99fb48c 100644
--- a/meta-oe/recipes-core/packagegroups/packagegroup-meta-oe.bb
+++ b/meta-oe/recipes-core/packagegroups/packagegroup-meta-oe.bb
@@ -222,7 +222,6 @@ RDEPENDS:packagegroup-meta-oe-dbs ="\
222 psqlodbc \ 222 psqlodbc \
223 rocksdb \ 223 rocksdb \
224 soci \ 224 soci \
225 sqlite \
226" 225"
227RDEPENDS:packagegroup-meta-oe-dbs:remove:libc-musl:powerpc = "rocksdb" 226RDEPENDS:packagegroup-meta-oe-dbs:remove:libc-musl:powerpc = "rocksdb"
228 227
diff --git a/meta-oe/recipes-dbs/sqlite/sqlite-2.8.17/0001-shell.c-Fix-format-not-a-string-literal-warning.patch b/meta-oe/recipes-dbs/sqlite/sqlite-2.8.17/0001-shell.c-Fix-format-not-a-string-literal-warning.patch
deleted file mode 100644
index c5d7c0c81..000000000
--- a/meta-oe/recipes-dbs/sqlite/sqlite-2.8.17/0001-shell.c-Fix-format-not-a-string-literal-warning.patch
+++ /dev/null
@@ -1,32 +0,0 @@
1From 443980ddc82fb40e2e1f9544f2be169bd23dd246 Mon Sep 17 00:00:00 2001
2From: Khem Raj <raj.khem@gmail.com>
3Date: Sat, 17 Jun 2017 16:49:24 -0700
4Subject: [PATCH] shell.c: Fix format not a string literal warning
5
6src/shell.c:695:20: error: format not a string literal and no format arguments [-Werror=format-security]
7| fprintf(stderr,zHelp);
8| ^~~~~
9
10Upstream-Status: Pending
11
12Signed-off-by: Khem Raj <raj.khem@gmail.com>
13---
14 src/shell.c | 2 +-
15 1 file changed, 1 insertion(+), 1 deletion(-)
16
17diff --git a/src/shell.c b/src/shell.c
18index bb46c49..3c6fe0f 100644
19--- a/src/shell.c
20+++ b/src/shell.c
21@@ -692,7 +692,7 @@ static int do_meta_command(char *zLine, struct callback_data *p){
22 }else
23
24 if( c=='h' && strncmp(azArg[0], "help", n)==0 ){
25- fprintf(stderr,zHelp);
26+ fprintf(stderr, "%s", zHelp);
27 }else
28
29 if( c=='i' && strncmp(azArg[0], "indices", n)==0 && nArg>1 ){
30--
312.13.1
32
diff --git a/meta-oe/recipes-dbs/sqlite/sqlite-2.8.17/mainmk_build_dynamic.patch b/meta-oe/recipes-dbs/sqlite/sqlite-2.8.17/mainmk_build_dynamic.patch
deleted file mode 100644
index 914422f1d..000000000
--- a/meta-oe/recipes-dbs/sqlite/sqlite-2.8.17/mainmk_build_dynamic.patch
+++ /dev/null
@@ -1,32 +0,0 @@
1diff -urN sqlite-2.8.17.orig/main.mk sqlite-2.8.17/main.mk
2--- sqlite-2.8.17.orig/main.mk 2005-04-23 22:43:23.000000000 +0000
3+++ sqlite-2.8.17/main.mk 2009-04-02 20:10:36.000000000 +0000
4@@ -139,7 +139,7 @@
5 # This is the default Makefile target. The objects listed here
6 # are what get build when you type just "make" with no arguments.
7 #
8-all: sqlite.h config.h libsqlite.a sqlite$(EXE)
9+all: sqlite.h config.h libsqlite.so sqlite$(EXE)
10
11 # Generate the file "last_change" which contains the date of change
12 # of the most recently modified source code file
13@@ -148,13 +148,12 @@
14 cat $(SRC) | grep '$$Id: ' | sort +4 | tail -1 \
15 | awk '{print $$5,$$6}' >last_change
16
17-libsqlite.a: $(LIBOBJ)
18- $(AR) libsqlite.a $(LIBOBJ)
19- $(RANLIB) libsqlite.a
20-
21-sqlite$(EXE): $(TOP)/src/shell.c libsqlite.a sqlite.h
22- $(TCCX) $(READLINE_FLAGS) -o sqlite$(EXE) $(TOP)/src/shell.c \
23- libsqlite.a $(LIBREADLINE) $(THREADLIB)
24+libsqlite.so: $(LIBOBJ)
25+ $(CC) $(LDFLAGS) -shared -o libsqlite.so -Wl,-soname,libsqlite.so.0 $(LIBOBJ)
26+
27+sqlite$(EXE): $(TOP)/src/shell.c libsqlite.so sqlite.h
28+ $(TCCX) $(LDFLAGS) $(READLINE_FLAGS) -o sqlite$(EXE) $(TOP)/src/shell.c \
29+ -lsqlite $(LIBREADLINE) $(THREADLIB)
30
31 sqlite_analyzer$(EXE): $(TOP)/src/tclsqlite.c libsqlite.a $(TESTSRC) \
32 $(TOP)/tool/spaceanal.tcl
diff --git a/meta-oe/recipes-dbs/sqlite/sqlite-2.8.17/mainmk_no_tcl.patch b/meta-oe/recipes-dbs/sqlite/sqlite-2.8.17/mainmk_no_tcl.patch
deleted file mode 100644
index b84b6486e..000000000
--- a/meta-oe/recipes-dbs/sqlite/sqlite-2.8.17/mainmk_no_tcl.patch
+++ /dev/null
@@ -1,20 +0,0 @@
1diff -bur sqlite-2.8.17~orig/main.mk sqlite-2.8.17/main.mk
2--- sqlite-2.8.17~orig/main.mk 2006-02-13 04:09:33.000000000 -0600
3+++ sqlite-2.8.17/main.mk 2006-02-13 04:15:42.000000000 -0600
4@@ -58,7 +58,7 @@
5 expr.o func.o hash.o insert.o \
6 main.o opcodes.o os.o pager.o parse.o pragma.o printf.o random.o \
7 select.o table.o tokenize.o trigger.o update.o util.o \
8- vacuum.o vdbe.o vdbeaux.o where.o tclsqlite.o
9+ vacuum.o vdbe.o vdbeaux.o where.o
10
11 # All of the source code files.
12 #
13@@ -91,7 +91,6 @@
14 $(TOP)/src/sqlite.h.in \
15 $(TOP)/src/sqliteInt.h \
16 $(TOP)/src/table.c \
17- $(TOP)/src/tclsqlite.c \
18 $(TOP)/src/tokenize.c \
19 $(TOP)/src/trigger.c \
20 $(TOP)/src/update.c \
diff --git a/meta-oe/recipes-dbs/sqlite/sqlite-2.8.17/sqlite.pc b/meta-oe/recipes-dbs/sqlite/sqlite-2.8.17/sqlite.pc
deleted file mode 100644
index 6bc742eec..000000000
--- a/meta-oe/recipes-dbs/sqlite/sqlite-2.8.17/sqlite.pc
+++ /dev/null
@@ -1,12 +0,0 @@
1# Package Information for pkg-config
2
3prefix=/usr
4exec_prefix=${prefix}
5libdir=${exec_prefix}/lib
6includedir=${prefix}/include
7
8Name: SQLite
9Description: SQL database engine
10Version: 2.8.17
11Libs: -L${libdir} -lsqlite
12Cflags: -I${includedir}
diff --git a/meta-oe/recipes-dbs/sqlite/sqlite_2.8.17.bb b/meta-oe/recipes-dbs/sqlite/sqlite_2.8.17.bb
deleted file mode 100644
index bb62afab4..000000000
--- a/meta-oe/recipes-dbs/sqlite/sqlite_2.8.17.bb
+++ /dev/null
@@ -1,61 +0,0 @@
1SUMMARY = "An Embeddable SQL Database Engine"
2HOMEPAGE = "http://www.sqlite.org/"
3SECTION = "libs"
4DEPENDS = "readline ncurses"
5LICENSE = "PD"
6LIC_FILES_CHKSUM = "file://src/main.c;beginline=1;endline=10;md5=e98469a8efa024a38ad5b2e4b92f4a96"
7
8PR = "r7"
9
10SRC_URI = "http://www.hwaci.com/sw/sqlite/sqlite-${PV}.tar.gz \
11 file://mainmk_build_dynamic.patch \
12 file://mainmk_no_tcl.patch \
13 file://sqlite.pc \
14 file://0001-shell.c-Fix-format-not-a-string-literal-warning.patch \
15 "
16
17SOURCES = "attach.o auth.o btree.o btree_rb.o build.o copy.o date.o delete.o \
18 expr.o func.o hash.o insert.o main.o opcodes.o os.o pager.o \
19 parse.o pragma.o printf.o random.o select.o table.o tokenize.o \
20 trigger.o update.o util.o vacuum.o vdbe.o vdbeaux.o where.o"
21
22inherit autotools pkgconfig
23
24do_configure() {
25 echo "main.mk is patched, no need to configure"
26 # make pkgconfig.bbclass pick this up
27 cp ${WORKDIR}/sqlite.pc ${S}
28}
29
30do_compile() {
31 oe_runmake -f ${S}/Makefile.linux-gcc \
32 TOP="${S}" \
33 BCC="${BUILD_CC}" \
34 TCC="${CC}" \
35 OPTS="-fPIC -D'INTPTR_TYPE=int'" \
36 TCL_FLAGS= LIBTCL= \
37 READLINE_FLAGS="-DHAVE_READLINE=1 -I${STAGING_INCDIR}" \
38 LIBREADLINE="-L. -L${STAGING_LIBDIR} -lreadline -lncurses"
39}
40
41do_install() {
42 install -d ${D}${libdir} ${D}${bindir}
43 install sqlite ${D}${bindir}
44 install -m 0755 libsqlite.so ${D}${libdir}/libsqlite.so.0.8.6
45 ln -sf libsqlite.so.0.8.6 ${D}${libdir}/libsqlite.so
46 ln -sf libsqlite.so.0.8.6 ${D}${libdir}/libsqlite.so.0
47 ln -sf libsqlite.so.0.8.6 ${D}${libdir}/libsqlite.so.0.8
48 install -d ${D}${includedir}
49 install -m 0644 sqlite.h ${D}${includedir}/sqlite.h
50 install -d ${D}${libdir}/pkgconfig
51 install -m 0644 ${S}/sqlite.pc ${D}${libdir}/pkgconfig/sqlite.pc
52}
53
54PACKAGES += "${PN}-bin"
55FILES:${PN}-bin = "${bindir}/*"
56FILES:${PN} = "${libdir}/*.so.*"
57
58SRC_URI[md5sum] = "838dbac20b56d2c4292e98848505a05b"
59SRC_URI[sha256sum] = "3f35ebfb67867fb5b583a03e480f900206af637efe7179b32294a6a0cf806f37"
60
61BBCLASSEXTEND = "native"