summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2018-09-06 11:50:16 -0700
committerKhem Raj <raj.khem@gmail.com>2018-09-09 10:46:29 -0700
commit973578148d343222e8a6a89076f515a4094a7844 (patch)
treed2c48d8a909271ddb226bc7b1c19a451321c4204
parent5cb9dae677066a0367a3eeef1953814d0c1fb6ca (diff)
downloadmeta-openembedded-973578148d343222e8a6a89076f515a4094a7844.tar.gz
uftrace: Upgrade to 0.8.3
* Deliberately provide a non existing path to with_elfutils so it does not copy libelf.so into its staged install and become a provider for that library while elfutils should be the legit provider and this package should just list it in its rdeps * Fix build with musl Signed-off-by: Khem Raj <raj.khem@gmail.com>
-rw-r--r--meta-oe/recipes-devtools/uftrace/uftrace/0001-include-dlfcn.h-for-RTLD_DEFAULT.patch39
-rw-r--r--meta-oe/recipes-devtools/uftrace/uftrace_0.8.3.bb (renamed from meta-oe/recipes-devtools/uftrace/uftrace_0.8.bb)12
2 files changed, 47 insertions, 4 deletions
diff --git a/meta-oe/recipes-devtools/uftrace/uftrace/0001-include-dlfcn.h-for-RTLD_DEFAULT.patch b/meta-oe/recipes-devtools/uftrace/uftrace/0001-include-dlfcn.h-for-RTLD_DEFAULT.patch
new file mode 100644
index 000000000..fe7aac931
--- /dev/null
+++ b/meta-oe/recipes-devtools/uftrace/uftrace/0001-include-dlfcn.h-for-RTLD_DEFAULT.patch
@@ -0,0 +1,39 @@
1From cdf7f2e394fcfb93a61f509ae3388f29540a6b35 Mon Sep 17 00:00:00 2001
2From: Khem Raj <raj.khem@gmail.com>
3Date: Sat, 8 Sep 2018 11:56:13 -0700
4Subject: [PATCH] include dlfcn.h for RTLD_DEFAULT
5
6Fixes
7plthook.c:128:41: error: use of undeclared identifier 'RTLD_DEFAULT'
8
9Upstream-Status: Submitted [https://github.com/namhyung/uftrace/pull/487]
10Signed-off-by: Khem Raj <raj.khem@gmail.com>
11---
12 libmcount/plthook.c | 1 +
13 utils/debug.c | 1 +
14 2 files changed, 2 insertions(+)
15
16diff --git a/libmcount/plthook.c b/libmcount/plthook.c
17index d9d84f0..d54f5e8 100644
18--- a/libmcount/plthook.c
19+++ b/libmcount/plthook.c
20@@ -6,6 +6,7 @@
21 #include <sys/mman.h>
22 #include <pthread.h>
23 #include <assert.h>
24+#include <dlfcn.h>
25
26 /* This should be defined before #include "utils.h" */
27 #define PR_FMT "mcount"
28diff --git a/utils/debug.c b/utils/debug.c
29index 2134b09..5460def 100644
30--- a/utils/debug.c
31+++ b/utils/debug.c
32@@ -13,6 +13,7 @@
33 #include <assert.h>
34 #include <limits.h>
35 #include <inttypes.h>
36+#include <dlfcn.h>
37
38 #include "utils/utils.h"
39
diff --git a/meta-oe/recipes-devtools/uftrace/uftrace_0.8.bb b/meta-oe/recipes-devtools/uftrace/uftrace_0.8.3.bb
index 82b179521..e377a5c9d 100644
--- a/meta-oe/recipes-devtools/uftrace/uftrace_0.8.bb
+++ b/meta-oe/recipes-devtools/uftrace/uftrace_0.8.3.bb
@@ -10,15 +10,19 @@ DEPENDS_append_libc-musl = " argp-standalone"
10 10
11inherit autotools 11inherit autotools
12 12
13SRCREV = "5af9ff9fa89c340617e52c8ed05798b352a7145c" 13# v0.8.3
14SRC_URI = "git://github.com/namhyung/${BPN}" 14SRCREV = "8b723a6fae2ef30495cd6279774fba9c95cd9c88"
15SRC_URI = "git://github.com/namhyung/${BPN} \
16 file://0001-include-dlfcn.h-for-RTLD_DEFAULT.patch \
17 "
15S = "${WORKDIR}/git" 18S = "${WORKDIR}/git"
16 19
17LDFLAGS_append_libc-musl = " -largp" 20LDFLAGS_append_libc-musl = " -largp"
18EXTRA_OECONF = "ARCH=${TARGET_ARCH}" 21EXTRA_UFTRACE_OECONF = "ARCH=${TARGET_ARCH} \
22 with_elfutils=/use/libelf/from/sysroot"
19 23
20do_configure() { 24do_configure() {
21 ${S}/configure ${EXTRA_OECONF} 25 ${S}/configure ${EXTRA_UFTRACE_OECONF}
22} 26}
23 27
24FILES_SOLIBSDEV = "" 28FILES_SOLIBSDEV = ""