summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorJamin Lin <jamin_lin@aspeedtech.com>2024-12-10 10:20:42 +0800
committerKhem Raj <raj.khem@gmail.com>2024-12-10 13:43:54 -0800
commit96d39d9d9d9eb3636fdf4939c4e8e357c4e7d4da (patch)
tree42051b3fdd3cf32c62b9279642f02b6acf2e79fe
parent59cb2ecdbd78fdbd1d145c410e5e0e5a5bd41420 (diff)
downloadmeta-openembedded-96d39d9d9d9eb3636fdf4939c4e8e357c4e7d4da.tar.gz
python3-pyhsslms: Add 2.0.0 recipe
This recipe was placed in meta-arm meta layer, https://git.yoctoproject.org/meta-arm/tree/meta-arm/recipes-devtools/python/python3-pyhsslms_2.0.0.bb However, users may want to build this python module but do not want to add "meta-arm" meta layer. To make this recipe more flexible, move this recipe from "meta-arm" to "meta-openembedded/meta-python" meta layer. This python module is used for supporting LMS algorithm and it use pure Software to sign/verify with LMS algorithm. Please see official github for detail, https://github.com/russhousley/pyhsslms Signed-off-by: Jamin Lin <jamin_lin@aspeedtech.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
-rw-r--r--meta-python/recipes-devtools/python/python3-pyhsslms_2.0.0.bb21
1 files changed, 21 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-pyhsslms_2.0.0.bb b/meta-python/recipes-devtools/python/python3-pyhsslms_2.0.0.bb
new file mode 100644
index 0000000000..3b54e36199
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-pyhsslms_2.0.0.bb
@@ -0,0 +1,21 @@
1SUMMARY = "Pure-Python implementation of HSS/LMS Digital Signatures (RFC 8554)"
2HOMEPAGE ="https://pypi.org/project/pyhsslms"
3LICENSE = "MIT"
4LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=bbc59ef8bf238c2902ca816b87b58571"
5
6inherit python_setuptools_build_meta
7
8# Maintainer refused to upload source to pypi.org, but said he would in a
9# future release. In the meantime, do github
10SRC_URI = "git:///github.com/russhousley/pyhsslms.git;branch=master;protocol=https"
11SRCREV = "c798728deed6d3f681c9e6bfd7fe8a6705f5638b"
12
13S = "${WORKDIR}/git"
14
15RDEPENDS:${PN} += " \
16 python3-core \
17 python3-crypt \
18 python3-netclient \
19"
20
21BBCLASSEXTEND = "native nativesdk"