diff options
author | Koen Kooi <koen@dominion.thruhere.net> | 2012-11-21 14:17:58 +0100 |
---|---|---|
committer | Joe MacDonald <joe.macdonald@windriver.com> | 2012-11-21 08:32:18 -0500 |
commit | 9637cb304f1e9116b037d0afd69014836a2fa512 (patch) | |
tree | 90ac46d97c8ac17bcd416acfdb0c1c76ef34f86e | |
parent | b69b6e04f12b2fc45a3ebac8c741bda41fea6409 (diff) | |
download | meta-openembedded-9637cb304f1e9116b037d0afd69014836a2fa512.tar.gz |
Revert "ntp: Clean up recipes"
This breaks the upgrade path since 'ntpdate' has been renamed to 'ntp-date'. I don't know why this patch was applied when it was shot down on review.
This reverts commit d102fc3fe64844f5c85ff350874728139a63fe78.
-rw-r--r-- | meta-networking/recipes-support/ntp/ntp-ssl_4.2.6p5.bb | 11 | ||||
-rw-r--r-- | meta-networking/recipes-support/ntp/ntp.inc | 49 | ||||
-rw-r--r-- | meta-networking/recipes-support/ntp/ntp_4.2.6p5.bb | 43 |
3 files changed, 53 insertions, 50 deletions
diff --git a/meta-networking/recipes-support/ntp/ntp-ssl_4.2.6p5.bb b/meta-networking/recipes-support/ntp/ntp-ssl_4.2.6p5.bb index e5851ae9af..a158990792 100644 --- a/meta-networking/recipes-support/ntp/ntp-ssl_4.2.6p5.bb +++ b/meta-networking/recipes-support/ntp/ntp-ssl_4.2.6p5.bb | |||
@@ -1,10 +1,11 @@ | |||
1 | require ntp.inc | 1 | require ntp_${PV}.bb |
2 | DEPENDS = "openssl" | 2 | DEPENDS = "openssl" |
3 | 3 | ||
4 | S = "${WORKDIR}/ntp-${PV}" | 4 | S = "${WORKDIR}/ntp-${PV}" |
5 | 5 | ||
6 | EXTRA_OECONF += "--with-openssl-libdir=${STAGING_LIBDIR} \ | 6 | EXTRA_OECONF = "--with-openssl-libdir=${STAGING_LIBDIR} \ |
7 | --with-openssl-incdir=${STAGING_INCDIR}/openssl \ | 7 | --with-openssl-incdir=${STAGING_INCDIR}/openssl" |
8 | --with-crypto" | ||
9 | 8 | ||
10 | FILES_${PN} += "${bindir}/sntp ${bindir}/ntp-keygen" | 9 | |
10 | SRC_URI[md5sum] = "98e16c7aa4ecd4c004b51bff18962e95" | ||
11 | SRC_URI[sha256sum] = "9f4a5271a285d390c9225e3ea28f70049ea377d30fc6de4659007cfff278671a" | ||
diff --git a/meta-networking/recipes-support/ntp/ntp.inc b/meta-networking/recipes-support/ntp/ntp.inc index e2dbdad39a..1d740f00fb 100644 --- a/meta-networking/recipes-support/ntp/ntp.inc +++ b/meta-networking/recipes-support/ntp/ntp.inc | |||
@@ -8,19 +8,14 @@ LICENSE = "ntp" | |||
8 | LIC_FILES_CHKSUM = "file://COPYRIGHT;md5=fea4b50c33b18c2194b4b1c9ca512670" | 8 | LIC_FILES_CHKSUM = "file://COPYRIGHT;md5=fea4b50c33b18c2194b4b1c9ca512670" |
9 | RSUGGESTS_${PN} = "iana-etc" | 9 | RSUGGESTS_${PN} = "iana-etc" |
10 | 10 | ||
11 | INC_PR = "r1" | 11 | SRC_URI = "http://www.eecis.udel.edu/~ntp/ntp_spool/ntp4/ntp-4.2/${P}.tar.gz \ |
12 | 12 | file://ipv6only-workaround.patch \ | |
13 | SRC_URI = "http://www.eecis.udel.edu/~ntp/ntp_spool/ntp4/ntp-4.2/ntp-${PV}.tar.gz \ | ||
14 | file://tickadj.c.patch \ | ||
15 | file://ntp-4.2.4_p6-nano.patch \ | ||
16 | file://ntpd \ | 13 | file://ntpd \ |
17 | file://ntp.conf \ | 14 | file://ntp.conf \ |
18 | file://ntpdate \ | 15 | file://ntpdate \ |
16 | file://ntpd.service \ | ||
19 | " | 17 | " |
20 | 18 | ||
21 | SRC_URI[md5sum] = "00df80a84ec9528fcfb09498075525bc" | ||
22 | SRC_URI[sha256sum] = "d6ab8371f9d31e594eb6922823d5ccd03dcc4e9d84b0e23ea25ac1405432f91c" | ||
23 | |||
24 | inherit autotools update-rc.d | 19 | inherit autotools update-rc.d |
25 | 20 | ||
26 | INITSCRIPT_NAME = "ntpd" | 21 | INITSCRIPT_NAME = "ntpd" |
@@ -29,46 +24,12 @@ INITSCRIPT_PARAMS = "defaults" | |||
29 | 24 | ||
30 | # The ac_cv_header_readline_history is to stop ntpdc depending on either | 25 | # The ac_cv_header_readline_history is to stop ntpdc depending on either |
31 | # readline or curses | 26 | # readline or curses |
32 | EXTRA_OECONF += " --with-net-snmp-config=no --without-ntpsnmpd ac_cv_header_readline_history_h=no" | 27 | EXTRA_OECONF = "--without-openssl --without-crypto ac_cv_header_readline_history_h=no" |
33 | CFLAGS_append = " -DPTYS_ARE_GETPT -DPTYS_ARE_SEARCHED" | 28 | CFLAGS_append = " -DPTYS_ARE_GETPT -DPTYS_ARE_SEARCHED" |
34 | 29 | ||
35 | do_configure(){ | 30 | PACKAGES += "ntpdate ${PN}-bin ${PN}-tickadj ${PN}-utils" |
36 | oe_runconf | ||
37 | } | ||
38 | |||
39 | do_install_append() { | ||
40 | install -d ${D}/${sysconfdir}/init.d | ||
41 | install -m 644 ${WORKDIR}/ntp.conf ${D}/${sysconfdir} | ||
42 | install -m 755 ${WORKDIR}/ntpd ${D}/${sysconfdir}/init.d | ||
43 | install -d ${D}/${sysconfdir}/network/if-up.d | ||
44 | install -m 755 ${WORKDIR}/ntpdate ${D}/${sysconfdir}/network/if-up.d | ||
45 | } | ||
46 | |||
47 | FILES_${PN}-bin = "${bindir}/ntp-wait ${bindir}/ntpdc ${bindir}/ntpq ${bindir}/ntptime ${bindir}/ntptrace" | ||
48 | FILES_${PN} = "${bindir}/ntpd ${sysconfdir}/ntp.conf ${sysconfdir}/init.d/ntpd ${sbindir} ${libdir}" | ||
49 | FILES_${PN}-tickadj = "${bindir}/tickadj" | ||
50 | FILES_${PN}-utils = "${bindir}/*" | ||
51 | FILES_${PN}-date += "${bindir}/ntpdate ${sysconfdir}/network/if-up.d/ntpdate" | ||
52 | |||
53 | # ntp originally includes tickadj. It's split off for inclusion in small firmware images on platforms | ||
54 | # with wonky clocks (e.g. OpenSlug) | ||
55 | RDEPENDS_${PN} = "${PN}-tickadj" | ||
56 | |||
57 | PACKAGES += "${PN}-date ${PN}-bin ${PN}-tickadj ${PN}-utils" | ||
58 | # NOTE: you don't need ntpdate, use "ntpd -q -g -x" | 31 | # NOTE: you don't need ntpdate, use "ntpd -q -g -x" |
59 | # or the ntpdate systemd service | 32 | # or the ntpdate systemd service |
60 | 33 | ||
61 | # This should use rc.update | 34 | # This should use rc.update |
62 | FILES_ntpdate = "${bindir}/ntpdate ${sysconfdir}/init.d/ntpdate" | 35 | FILES_ntpdate = "${bindir}/ntpdate ${sysconfdir}/init.d/ntpdate" |
63 | |||
64 | pkg_postinst_ntpdate() { | ||
65 | if test "x$D" != "x"; then | ||
66 | exit 1 | ||
67 | else | ||
68 | if ! grep -q -s ntpdate /var/spool/cron/root; then | ||
69 | echo "adding crontab" | ||
70 | test -d /var/spool/cron || mkdir -p /var/spool/cron | ||
71 | echo "30 * * * * /usr/bin/ntpdate -b -s -u pool.ntp.org" >> /var/spool/cron/root | ||
72 | fi | ||
73 | fi | ||
74 | } | ||
diff --git a/meta-networking/recipes-support/ntp/ntp_4.2.6p5.bb b/meta-networking/recipes-support/ntp/ntp_4.2.6p5.bb index 175a1b07ed..f7c5b68856 100644 --- a/meta-networking/recipes-support/ntp/ntp_4.2.6p5.bb +++ b/meta-networking/recipes-support/ntp/ntp_4.2.6p5.bb | |||
@@ -1,4 +1,45 @@ | |||
1 | require ntp.inc | 1 | require ntp.inc |
2 | 2 | ||
3 | EXTRA_OECONF += "--without-openssl --without-crypto" | 3 | SRC_URI = "http://www.eecis.udel.edu/~ntp/ntp_spool/ntp4/ntp-4.2/ntp-${PV}.tar.gz \ |
4 | file://tickadj.c.patch \ | ||
5 | file://ntp-4.2.4_p6-nano.patch \ | ||
6 | file://ntpd \ | ||
7 | file://ntp.conf \ | ||
8 | file://ntpdate \ | ||
9 | " | ||
10 | |||
11 | SRC_URI[md5sum] = "59876a9009b098ff59767ee45a88ebd2" | ||
12 | SRC_URI[sha256sum] = "6e84d4ddfa14b911c3ed88463af10867e1fa9b287e7b34d8a02e78be85a7c40e" | ||
13 | |||
14 | EXTRA_OECONF += " --with-net-snmp-config=no --without-ntpsnmpd" | ||
15 | |||
16 | do_install_append() { | ||
17 | install -d ${D}/${sysconfdir}/init.d | ||
18 | install -m 644 ${WORKDIR}/ntp.conf ${D}/${sysconfdir} | ||
19 | install -m 755 ${WORKDIR}/ntpd ${D}/${sysconfdir}/init.d | ||
20 | install -d ${D}/${sysconfdir}/network/if-up.d | ||
21 | install -m 755 ${WORKDIR}/ntpdate ${D}/${sysconfdir}/network/if-up.d | ||
22 | } | ||
23 | |||
24 | FILES_${PN}-bin = "${bindir}/ntp-wait ${bindir}/ntpdc ${bindir}/ntpq ${bindir}/ntptime ${bindir}/ntptrace" | ||
25 | FILES_${PN} = "${bindir}/ntpd ${sysconfdir}/ntp.conf ${sysconfdir}/init.d/ntpd" | ||
26 | FILES_${PN}-tickadj = "${bindir}/tickadj" | ||
27 | FILES_ntp-utils = "${bindir}/*" | ||
28 | FILES_ntpdate = "${bindir}/ntpdate ${sysconfdir}/network/if-up.d/ntpdate" | ||
29 | |||
30 | # ntp originally includes tickadj. It's split off for inclusion in small firmware images on platforms | ||
31 | # with wonky clocks (e.g. OpenSlug) | ||
32 | RDEPENDS_${PN} = "${PN}-tickadj" | ||
33 | |||
34 | pkg_postinst_ntpdate() { | ||
35 | if test "x$D" != "x"; then | ||
36 | exit 1 | ||
37 | else | ||
38 | if ! grep -q -s ntpdate /var/spool/cron/root; then | ||
39 | echo "adding crontab" | ||
40 | test -d /var/spool/cron || mkdir -p /var/spool/cron | ||
41 | echo "30 * * * * /usr/bin/ntpdate -b -s -u pool.ntp.org" >> /var/spool/cron/root | ||
42 | fi | ||
43 | fi | ||
44 | } | ||
4 | 45 | ||