summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMartin Jansa <martin.jansa@gmail.com>2018-03-01 10:35:16 +0000
committerArmin Kuster <akuster808@gmail.com>2018-03-16 19:15:49 -0700
commit96093b267ab98942c1c763ecce5391c445871528 (patch)
tree62f0ceb06a0ee98bc230e235204843cb9ed8be40
parent0b43a6edc2c352a69cdfcbf79958b117227ff1ab (diff)
downloadmeta-openembedded-96093b267ab98942c1c763ecce5391c445871528.tar.gz
kodi: fix indentation
* don't use mix of tabs and spaces for multiline indentation Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com> Signed-off-by: Armin Kuster <akuster808@gmail.com>
-rw-r--r--meta-multimedia/recipes-mediacenter/kodi/kodi_17.bb182
1 files changed, 92 insertions, 90 deletions
diff --git a/meta-multimedia/recipes-mediacenter/kodi/kodi_17.bb b/meta-multimedia/recipes-mediacenter/kodi/kodi_17.bb
index 656aefeff..295618914 100644
--- a/meta-multimedia/recipes-mediacenter/kodi/kodi_17.bb
+++ b/meta-multimedia/recipes-mediacenter/kodi/kodi_17.bb
@@ -6,59 +6,59 @@ LIC_FILES_CHKSUM = "file://LICENSE.GPL;md5=930e2a5f63425d8dd72dbd7391c43c46"
6FILESPATH =. "${FILE_DIRNAME}/kodi-17:" 6FILESPATH =. "${FILE_DIRNAME}/kodi-17:"
7 7
8DEPENDS = " \ 8DEPENDS = " \
9 cmake-native \ 9 cmake-native \
10 curl-native \ 10 curl-native \
11 gperf-native \ 11 gperf-native \
12 jsonschemabuilder-native \ 12 jsonschemabuilder-native \
13 nasm-native \ 13 nasm-native \
14 swig-native \ 14 swig-native \
15 unzip-native \ 15 unzip-native \
16 yasm-native \ 16 yasm-native \
17 zip-native \ 17 zip-native \
18 avahi \ 18 avahi \
19 boost \ 19 boost \
20 bzip2 \ 20 bzip2 \
21 crossguid \ 21 crossguid \
22 curl \ 22 curl \
23 dcadec \ 23 dcadec \
24 enca \ 24 enca \
25 expat \ 25 expat \
26 faad2 \ 26 faad2 \
27 ffmpeg \ 27 ffmpeg \
28 fontconfig \ 28 fontconfig \
29 fribidi \ 29 fribidi \
30 giflib \ 30 giflib \
31 jasper \ 31 jasper \
32 libass \ 32 libass \
33 libcdio \ 33 libcdio \
34 libcec \ 34 libcec \
35 libmad \ 35 libmad \
36 libmicrohttpd \ 36 libmicrohttpd \
37 libmms \ 37 libmms \
38 libmms \ 38 libmms \
39 libmodplug \ 39 libmodplug \
40 libpcre \ 40 libpcre \
41 libplist \ 41 libplist \
42 libsamplerate0 \ 42 libsamplerate0 \
43 libsdl-image \ 43 libsdl-image \
44 libsdl-mixer \ 44 libsdl-mixer \
45 libsquish \ 45 libsquish \
46 libssh \ 46 libssh \
47 libtinyxml \ 47 libtinyxml \
48 libusb1 \ 48 libusb1 \
49 libxslt \ 49 libxslt \
50 lzo \ 50 lzo \
51 mpeg2dec \ 51 mpeg2dec \
52 python \ 52 python \
53 sqlite3 \ 53 sqlite3 \
54 taglib \ 54 taglib \
55 virtual/egl \ 55 virtual/egl \
56 virtual/libsdl \ 56 virtual/libsdl \
57 wavpack \ 57 wavpack \
58 yajl \ 58 yajl \
59 zlib \ 59 zlib \
60 ${@enable_glew(bb, d)} \ 60 ${@enable_glew(bb, d)} \
61 " 61"
62 62
63PROVIDES = "xbmc" 63PROVIDES = "xbmc"
64 64
@@ -66,24 +66,24 @@ SRCREV = "6abeebd5ba371547c8f04272296433f5e4e28e86"
66PV = "17.3+gitr${SRCPV}" 66PV = "17.3+gitr${SRCPV}"
67ADDONSPV = "17.1" 67ADDONSPV = "17.1"
68SRC_URI = "git://github.com/xbmc/xbmc.git;branch=Krypton \ 68SRC_URI = "git://github.com/xbmc/xbmc.git;branch=Krypton \
69 https://repo.voidlinux.eu/distfiles/${BPN}-${ADDONSPV}-generated-addons.tar.xz;name=addons;unpack=0 \ 69 https://repo.voidlinux.eu/distfiles/${BPN}-${ADDONSPV}-generated-addons.tar.xz;name=addons;unpack=0 \
70 file://0003-configure-don-t-try-to-run-stuff-to-find-tinyxml.patch \ 70 file://0003-configure-don-t-try-to-run-stuff-to-find-tinyxml.patch \
71 file://0004-handle-SIGTERM.patch \ 71 file://0004-handle-SIGTERM.patch \
72 file://0005-add-support-to-read-frequency-output-if-using-intel-.patch \ 72 file://0005-add-support-to-read-frequency-output-if-using-intel-.patch \
73 file://0006-Disable-DVD-support.patch \ 73 file://0006-Disable-DVD-support.patch \
74 file://0007-Always-compile-libcpluff-as-PIC.patch \ 74 file://0007-Always-compile-libcpluff-as-PIC.patch \
75 file://0008-kodi-config.cmake-use-CMAKE_FIND_ROOT_PATH-to-fix-cr.patch \ 75 file://0008-kodi-config.cmake-use-CMAKE_FIND_ROOT_PATH-to-fix-cr.patch \
76 file://0009-build-Add-support-for-musl-triplets.patch \ 76 file://0009-build-Add-support-for-musl-triplets.patch \
77 file://0010-RssReader-Fix-compiler-warning-comparing-pointer-to-.patch \ 77 file://0010-RssReader-Fix-compiler-warning-comparing-pointer-to-.patch \
78 file://0011-Let-configure-pass-on-unknown-architectures-setting-.patch \ 78 file://0011-Let-configure-pass-on-unknown-architectures-setting-.patch \
79 file://0012-Revert-droid-fix-builds-with-AML-disabled.patch \ 79 file://0012-Revert-droid-fix-builds-with-AML-disabled.patch \
80 file://0001-change-order-of-detecting-libegl-and-libgles2.patch \ 80 file://0001-change-order-of-detecting-libegl-and-libgles2.patch \
81 file://0013-FTPParse.cpp-use-std-string.patch \ 81 file://0013-FTPParse.cpp-use-std-string.patch \
82" 82"
83 83
84SRC_URI_append_libc-musl = " \ 84SRC_URI_append_libc-musl = " \
85 file://0001-Fix-file_Emu-on-musl.patch \ 85 file://0001-Fix-file_Emu-on-musl.patch \
86 file://0002-Remove-FILEWRAP.patch \ 86 file://0002-Remove-FILEWRAP.patch \
87" 87"
88SRC_URI[addons.md5sum] = "719614fa764011a18665d08af5c8c92f" 88SRC_URI[addons.md5sum] = "719614fa764011a18665d08af5c8c92f"
89SRC_URI[addons.sha256sum] = "350da57408c27473eaf40e7f544bc94841bf101dc4346085260c5c4af0adac97" 89SRC_URI[addons.sha256sum] = "350da57408c27473eaf40e7f544bc94841bf101dc4346085260c5c4af0adac97"
@@ -185,29 +185,31 @@ FILES_${PN}-dbg += "${libdir}/kodi/.debug ${libdir}/kodi/*/.debug ${libdir}/kodi
185 185
186# kodi uses some kind of dlopen() method for libcec so we need to add it manually 186# kodi uses some kind of dlopen() method for libcec so we need to add it manually
187# OpenGL builds need glxinfo, that's in mesa-demos 187# OpenGL builds need glxinfo, that's in mesa-demos
188RRECOMMENDS_${PN}_append = " libcec \ 188RRECOMMENDS_${PN}_append = " \
189 python \ 189 libcec \
190 python-ctypes \ 190 python \
191 python-lang \ 191 python-ctypes \
192 python-re \ 192 python-lang \
193 python-netclient \ 193 python-re \
194 python-html \ 194 python-netclient \
195 python-difflib \ 195 python-html \
196 python-json \ 196 python-difflib \
197 python-zlib \ 197 python-json \
198 python-shell \ 198 python-zlib \
199 python-sqlite3 \ 199 python-shell \
200 python-compression \ 200 python-sqlite3 \
201 libcurl \ 201 python-compression \
202 ${@bb.utils.contains('PACKAGECONFIG', 'x11', 'xrandr xdpyinfo', '', d)} \ 202 libcurl \
203 ${@bb.utils.contains('PACKAGECONFIG', 'x11', 'xrandr xdpyinfo', '', d)} \
204"
205RRECOMMENDS_${PN}_append_libc-glibc = " \
206 glibc-charmap-ibm850 \
207 glibc-gconv-ibm850 \
208 glibc-gconv-unicode \
209 glibc-gconv-utf-32 \
210 glibc-charmap-utf-8 \
211 glibc-localedata-en-us \
203" 212"
204RRECOMMENDS_${PN}_append_libc-glibc = " glibc-charmap-ibm850 \
205 glibc-gconv-ibm850 \
206 glibc-gconv-unicode \
207 glibc-gconv-utf-32 \
208 glibc-charmap-utf-8 \
209 glibc-localedata-en-us \
210 "
211 213
212RPROVIDES_${PN} += "xbmc" 214RPROVIDES_${PN} += "xbmc"
213 215