summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorJackie Huang <jackie.huang@windriver.com>2014-11-06 03:22:27 -0500
committerMartin Jansa <Martin.Jansa@gmail.com>2015-01-15 16:36:35 +0100
commit95dc2ddce7a0ee4d16d6c69fd123e4e6921bdf2e (patch)
tree2267b8fcbf0bb6d92338b235c0646383964aa27e
parentdadf58542803e596f8984a390091c50a425f8825 (diff)
downloadmeta-openembedded-95dc2ddce7a0ee4d16d6c69fd123e4e6921bdf2e.tar.gz
vim: add recipe for vim-tiny
Changes: - Add bb for vim-tiny based on vim.bb - Change PACKAGECONFIG and do_install for vim-tiny - Change BPN to vim in vim.bb so it works fine when required by vim-tiny - Add proper alternative links for vim and vim-tiny to avoid conflicts - Don't use do_install_append in vim.bb so it works fine when required by vim-tiny Signed-off-by: Jackie Huang <jackie.huang@windriver.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
-rw-r--r--meta-oe/recipes-support/vim/vim-tiny_7.4.481.bb13
-rw-r--r--meta-oe/recipes-support/vim/vim_7.4.481.bb20
2 files changed, 26 insertions, 7 deletions
diff --git a/meta-oe/recipes-support/vim/vim-tiny_7.4.481.bb b/meta-oe/recipes-support/vim/vim-tiny_7.4.481.bb
new file mode 100644
index 000000000..bb8f2b7ea
--- /dev/null
+++ b/meta-oe/recipes-support/vim/vim-tiny_7.4.481.bb
@@ -0,0 +1,13 @@
1require vim_${PV}.bb
2
3SUMMARY += " (with tiny features)"
4
5PACKAGECONFIG += "tiny"
6
7do_install() {
8 install -d ${D}/${bindir}
9 install -m 0755 ${S}/vim ${D}/${bindir}/vim.tiny
10}
11
12ALTERNATIVE_PRIORITY = "90"
13ALTERNATIVE_TARGET = "${bindir}/vim.tiny"
diff --git a/meta-oe/recipes-support/vim/vim_7.4.481.bb b/meta-oe/recipes-support/vim/vim_7.4.481.bb
index b85ff63d5..749022918 100644
--- a/meta-oe/recipes-support/vim/vim_7.4.481.bb
+++ b/meta-oe/recipes-support/vim/vim_7.4.481.bb
@@ -12,9 +12,9 @@ SRC_URI = "hg://vim.googlecode.com/hg/;protocol=https;module=vim \
12" 12"
13SRCREV = "v7-4-481" 13SRCREV = "v7-4-481"
14 14
15S = "${WORKDIR}/${BPN}/src" 15S = "${WORKDIR}/vim/src"
16 16
17VIMDIR = "${BPN}${@d.getVar('PV',1).split('.')[0]}${@d.getVar('PV',1).split('.')[1]}" 17VIMDIR = "vim${@d.getVar('PV',1).split('.')[0]}${@d.getVar('PV',1).split('.')[1]}"
18 18
19inherit autotools update-alternatives 19inherit autotools update-alternatives
20inherit autotools-brokensep 20inherit autotools-brokensep
@@ -59,7 +59,9 @@ EXTRA_OECONF = " \
59 STRIP=/bin/true \ 59 STRIP=/bin/true \
60" 60"
61 61
62do_install_append() { 62do_install() {
63 autotools_do_install
64
63 # Work around rpm picking up csh or awk or perl as a dep 65 # Work around rpm picking up csh or awk or perl as a dep
64 chmod -x ${D}${datadir}/${BPN}/${VIMDIR}/tools/vim132 66 chmod -x ${D}${datadir}/${BPN}/${VIMDIR}/tools/vim132
65 chmod -x ${D}${datadir}/${BPN}/${VIMDIR}/tools/mve.awk 67 chmod -x ${D}${datadir}/${BPN}/${VIMDIR}/tools/mve.awk
@@ -67,6 +69,9 @@ do_install_append() {
67 69
68 # Install example vimrc from runtime files 70 # Install example vimrc from runtime files
69 install -m 0644 ../runtime/vimrc_example.vim ${D}/${datadir}/${BPN}/vimrc 71 install -m 0644 ../runtime/vimrc_example.vim ${D}/${datadir}/${BPN}/vimrc
72
73 # we use --with-features=big as default
74 mv ${D}${bindir}/${BPN} ${D}${bindir}/${BPN}.${BPN}
70} 75}
71 76
72PARALLEL_MAKEINST = "" 77PARALLEL_MAKEINST = ""
@@ -97,7 +102,8 @@ RDEPENDS_${PN} = "ncurses-terminfo-base"
97# Recommend that runtime data is installed along with vim 102# Recommend that runtime data is installed along with vim
98RRECOMMENDS_${PN} = "${PN}-syntax ${PN}-help ${PN}-tutor ${PN}-vimrc ${PN}-common" 103RRECOMMENDS_${PN} = "${PN}-syntax ${PN}-help ${PN}-tutor ${PN}-vimrc ${PN}-common"
99 104
100ALTERNATIVE_${PN} = "vi" 105ALTERNATIVE_${PN} = "vi vim"
101ALTERNATIVE_TARGET[vi] = "${bindir}/${BPN}" 106ALTERNATIVE_TARGET = "${bindir}/${BPN}.${BPN}"
102ALTERNATIVE_LINK_NAME[vi] = "${base_bindir}/vi" 107ALTERNATIVE_LINK_NAME[vi] = "${bindir}/vi"
103ALTERNATIVE_PRIORITY[vi] = "100" 108ALTERNATIVE_LINK_NAME[vim] = "${bindir}/vim"
109ALTERNATIVE_PRIORITY = "100"