diff options
author | mark.yang <mark.yang@lge.com> | 2025-04-08 20:52:11 +0900 |
---|---|---|
committer | Khem Raj <raj.khem@gmail.com> | 2025-04-08 08:22:05 -0700 |
commit | 94819a3e4e08adf43031981517a87fc753ae45f1 (patch) | |
tree | e3c9a9d7ad27a2f4e69c2d0655f210e469e9ffc0 | |
parent | 4b30277f2a3f3bffc87ba4d038861718df76454c (diff) | |
download | meta-openembedded-94819a3e4e08adf43031981517a87fc753ae45f1.tar.gz |
freeipmi: fix error with gcc-15
* Import submitted patch from:
https://lists.gnu.org/archive/html/freeipmi-devel/2025-02/msg00000.html
to fix:
http://errors.yoctoproject.org/Errors/Details/851185/
Error occurs with gcc version 15.
In gcc-15, C23 is the default and 'bool' is used as a reserved keyword.
https://gcc.gnu.org/git/?p=gcc.git;a=commitdiff;h=55e3bd376b2214e200fa76d12b67ff259b06c212
Signed-off-by: mark.yang <mark.yang@lge.com>
Signed-off-by: Khem Raj <raj.khem@gmail.com>
-rw-r--r-- | meta-oe/recipes-support/freeipmi/freeipmi/0001-Fix-for-GCC15-C23-build-failure.patch | 42 | ||||
-rw-r--r-- | meta-oe/recipes-support/freeipmi/freeipmi_1.6.15.bb | 5 |
2 files changed, 46 insertions, 1 deletions
diff --git a/meta-oe/recipes-support/freeipmi/freeipmi/0001-Fix-for-GCC15-C23-build-failure.patch b/meta-oe/recipes-support/freeipmi/freeipmi/0001-Fix-for-GCC15-C23-build-failure.patch new file mode 100644 index 0000000000..ee27fe7906 --- /dev/null +++ b/meta-oe/recipes-support/freeipmi/freeipmi/0001-Fix-for-GCC15-C23-build-failure.patch | |||
@@ -0,0 +1,42 @@ | |||
1 | From 5afe6492735938e0053ae78817399fa433f0f8c7 Mon Sep 17 00:00:00 2001 | ||
2 | From: "Pavel Cahyna" <pcahyna@redhat.com> | ||
3 | Date: Tue, 8 Apr 2025 19:05:53 +0900 | ||
4 | Subject: [PATCH] Fix for GCC15 / C23 build failure | ||
5 | |||
6 | * Import submitted patch from: | ||
7 | https://lists.gnu.org/archive/html/freeipmi-devel/2025-02/msg00000.html | ||
8 | |||
9 | to fix: | ||
10 | http://errors.yoctoproject.org/Errors/Details/851185/ | ||
11 | Error occurs with gcc version 15. | ||
12 | In gcc-15, C23 is the default and 'bool' is used as a reserved keyword. | ||
13 | https://gcc.gnu.org/git/?p=gcc.git;a=commitdiff;h=55e3bd376b2214e200fa76d12b67ff259b06c212 | ||
14 | |||
15 | Upstream-Status: Submitted [https://lists.gnu.org/archive/html/freeipmi-devel/2025-02/msg00000.html] | ||
16 | Signed-off-by: mark.yang <mark.yang@lge.com> | ||
17 | --- | ||
18 | common/toolcommon/tool-config-file-common.c | 6 +++--- | ||
19 | 1 file changed, 3 insertions(+), 3 deletions(-) | ||
20 | |||
21 | diff --git a/common/toolcommon/tool-config-file-common.c b/common/toolcommon/tool-config-file-common.c | ||
22 | index 609e7a3..20dfad5 100644 | ||
23 | --- a/common/toolcommon/tool-config-file-common.c | ||
24 | +++ b/common/toolcommon/tool-config-file-common.c | ||
25 | @@ -78,14 +78,14 @@ _config_file_bool (conffile_t cf, | ||
26 | void *app_ptr, | ||
27 | int app_data) | ||
28 | { | ||
29 | - int *bool; | ||
30 | + int *value; | ||
31 | |||
32 | assert (data); | ||
33 | assert (optionname); | ||
34 | assert (option_ptr); | ||
35 | |||
36 | - bool = (int *)option_ptr; | ||
37 | - *bool = data->boolval; | ||
38 | + value = (int *)option_ptr; | ||
39 | + *value = data->boolval; | ||
40 | return (0); | ||
41 | } | ||
42 | |||
diff --git a/meta-oe/recipes-support/freeipmi/freeipmi_1.6.15.bb b/meta-oe/recipes-support/freeipmi/freeipmi_1.6.15.bb index e977bbcd9e..e04ebfb0c6 100644 --- a/meta-oe/recipes-support/freeipmi/freeipmi_1.6.15.bb +++ b/meta-oe/recipes-support/freeipmi/freeipmi_1.6.15.bb | |||
@@ -13,7 +13,10 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=d32239bcb673463ab874e80d47fae504 \ | |||
13 | file://COPYING.pstdout;md5=d32239bcb673463ab874e80d47fae504 \ | 13 | file://COPYING.pstdout;md5=d32239bcb673463ab874e80d47fae504 \ |
14 | file://COPYING.sunbmc;md5=c03f21cd76ff5caba6b890d1213cbfbb" | 14 | file://COPYING.sunbmc;md5=c03f21cd76ff5caba6b890d1213cbfbb" |
15 | 15 | ||
16 | SRC_URI = "${GNU_MIRROR}/freeipmi/freeipmi-${PV}.tar.gz" | 16 | SRC_URI = " \ |
17 | ${GNU_MIRROR}/freeipmi/freeipmi-${PV}.tar.gz \ | ||
18 | file://0001-Fix-for-GCC15-C23-build-failure.patch \ | ||
19 | " | ||
17 | SRC_URI[sha256sum] = "d6929c354639f5ce75b5b1897e8b366eb63625c23e5c4590a7aea034fe2b8caf" | 20 | SRC_URI[sha256sum] = "d6929c354639f5ce75b5b1897e8b366eb63625c23e5c4590a7aea034fe2b8caf" |
18 | 21 | ||
19 | DEPENDS = "libgcrypt" | 22 | DEPENDS = "libgcrypt" |