summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorEero Aaltonen <eero.aaltonen@vaisala.com>2024-04-15 14:30:29 +0300
committerKhem Raj <raj.khem@gmail.com>2024-04-15 21:01:20 -0700
commit92e149ec0746878c7f48f489c7cf5eb514ac76c2 (patch)
tree80552dc9021e4230486ac99a836cd6de4e3411aa
parent7b3b303c738bcaa644693f21c7a06ca029f2ed28 (diff)
downloadmeta-openembedded-92e149ec0746878c7f48f489c7cf5eb514ac76c2.tar.gz
docopt.cpp: turn boost to a PACKAGECONFIG option
docopt.cpp only uses boost regex with the option USE_BOOST_REGEX=ON. When used, boost regex is statically linked. Signed-off-by: Eero Aaltonen <eero.aaltonen@vaisala.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
-rw-r--r--meta-oe/recipes-extended/docopt.cpp/docopt.cpp_git.bb4
1 files changed, 3 insertions, 1 deletions
diff --git a/meta-oe/recipes-extended/docopt.cpp/docopt.cpp_git.bb b/meta-oe/recipes-extended/docopt.cpp/docopt.cpp_git.bb
index 3d438871e..87eed4b65 100644
--- a/meta-oe/recipes-extended/docopt.cpp/docopt.cpp_git.bb
+++ b/meta-oe/recipes-extended/docopt.cpp/docopt.cpp_git.bb
@@ -13,7 +13,6 @@ LIC_FILES_CHKSUM = "\
13 file://LICENSE-MIT;md5=4b242fd9ef20207e18286d73da8a6677 \ 13 file://LICENSE-MIT;md5=4b242fd9ef20207e18286d73da8a6677 \
14" 14"
15 15
16DEPENDS = "boost"
17SRCREV = "42ebcec9dc2c99a1b3a4542787572045763ad196" 16SRCREV = "42ebcec9dc2c99a1b3a4542787572045763ad196"
18PV = "0.6.3+git" 17PV = "0.6.3+git"
19 18
@@ -24,3 +23,6 @@ SRC_URI = "\
24S = "${WORKDIR}/git" 23S = "${WORKDIR}/git"
25 24
26inherit cmake 25inherit cmake
26
27PACKAGECONFIG ??= ""
28PACKAGECONFIG[boost] = "-DUSE_BOOST_REGEX=ON,-DUSE_BOOST_REGEX=OFF,boost"