diff options
author | Tim Orling <ticotimo@gmail.com> | 2020-09-21 21:47:25 -0700 |
---|---|---|
committer | Khem Raj <raj.khem@gmail.com> | 2020-09-23 10:13:35 -0700 |
commit | 92be59704b4afa65166fc6df209355b4fac67e00 (patch) | |
tree | 9f30c1d11f9ae47e4ccb094d64c6202e30938b9d | |
parent | 2a460d8c678dee0012846f0720ef0626bee1e5bd (diff) | |
download | meta-openembedded-92be59704b4afa65166fc6df209355b4fac67e00.tar.gz |
python3-markupsafe: bbappend for ptest
The main recipe has moved to oe-core, but with ptest
disabled. Here we simply conditionally inherit ptest
to enable it in meta-python.
Remove the original recipe and the python3-markupsafe/
directory.
Signed-off-by: Tim Orling <ticotimo@gmail.com>
Signed-off-by: Khem Raj <raj.khem@gmail.com>
3 files changed, 2 insertions, 30 deletions
diff --git a/meta-python/recipes-devtools/python/python3-markupsafe/run-ptest b/meta-python/recipes-devtools/python/python3-markupsafe/run-ptest deleted file mode 100644 index 5cec71169..000000000 --- a/meta-python/recipes-devtools/python/python3-markupsafe/run-ptest +++ /dev/null | |||
@@ -1,3 +0,0 @@ | |||
1 | #!/bin/sh | ||
2 | |||
3 | pytest | ||
diff --git a/meta-python/recipes-devtools/python/python3-markupsafe_1.%.bbappend b/meta-python/recipes-devtools/python/python3-markupsafe_1.%.bbappend new file mode 100644 index 000000000..91814e6cd --- /dev/null +++ b/meta-python/recipes-devtools/python/python3-markupsafe_1.%.bbappend | |||
@@ -0,0 +1,2 @@ | |||
1 | # Main recipe was moved to oe-core, but with ptest disabled | ||
2 | inherit ${@bb.utils.filter('DISTRO_FEATURES', 'ptest', d)} | ||
diff --git a/meta-python/recipes-devtools/python/python3-markupsafe_1.1.1.bb b/meta-python/recipes-devtools/python/python3-markupsafe_1.1.1.bb deleted file mode 100644 index 7de57cbd6..000000000 --- a/meta-python/recipes-devtools/python/python3-markupsafe_1.1.1.bb +++ /dev/null | |||
@@ -1,27 +0,0 @@ | |||
1 | DESCRIPTION = "Implements a XML/HTML/XHTML Markup safe string for Python" | ||
2 | HOMEPAGE = "http://github.com/mitsuhiko/markupsafe" | ||
3 | LICENSE = "BSD-3-Clause" | ||
4 | LIC_FILES_CHKSUM = "file://LICENSE.rst;md5=ffeffa59c90c9c4a033c7574f8f3fb75" | ||
5 | |||
6 | SRC_URI[md5sum] = "43fd756864fe42063068e092e220c57b" | ||
7 | SRC_URI[sha256sum] = "29872e92839765e546828bb7754a68c418d927cd064fd4708fab9fe9c8bb116b" | ||
8 | |||
9 | PYPI_PACKAGE = "MarkupSafe" | ||
10 | inherit pypi ptest setuptools3 | ||
11 | |||
12 | RDEPENDS_${PN} += "${PYTHON_PN}-stringold" | ||
13 | |||
14 | BBCLASSEXTEND = "native nativesdk" | ||
15 | |||
16 | SRC_URI += " \ | ||
17 | file://run-ptest \ | ||
18 | " | ||
19 | |||
20 | RDEPENDS_${PN}-ptest += " \ | ||
21 | ${PYTHON_PN}-pytest \ | ||
22 | " | ||
23 | |||
24 | do_install_ptest() { | ||
25 | install -d ${D}${PTEST_PATH}/tests | ||
26 | cp -f ${S}/tests/* ${D}${PTEST_PATH}/tests/ | ||
27 | } | ||