diff options
author | Derek Straka <derek@asterius.io> | 2025-01-17 18:59:42 +0000 |
---|---|---|
committer | Khem Raj <raj.khem@gmail.com> | 2025-01-17 11:29:13 -0800 |
commit | 90ab0bc4fe1fdc913cbd0bc5801d0833f8910c62 (patch) | |
tree | 5b8367e0297dc8f9b4597220b9a0cc9c60e7fd43 | |
parent | dc556825e9d9d1dc2cde729792fc84091f8d3fe8 (diff) | |
download | meta-openembedded-90ab0bc4fe1fdc913cbd0bc5801d0833f8910c62.tar.gz |
python3-python-multipart: update recipe to use the ptest-python-pytest class
Signed-off-by: Derek Straka <derek@asterius.io>
Signed-off-by: Khem Raj <raj.khem@gmail.com>
-rw-r--r-- | meta-python/recipes-devtools/python/python3-python-multipart/run-ptest | 3 | ||||
-rw-r--r-- | meta-python/recipes-devtools/python/python3-python-multipart_0.0.20.bb | 12 |
2 files changed, 1 insertions, 14 deletions
diff --git a/meta-python/recipes-devtools/python/python3-python-multipart/run-ptest b/meta-python/recipes-devtools/python/python3-python-multipart/run-ptest deleted file mode 100644 index 8d2017d39c..0000000000 --- a/meta-python/recipes-devtools/python/python3-python-multipart/run-ptest +++ /dev/null | |||
@@ -1,3 +0,0 @@ | |||
1 | #!/bin/sh | ||
2 | |||
3 | pytest --automake | ||
diff --git a/meta-python/recipes-devtools/python/python3-python-multipart_0.0.20.bb b/meta-python/recipes-devtools/python/python3-python-multipart_0.0.20.bb index db5e7bb45a..71f9674ec8 100644 --- a/meta-python/recipes-devtools/python/python3-python-multipart_0.0.20.bb +++ b/meta-python/recipes-devtools/python/python3-python-multipart_0.0.20.bb | |||
@@ -4,22 +4,12 @@ LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=3d98f0d58b28321924a89ab60c82410e" | |||
4 | 4 | ||
5 | SRC_URI[sha256sum] = "8dd0cab45b8e23064ae09147625994d090fa46f5b0d1e13af944c331a7fa9d13" | 5 | SRC_URI[sha256sum] = "8dd0cab45b8e23064ae09147625994d090fa46f5b0d1e13af944c331a7fa9d13" |
6 | 6 | ||
7 | inherit pypi python_hatchling ptest | 7 | inherit pypi python_hatchling ptest-python-pytest |
8 | 8 | ||
9 | PYPI_PACKAGE = "python_multipart" | 9 | PYPI_PACKAGE = "python_multipart" |
10 | UPSTREAM_CHECK_PYPI_PACKAGE = "${PYPI_PACKAGE}" | 10 | UPSTREAM_CHECK_PYPI_PACKAGE = "${PYPI_PACKAGE}" |
11 | 11 | ||
12 | SRC_URI += " \ | ||
13 | file://run-ptest \ | ||
14 | " | ||
15 | |||
16 | RDEPENDS:${PN}-ptest += " \ | 12 | RDEPENDS:${PN}-ptest += " \ |
17 | python3-pytest \ | ||
18 | python3-pyyaml \ | 13 | python3-pyyaml \ |
19 | python3-unittest-automake-output \ | ||
20 | " | 14 | " |
21 | 15 | ||
22 | do_install_ptest() { | ||
23 | install -d ${D}${PTEST_PATH}/tests | ||
24 | cp -rf ${S}/tests/* ${D}${PTEST_PATH}/tests/ | ||
25 | } | ||