summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorChunrong Guo <B40290@freescale.com>2013-08-30 10:21:24 +0000
committerMartin Jansa <Martin.Jansa@gmail.com>2013-09-10 22:43:13 +0200
commit8ef842b8ad2ede706110afe83171876122651ec6 (patch)
treea29804efe612892e8c96ef67e725e5495c64ebac
parente0eaa29f0208bf32ce33e1a50ad9a1f39f7b6c27 (diff)
downloadmeta-openembedded-8ef842b8ad2ede706110afe83171876122651ec6.tar.gz
daq: add recipe
*The dump DAQ test the various inline mode features *snort depends daq Signed-off-by: Chunrong Guo <B40290@freescale.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
-rw-r--r--meta-oe/recipes-connectivity/daq/daq_2.0.1.bb16
-rw-r--r--meta-oe/recipes-connectivity/daq/files/disable-run-test-program-while-cross-compiling.patch29
2 files changed, 45 insertions, 0 deletions
diff --git a/meta-oe/recipes-connectivity/daq/daq_2.0.1.bb b/meta-oe/recipes-connectivity/daq/daq_2.0.1.bb
new file mode 100644
index 000000000..4c1be443d
--- /dev/null
+++ b/meta-oe/recipes-connectivity/daq/daq_2.0.1.bb
@@ -0,0 +1,16 @@
1DESCRIPTION = "The dump DAQ test the various inline mode features "
2HOMEPAGE = "http://www.snort.org"
3LICENSE = "GPLv2"
4LIC_FILES_CHKSUM = "file://COPYING;md5=f9ce51a65dd738dc1ae631d8b21c40e0"
5
6PARALLEL_MAKE = ""
7
8DEPENDS = "libpcap libpcre "
9
10SRC_URI = "http://fossies.org/linux/misc/daq-${PV}.tar.gz \
11 file://disable-run-test-program-while-cross-compiling.patch "
12
13SRC_URI[md5sum] = "044aa3663d44580d005293eeb8ccf175"
14SRC_URI[sha256sum] = "ebba87c2ec76ac65d2980934423b0597909caead3a86ce5d1ba1ea6ce518ec6d"
15
16inherit autotools
diff --git a/meta-oe/recipes-connectivity/daq/files/disable-run-test-program-while-cross-compiling.patch b/meta-oe/recipes-connectivity/daq/files/disable-run-test-program-while-cross-compiling.patch
new file mode 100644
index 000000000..12a6cba60
--- /dev/null
+++ b/meta-oe/recipes-connectivity/daq/files/disable-run-test-program-while-cross-compiling.patch
@@ -0,0 +1,29 @@
1Upstream-Status:Inappropriate [embedded specific]
2
3fix the below error:
4configure: error: cannot run test program while cross compiling
5
6Signed-off-by: Chunrong Guo <B40290@freescale.com>
7
8--- a/m4/sf.m4old 2013-08-30 04:08:18.768409680 -0500
9+++ b/m4/sf.m4 2013-08-30 04:09:24.591367890 -0500
10@@ -135,19 +135,6 @@
11 exit 1
12 fi
13 AC_MSG_CHECKING([for libpcap version >= $1])
14- AC_RUN_IFELSE(
15- [AC_LANG_PROGRAM(
16- [[
17- #include <pcap.h>
18- #include <string.h>
19- extern char pcap_version[];
20- ]],
21- [[
22- if (strcmp(pcap_version, $1) < 0)
23- return 1;
24- ]])],
25- [libpcap_version_1x="yes"],
26- [libpcap_version_1x="no"])
27 if test "x$libpcap_version_1x" = "xno"; then
28 AC_MSG_RESULT(no)
29 echo