summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorBen Shelton <ben.shelton@ni.com>2015-02-18 17:03:41 -0600
committerMartin Jansa <Martin.Jansa@gmail.com>2015-02-27 09:35:51 +0100
commit8b0a43983c65a2f453d82f909a1860f5770e5041 (patch)
tree54cee104548deb7ae896d5779d504403c431f19d
parentd3f82f82f46c8abf8ab07a853599379c47422b7a (diff)
downloadmeta-openembedded-8b0a43983c65a2f453d82f909a1860f5770e5041.tar.gz
python-msgpack: add recipe
python-msgpack implements the MessagePack binary serialization format for Python. Copied from commit 91ed2353847d4121e3dd8ad10ca0c24194ac9765 in meta-cloud-services/meta-openstack and updated to version 0.4.5. Signed-off-by: Ben Shelton <ben.shelton@ni.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
-rw-r--r--meta-python/recipes-devtools/python/python-msgpack_0.4.5.bb17
1 files changed, 17 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python-msgpack_0.4.5.bb b/meta-python/recipes-devtools/python/python-msgpack_0.4.5.bb
new file mode 100644
index 000000000..206b03dd4
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python-msgpack_0.4.5.bb
@@ -0,0 +1,17 @@
1DESCRIPTION = "MessagePack (de)serializer"
2HOMEPAGE = "https://pypi.python.org/pypi/msgpack-python/"
3SECTION = "devel/python"
4LICENSE = "Apache-2.0"
5LIC_FILES_CHKSUM = "file://COPYING;md5=cd9523181d9d4fbf7ffca52eaa2a5751"
6
7PR = "r0"
8SRCNAME = "msgpack-python"
9
10SRC_URI = "https://pypi.python.org/packages/source/m/${SRCNAME}/${SRCNAME}-${PV}.tar.gz"
11
12SRC_URI[md5sum] = "3b82bc542d5599896695512e7c32f42d"
13SRC_URI[sha256sum] = "a07cd6615a6bf38cfa2f010b121c7e77b74a3e7b971ef3e475c3d33308014cbb"
14
15S = "${WORKDIR}/${SRCNAME}-${PV}"
16
17inherit setuptools