summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorArmin Kuster <akuster808@gmail.com>2016-05-23 18:34:00 -0700
committerJoe MacDonald <joe_macdonald@mentor.com>2016-06-01 19:35:50 -0400
commit880c3dce369255e468cdd8dc0be6e15e913f806c (patch)
tree951b858e046a4fed3307d17f8dfeab8c42d2e087
parentd46c89ae44c811b64b117613072698601e483b32 (diff)
downloadmeta-openembedded-880c3dce369255e468cdd8dc0be6e15e913f806c.tar.gz
opensaf: update to 5.0.0
clean up to meet style guide Signed-off-by: Armin Kuster <akuster808@gmail.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com> Signed-off-by: Joe MacDonald <joe_macdonald@mentor.com>
-rw-r--r--meta-networking/recipes-daemons/opensaf/opensaf_5.0.0.bb (renamed from meta-networking/recipes-daemons/opensaf/opensaf_4.7.0.bb)37
1 files changed, 17 insertions, 20 deletions
diff --git a/meta-networking/recipes-daemons/opensaf/opensaf_4.7.0.bb b/meta-networking/recipes-daemons/opensaf/opensaf_5.0.0.bb
index 42e883a31..f6873781d 100644
--- a/meta-networking/recipes-daemons/opensaf/opensaf_4.7.0.bb
+++ b/meta-networking/recipes-daemons/opensaf/opensaf_5.0.0.bb
@@ -10,22 +10,21 @@ an informal group of supporters of the OpenSAF initiative. The OpenSAF \
10Foundation was founded on January 22nd 2008 with Emerson Network Power, \ 10Foundation was founded on January 22nd 2008 with Emerson Network Power, \
11Ericsson, Nokia Siemens Networks, HP and Sun Microsystems as founding members." 11Ericsson, Nokia Siemens Networks, HP and Sun Microsystems as founding members."
12HOMEPAGE = "http://www.opensaf.org" 12HOMEPAGE = "http://www.opensaf.org"
13SECTION = "admin"
14LICENSE = "LGPLv2.1"
15LIC_FILES_CHKSUM = "file://COPYING.LIB;md5=a916467b91076e631dd8edb7424769c7"
13 16
14inherit autotools useradd systemd pkgconfig 17DEPENDS = "libxml2 python"
15 18
16SRC_URI = "${SOURCEFORGE_MIRROR}/${BPN}/releases/${BPN}-${PV}.tar.gz \ 19SRC_URI = "${SOURCEFORGE_MIRROR}/${BPN}/releases/${BPN}-${PV}.tar.gz \
17 file://install-samples-from-srcdir.patch \ 20 file://install-samples-from-srcdir.patch \
18 file://0001-plmcd-error-fix.patch \ 21 file://0001-plmcd-error-fix.patch \
19 " 22 "
20 23
21SRC_URI[md5sum] = "82dd2777a672140e22b8205f10aa55d3" 24SRC_URI[md5sum] = "94cd1a4c0406e6a45bb04c003f8690e7"
22SRC_URI[sha256sum] = "da9e138650b835728ad51d99268d3a31419b254c4cb4e87c6ec90bc45266d7d2" 25SRC_URI[sha256sum] = "4b4188a0f3d0ed1ed0e3d77de27c45e2c96b437401de08e7df2ed9ecd54bb999"
23
24SECTION = "admin"
25LICENSE = "LGPLv2.1"
26LIC_FILES_CHKSUM = "file://COPYING.LIB;md5=a916467b91076e631dd8edb7424769c7"
27 26
28DEPENDS = "libxml2 python" 27inherit autotools useradd systemd pkgconfig
29 28
30USERADD_PACKAGES = "${PN}" 29USERADD_PACKAGES = "${PN}"
31GROUPADD_PARAM_${PN} = "-f -r opensaf" 30GROUPADD_PARAM_${PN} = "-f -r opensaf"
@@ -37,22 +36,14 @@ SYSTEMD_AUTO_ENABLE = "disable"
37PACKAGECONFIG[systemd] = "--enable-systemd-daemon" 36PACKAGECONFIG[systemd] = "--enable-systemd-daemon"
38PACKAGECONFIG[openhpi] = "--with-hpi-interface=B03 --enable-ais-plm,,openhpi" 37PACKAGECONFIG[openhpi] = "--with-hpi-interface=B03 --enable-ais-plm,,openhpi"
39 38
40do_configure_prepend () {
41 ( cd ${S}; autoreconf -f -i -s )
42}
43
44EXTRA_OECONF += " --libdir=${libdir}/opensaf " 39EXTRA_OECONF += " --libdir=${libdir}/opensaf "
45EXTRA_OEMAKE += " -Wl,-rpath,${libdir}/opensaf " 40EXTRA_OEMAKE += " -Wl,-rpath,${libdir}/opensaf "
46 41
47PKGLIBDIR="${libdir}/opensaf/opensaf" 42PKGLIBDIR="${libdir}/opensaf/opensaf"
48 43
49FILES_${PN} += "${localstatedir}/run" 44do_configure_prepend () {
50 45 ( cd ${S}; autoreconf -f -i -s )
51FILES_${PN}-staticdev += "${PKGLIBDIR}/*.a" 46}
52
53RDEPENDS_${PN} += "bash python"
54
55INSANE_SKIP_${PN} = "dev-so"
56 47
57do_install_append() { 48do_install_append() {
58 rm -fr "${D}${localstatedir}/lock" 49 rm -fr "${D}${localstatedir}/lock"
@@ -62,5 +53,11 @@ do_install_append() {
62 install -m 0644 ${B}/osaf/services/infrastructure/nid/config/opensafd.service \ 53 install -m 0644 ${B}/osaf/services/infrastructure/nid/config/opensafd.service \
63 ${D}${systemd_unitdir}/system 54 ${D}${systemd_unitdir}/system
64 install -m 0644 ${B}/contrib/plmc/config/*.service ${D}/${systemd_unitdir}/system 55 install -m 0644 ${B}/contrib/plmc/config/*.service ${D}/${systemd_unitdir}/system
65
66} 56}
57
58FILES_${PN} += "${localstatedir}/run"
59FILES_${PN}-staticdev += "${PKGLIBDIR}/*.a"
60
61INSANE_SKIP_${PN} = "dev-so"
62
63RDEPENDS_${PN} += "bash python"