summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorChong.Lu@windriver.com <Chong.Lu@windriver.com>2014-06-06 18:12:47 +0800
committerMartin Jansa <Martin.Jansa@gmail.com>2014-06-13 13:38:11 +0200
commit872621cf60db401e2826ebfa2c1572a8bf53f2d5 (patch)
treea60f0cd991e2cd532820c8c636ee964606ea1338
parent65d71946f2e9cf7a55dc1f153a1f47fa504ee47a (diff)
downloadmeta-openembedded-872621cf60db401e2826ebfa2c1572a8bf53f2d5.tar.gz
python-m2crypto: avoid swig problem
Swig is used to generate C source and it has trouble processing opensslconf.h sometimes. So, we help it out when multilib variants exist. For native builds, the variant header will never exist. Specific multi-lib header files might be named *-32.h or *-n32.h, so we check for both names. We also might check for *-n64.h although that will never exist. It appears that *-o??.h will never exist, so we don't check for that. Signed-off-by: Joe Slater <jslater@windriver.com> Signed-off-by: Chong Lu <Chong.Lu@windriver.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
-rw-r--r--meta-oe/recipes-devtools/python/python-m2crypto_0.21.1.bb23
1 files changed, 22 insertions, 1 deletions
diff --git a/meta-oe/recipes-devtools/python/python-m2crypto_0.21.1.bb b/meta-oe/recipes-devtools/python/python-m2crypto_0.21.1.bb
index 21c02696d..67ec9214a 100644
--- a/meta-oe/recipes-devtools/python/python-m2crypto_0.21.1.bb
+++ b/meta-oe/recipes-devtools/python/python-m2crypto_0.21.1.bb
@@ -1,7 +1,7 @@
1SUMMARY = "A Python crypto and SSL toolkit" 1SUMMARY = "A Python crypto and SSL toolkit"
2HOMEPAGE = "http://chandlerproject.org/bin/view/Projects/MeTooCrypto" 2HOMEPAGE = "http://chandlerproject.org/bin/view/Projects/MeTooCrypto"
3 3
4DEPENDS = "openssl swig-native" 4DEPENDS = "openssl swig-native python"
5 5
6LICENSE = "BSD" 6LICENSE = "BSD"
7LIC_FILES_CHKSUM = "file://LICENCE;md5=b0e1f0b7d0ce8a62c18b1287b991800e" 7LIC_FILES_CHKSUM = "file://LICENCE;md5=b0e1f0b7d0ce8a62c18b1287b991800e"
@@ -20,4 +20,25 @@ SWIG_FEATURES_x86-64 = "-D__x86_64__"
20SWIG_FEATURES ?= "" 20SWIG_FEATURES ?= ""
21export SWIG_FEATURES 21export SWIG_FEATURES
22 22
23# Get around a problem with swig, but only if the
24# multilib header file exists.
25#
26do_compile_prepend() {
27 if [ "${SITEINFO_BITS}" = "64" ];then
28 bit="64"
29 else
30 bit="32"
31 fi
32
33 if [ -e ${STAGING_INCDIR}/openssl/opensslconf-${bit}.h ] ;then
34 for i in SWIG/_ec.i SWIG/_evp.i; do
35 sed -i -e "s/opensslconf.*\./opensslconf-${bit}\./" "$i"
36 done
37 elif [ -e ${STAGING_INCDIR}/openssl/opensslconf-n${bit}.h ] ;then
38 for i in SWIG/_ec.i SWIG/_evp.i; do
39 sed -i -e "s/opensslconf.*\./opensslconf-n${bit}\./" "$i"
40 done
41 fi
42}
43
23BBCLASSEXTEND = "native" 44BBCLASSEXTEND = "native"