summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2015-09-03 07:39:54 +0000
committerMartin Jansa <Martin.Jansa@gmail.com>2015-09-08 16:21:38 +0200
commit81fdb4d1f80ebfffe4d245138637592d23babca6 (patch)
tree50eacb2370dec64f3e25edb6843abc75a0221308
parent8a5df66704ce01f5d53c20d85d50d0a9c9dacc9e (diff)
downloadmeta-openembedded-81fdb4d1f80ebfffe4d245138637592d23babca6.tar.gz
plymouth: Add recipe
Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
-rw-r--r--meta-oe/recipes-core/plymouth/plymouth_0.9.2.bb61
1 files changed, 61 insertions, 0 deletions
diff --git a/meta-oe/recipes-core/plymouth/plymouth_0.9.2.bb b/meta-oe/recipes-core/plymouth/plymouth_0.9.2.bb
new file mode 100644
index 000000000..b8c82ed4e
--- /dev/null
+++ b/meta-oe/recipes-core/plymouth/plymouth_0.9.2.bb
@@ -0,0 +1,61 @@
1SUMMARY = "Plymouth is a project from Fedora providing a flicker-free graphical boot process."
2
3DESCRIPTION = "Plymouth is an application that runs very early in the boot process \
4 (even before the root filesystem is mounted!) that provides a \
5 graphical boot animation while the boot process happens in the background."
6
7HOMEPAGE = "http://www.freedesktop.org/wiki/Software/Plymouth"
8SECTION = "base"
9
10LICENSE = "GPLv2+"
11
12LIC_FILES_CHKSUM = "file://COPYING;md5=94d55d512a9ba36caa9b7df079bae19f"
13
14DEPENDS = "libcap libpng cairo dbus udev"
15PROVIDES = "virtual/psplash"
16RPROVIDES_${PN} = "virtual/psplash virtual/psplash-support"
17
18SRC_URI = "http://www.freedesktop.org/software/plymouth/releases/${BPN}-${PV}.tar.bz2"
19SRC_URI[md5sum] = "ff420994deb7ea203df678df92e7ab7d"
20SRC_URI[sha256sum] = "2f0ce82042cf9c7eadd2517a1f74c8a85fa8699781d9f294a06eade29fbed57f"
21
22EXTRA_OECONF += " --enable-shared --disable-static --disable-gtk \
23 --with-logo=${LOGO} \
24 ${@bb.utils.contains('DISTRO_FEATURES', 'systemd', '--enable-systemd-integration --with-system-root-install', '', d)} \
25 "
26
27PACKAGECONFIG[drm] = "--enable-drm,--disable-drm,libdrm"
28PACKAGECONFIG[pango] = "--enable-pango,--disable-pango,pango"
29PACKAGECONFIG[gtk] = "--enable-gtk,--disable-gtk,gtk+"
30
31PACKAGECONFIG ??= "pango"
32
33LOGO ??= "${datadir}/plymouth/bizcom.png"
34
35PACKAGECONFIG_append_x86 = " drm"
36PACKAGECONFIG_append_x86-64 = " drm"
37
38inherit autotools pkgconfig systemd
39
40
41do_install_append() {
42 install -d ${D}${systemd_unitdir}/system
43 install -m 644 ${B}/systemd-units/*.service ${D}${systemd_unitdir}/system
44 install -m 644 ${B}/systemd-units/systemd-ask-password-plymouth.path ${D}${systemd_unitdir}/system
45 # Remove /var/run from package as plymouth will populate it on startup
46 rm -fr "${D}${localstatedir}/run"
47}
48
49PACKAGES =+ "${PN}-initrd ${PN}-set-default-theme"
50
51FILES_${PN}-initrd = "${libdir}/plymouth/plymouth/*"
52FILES_${PN}-set-default-theme = "${sbindir}/plymouth-set-default-theme"
53
54FILES_${PN} += "${systemd_unitdir}/system/*"
55FILES_${PN}-dbg += "${libdir}/plymouth/renderers/.debug"
56
57
58RDEPENDS_${PN}-initrd = "bash dracut"
59RDEPENDS_${PN}-set-default-theme = "bash"
60
61SYSTEMD_SERVICE_${PN} = "plymouth-start.service"