summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorJörg Sommer <joerg.sommer@navimatix.de>2023-12-27 17:58:35 +0100
committerKhem Raj <raj.khem@gmail.com>2023-12-29 09:04:22 -0800
commit813fb0def8a8bca81706496dd6f106692616a11f (patch)
tree0b9dce36592159be651ca6dfa276ee975976193c
parentf4c3c747d6df6015eb1231f2867ffe43ddb9620e (diff)
downloadmeta-openembedded-813fb0def8a8bca81706496dd6f106692616a11f.tar.gz
i2cdev: New recipe with i2c tools
The main part is the tool lsi2c to scan the i2c bus, like lspci and lsusb do. This recipe also ships a static library *libi2cdev.a*. Because this library contains the file *smbus.c* which is *GPL v2+,* and a static library can't be linked dynamically to satisfy the LGPL, the whole recipe is marked as *GPL-2.0-or-later.* Signed-off-by: Jörg Sommer <joerg.sommer@navimatix.de> Signed-off-by: Khem Raj <raj.khem@gmail.com>
-rw-r--r--meta-oe/recipes-bsp/i2cdev/i2cdev/fix-lsi2c-makefile.patch28
-rw-r--r--meta-oe/recipes-bsp/i2cdev/i2cdev_git.bb26
2 files changed, 54 insertions, 0 deletions
diff --git a/meta-oe/recipes-bsp/i2cdev/i2cdev/fix-lsi2c-makefile.patch b/meta-oe/recipes-bsp/i2cdev/i2cdev/fix-lsi2c-makefile.patch
new file mode 100644
index 0000000000..820d4bb447
--- /dev/null
+++ b/meta-oe/recipes-bsp/i2cdev/i2cdev/fix-lsi2c-makefile.patch
@@ -0,0 +1,28 @@
1From 57c09727220e00ab961325a2c85f5611bd1770d6 Mon Sep 17 00:00:00 2001
2Message-Id: <57c09727220e00ab961325a2c85f5611bd1770d6.1701984646.git.joerg.sommer@navimatix.de>
3From: =?UTF-8?q?J=C3=B6rg=20Sommer?= <joerg.sommer@navimatix.de>
4Date: Thu, 7 Dec 2023 22:29:40 +0100
5Subject: [PATCH] lsi2c/Makefile: Use builddir to refer to libi2cdev.a
6
7Signed-off-by: Jörg Sommer <joerg.sommer@navimatix.de>
8Upstream-Status: Submitted [https://github.com/costad2/i2cdev/pull/2/commits/43f15e97d869797dbfeaacafa13216aaaf353426]
9---
10 lsi2c/Makefile.am | 2 +-
11 1 file changed, 1 insertion(+), 1 deletion(-)
12
13diff --git a/lsi2c/Makefile.am b/lsi2c/Makefile.am
14index 6defc1f..0d81d01 100644
15--- a/lsi2c/Makefile.am
16+++ b/lsi2c/Makefile.am
17@@ -14,7 +14,7 @@ bin_PROGRAMS=lsi2c
18 lsi2c_SOURCES = lsi2c.c
19
20 # Linker options for lsi2c
21-lsi2c_LDADD = $(top_srcdir)/libi2cdev/libi2cdev.a
22+lsi2c_LDADD = $(top_builddir)/libi2cdev/libi2cdev.a
23
24 # Compiler options for lsi2c
25 lsi2c_CFLAGS = -I$(top_srcdir)/include -std=c99 -fPIC
26--
272.34.1
28
diff --git a/meta-oe/recipes-bsp/i2cdev/i2cdev_git.bb b/meta-oe/recipes-bsp/i2cdev/i2cdev_git.bb
new file mode 100644
index 0000000000..b1f8a7f805
--- /dev/null
+++ b/meta-oe/recipes-bsp/i2cdev/i2cdev_git.bb
@@ -0,0 +1,26 @@
1SUMMARY = "i2c dev tools for Linux"
2DESCRIPTION = "\
3 This package contains an I2C dev library and the i2c bus scanning \
4 utility lsi2c. \
5"
6AUTHOR = "Danielle Costantino"
7HOMEPAGE = "https://github.com/costad2/i2cdev"
8LICENSE = "GPL-2.0-or-later"
9LIC_FILES_CHKSUM = "\
10 file://COPYING;md5=768997ba510a952bef1775c50bc22b00 \
11 file://include/libi2cdev.h;beginline=12;endline=25;md5=72486a5e192d6ac5c7e55a4a95e380a6 \
12 file://libi2cdev/smbus.c;beginline=9;endline=22;md5=d9a0de5a611b960fa75912ded6c60096 \
13 file://lsi2c/lsi2c.c;beginline=11;endline=24;md5=72486a5e192d6ac5c7e55a4a95e380a6 \
14"
15
16PR = "git${SRCPV}"
17
18SRC_URI = "\
19 git://github.com/costad2/i2cdev.git;protocol=https;branch=master \
20 file://fix-lsi2c-makefile.patch \
21"
22SRCREV = "ed9ad777d842880e7ac6ca5e0de4bd2d3b4d02dc"
23
24S = "${WORKDIR}/git"
25
26inherit autotools