summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMark Asselstine <mark.asselstine@windriver.com>2017-12-04 14:00:44 -0500
committerArmin Kuster <akuster808@gmail.com>2017-12-22 19:43:55 -0800
commit80b3f2e8203b26d8424d2e86405293a1fc0e262b (patch)
tree1ec148fb989782f6ffa801d19bac245f2a7e8ca2
parent6b9cb0a7b0ff3142575ef1630b97b41a4c6cb5d7 (diff)
downloadmeta-openembedded-80b3f2e8203b26d8424d2e86405293a1fc0e262b.tar.gz
python-pyroute2: uprev to v0.4.21 (from 0.3.22)
Drop the json<-->simplejson patch instead opting to depend on python-json (part of core python libs). Beyond this the uprev is straightforward. Signed-off-by: Mark Asselstine <mark.asselstine@windriver.com> Signed-off-by: Armin Kuster <akuster808@gmail.com>
-rw-r--r--meta-python/recipes-devtools/python/python-pyroute2.inc23
-rw-r--r--meta-python/recipes-devtools/python/python-pyroute2/import-simplejson-as-json.patch26
-rw-r--r--meta-python/recipes-devtools/python/python-pyroute2_0.4.21.bb (renamed from meta-python/recipes-devtools/python/python-pyroute2_0.3.22.bb)0
-rw-r--r--meta-python/recipes-devtools/python/python3-pyroute2_0.4.21.bb (renamed from meta-python/recipes-devtools/python/python3-pyroute2_0.3.22.bb)0
4 files changed, 6 insertions, 43 deletions
diff --git a/meta-python/recipes-devtools/python/python-pyroute2.inc b/meta-python/recipes-devtools/python/python-pyroute2.inc
index da1d4cd9b..521162c77 100644
--- a/meta-python/recipes-devtools/python/python-pyroute2.inc
+++ b/meta-python/recipes-devtools/python/python-pyroute2.inc
@@ -1,26 +1,15 @@
1SUMMARY = "A pure Python netlink and Linux network configuration library" 1SUMMARY = "A pure Python netlink and Linux network configuration library"
2LICENSE = "GPLv2 & Apache-2.0" 2LICENSE = "GPLv2 & Apache-2.0"
3LIC_FILES_CHKSUM = "file://LICENSE.GPL.v2;md5=b234ee4d69f5fce4486a80fdaf4a4263 \ 3LIC_FILES_CHKSUM = "file://LICENSE.GPL.v2;md5=b234ee4d69f5fce4486a80fdaf4a4263 \
4 file://LICENSE.Apache.v2;md5=3b83ef96387f14655fc854ddc3c6bd57" 4 file://LICENSE.Apache.v2;md5=34281e312165f843a2b7d1f114fe65ce"
5 5
6SRC_URI[md5sum] = "733adb362b6603c7269c0b3df3045a55" 6SRC_URI[md5sum] = "9c251543c4282a2f8b1a8d6aa8afc688"
7SRC_URI[sha256sum] = "5cdf44656cf623369f0cbf183d9d14a1a50ebdffbd50d4e30ffda62c0a05d7b3" 7SRC_URI[sha256sum] = "7afad28ee0a0f3e7c34adaa9f953d00560ed9910203e93f107833b6e8d151171"
8
9SRC_URI += "file://import-simplejson-as-json.patch"
10 8
11FILESEXTRAPATHS_prepend := "${THISDIR}/python-pyroute2:" 9FILESEXTRAPATHS_prepend := "${THISDIR}/python-pyroute2:"
12 10
13inherit pypi 11inherit pypi
14 12
15RDEPENDS_${PN} += "\ 13RDEPENDS_${PN} += " \
16 ${PYTHON_PN}-distutils \ 14 ${PYTHON_PN}-json \
17 ${PYTHON_PN}-simplejson \ 15 "
18 ${PYTHON_PN}-multiprocessing \
19 ${PYTHON_PN}-io ${PYTHON_PN}-pprint \
20 ${PYTHON_PN}-pickle \
21 ${PYTHON_PN}-logging \
22 ${PYTHON_PN}-threading \
23 ${PYTHON_PN}-textutils \
24 ${PYTHON_PN}-subprocess \
25 ${PYTHON_PN}-netclient \
26"
diff --git a/meta-python/recipes-devtools/python/python-pyroute2/import-simplejson-as-json.patch b/meta-python/recipes-devtools/python/python-pyroute2/import-simplejson-as-json.patch
deleted file mode 100644
index d73da07d2..000000000
--- a/meta-python/recipes-devtools/python/python-pyroute2/import-simplejson-as-json.patch
+++ /dev/null
@@ -1,26 +0,0 @@
1Upstream-Status: Inappropriate [wrong dependency]
2
3Subject: [PATCH] import simplejson as json
4
5At runtime python-pyroute2 tries to import json, but the module is not
6available, import simplejson as json solve the issue.
7
8Signed-off-by: Fabio Berton <fabio.berton@ossystems.com.br>
9---
10 pyroute2/netlink/rtnl/ifinfmsg.py | 2 +-
11 1 file changed, 1 insertion(+), 1 deletion(-)
12
13diff --git a/pyroute2/netlink/rtnl/ifinfmsg.py b/pyroute2/netlink/rtnl/ifinfmsg.py
14index 4f14f25..55643eb 100644
15--- a/pyroute2/netlink/rtnl/ifinfmsg.py
16+++ b/pyroute2/netlink/rtnl/ifinfmsg.py
17@@ -1,5 +1,5 @@
18 import os
19-import json
20+import simplejson as json
21 import errno
22 import select
23 import struct
24--
252.1.4
26
diff --git a/meta-python/recipes-devtools/python/python-pyroute2_0.3.22.bb b/meta-python/recipes-devtools/python/python-pyroute2_0.4.21.bb
index 7b9c8e044..7b9c8e044 100644
--- a/meta-python/recipes-devtools/python/python-pyroute2_0.3.22.bb
+++ b/meta-python/recipes-devtools/python/python-pyroute2_0.4.21.bb
diff --git a/meta-python/recipes-devtools/python/python3-pyroute2_0.3.22.bb b/meta-python/recipes-devtools/python/python3-pyroute2_0.4.21.bb
index a23e72c4a..a23e72c4a 100644
--- a/meta-python/recipes-devtools/python/python3-pyroute2_0.3.22.bb
+++ b/meta-python/recipes-devtools/python/python3-pyroute2_0.4.21.bb