summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authoralperak <alperyasinak1@gmail.com>2024-02-07 09:32:44 +0300
committerKhem Raj <raj.khem@gmail.com>2024-02-09 09:52:14 -0800
commit7e45304132af657fed7990e271dd4a9f9255ab43 (patch)
treea73afce8e6e19d7b03144a1a686bf4f849f1a02f
parent941f2a62151368232d179ccc11a0037f751415bf (diff)
downloadmeta-openembedded-7e45304132af657fed7990e271dd4a9f9255ab43.tar.gz
python3-web3: upgrade 6.15.0 -> 6.15.1
Changelog: Bugfixes Handle new geth errors related to waiting for a transaction receipt while transactions are still being indexed Improved Documentation Remove annual user survey prompt from docs Internal Changes Create test fixture for latest geth version. Run tests with geth in --dev mode Formatting updates for black==24.1.0 Add eth-tester version that supports eth_feeHistory Signed-off-by: alperak <alperyasinak1@gmail.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
-rw-r--r--meta-python/recipes-devtools/python/python3-web3_6.15.0.bb21
-rw-r--r--meta-python/recipes-devtools/python/python3-web3_6.15.1.bb26
2 files changed, 26 insertions, 21 deletions
diff --git a/meta-python/recipes-devtools/python/python3-web3_6.15.0.bb b/meta-python/recipes-devtools/python/python3-web3_6.15.0.bb
deleted file mode 100644
index e216857de..000000000
--- a/meta-python/recipes-devtools/python/python3-web3_6.15.0.bb
+++ /dev/null
@@ -1,21 +0,0 @@
1SUMMARY = "A Python library for interacting with Ethereum."
2HOMEPAGE = "https://github.com/ethereum/web3.py"
3SECTION = "devel/python"
4LICENSE = "MIT"
5LIC_FILES_CHKSUM = "file://LICENSE;md5=373fede350846fdffd23648fba504635"
6
7SRC_URI[sha256sum] = "a646d1fe5eba00625b5459d23910e472f0d0aa063788422bff2648ca4e1ebc7e"
8
9inherit pypi setuptools3
10
11RDEPENDS:${PN} += " \
12 python3-aiohttp \
13 python3-eth-account \
14 python3-idna \
15 python3-jsonschema \
16 python3-google-api-core \
17 python3-lru-dict \
18 python3-requests \
19 python3-setuptools \
20 python3-websockets \
21"
diff --git a/meta-python/recipes-devtools/python/python3-web3_6.15.1.bb b/meta-python/recipes-devtools/python/python3-web3_6.15.1.bb
new file mode 100644
index 000000000..00b19bb24
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-web3_6.15.1.bb
@@ -0,0 +1,26 @@
1SUMMARY = "A Python library for interacting with Ethereum."
2HOMEPAGE = "https://github.com/ethereum/web3.py"
3SECTION = "devel/python"
4LICENSE = "MIT"
5LIC_FILES_CHKSUM = "file://LICENSE;md5=373fede350846fdffd23648fba504635"
6
7SRC_URI[sha256sum] = "f9e7eefc1b3c3d194868a4ef9583b625c18ea3f31a48ebe143183db74898f381"
8
9inherit pypi setuptools3
10
11RDEPENDS:${PN} += " \
12 ${PYTHON_PN}-aiohttp \
13 ${PYTHON_PN}-eth-abi \
14 ${PYTHON_PN}-eth-account \
15 ${PYTHON_PN}-eth-hash \
16 ${PYTHON_PN}-eth-typing \
17 ${PYTHON_PN}-eth-utils \
18 ${PYTHON_PN}-hexbytes \
19 ${PYTHON_PN}-jsonschema \
20 ${PYTHON_PN}-protobuf \
21 ${PYTHON_PN}-pydantic \
22 ${PYTHON_PN}-requests \
23 ${PYTHON_PN}-typing-extensions \
24 ${PYTHON_PN}-websockets \
25 ${PYTHON_PN}-pyunormalize \
26"