diff options
author | Andreas Oberritter <obi@opendreambox.org> | 2014-03-13 15:18:33 +0100 |
---|---|---|
committer | Martin Jansa <Martin.Jansa@gmail.com> | 2014-03-18 20:09:34 +0100 |
commit | 7cd63c175d4b8c47236872bbe07572786df3130a (patch) | |
tree | a9f24dd3210b21645b30a7583cbbf89c0fc0c085 | |
parent | d92c9c652c272aa22036458adf3c0bcb44eca728 (diff) | |
download | meta-openembedded-7cd63c175d4b8c47236872bbe07572786df3130a.tar.gz |
libconnman-qt: update to 1.0.50+git80ac184
Allows to install versions for Qt4/X11 and Qt4/Embedded into
the same filesystem by overriding the target name.
This version also removes a superflous .pc file from ${libdir}.
Signed-off-by: Andreas Oberritter <obi@opendreambox.org>
Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
3 files changed, 47 insertions, 4 deletions
diff --git a/meta-oe/recipes-qt/libconnman-qt/libconnman-qt.inc b/meta-oe/recipes-qt/libconnman-qt/libconnman-qt.inc index 77e70e899..3f91be2a4 100644 --- a/meta-oe/recipes-qt/libconnman-qt/libconnman-qt.inc +++ b/meta-oe/recipes-qt/libconnman-qt/libconnman-qt.inc | |||
@@ -3,8 +3,8 @@ HOMEPAGE = "https://github.com/nemomobile/libconnman-qt" | |||
3 | SECTION = "qt/lib" | 3 | SECTION = "qt/lib" |
4 | LICENSE = "Apache-2.0" | 4 | LICENSE = "Apache-2.0" |
5 | LIC_FILES_CHKSUM = "file://libconnman-qt/clockmodel.h;endline=8;md5=ea9f724050803f15d2d900ce3c5dac88" | 5 | LIC_FILES_CHKSUM = "file://libconnman-qt/clockmodel.h;endline=8;md5=ea9f724050803f15d2d900ce3c5dac88" |
6 | SRCREV = "ddbeaf72b4d3c49285b0513b28948edacfc40b51" | 6 | SRCREV = "80ac184d859ea90c026403f5a520644945a5081a" |
7 | PV = "1.0.46+git${SRCPV}" | 7 | PV = "1.0.50+git${SRCPV}" |
8 | 8 | ||
9 | SRC_URI = "git://github.com/nemomobile/libconnman-qt.git;branch=master" | 9 | SRC_URI = "git://github.com/nemomobile/libconnman-qt.git;branch=master" |
10 | 10 | ||
@@ -12,7 +12,7 @@ S = "${WORKDIR}/git" | |||
12 | 12 | ||
13 | inherit pkgconfig | 13 | inherit pkgconfig |
14 | 14 | ||
15 | EXTRA_QMAKEVARS_PRE += "CONFIG+=notests" | 15 | EXTRA_QMAKEVARS_PRE += "CONFIG+=notests TARGET_SUFFIX=${QT_DIR_NAME}" |
16 | 16 | ||
17 | do_configure_prepend() { | 17 | do_configure_prepend() { |
18 | # Hack *.pro variables | 18 | # Hack *.pro variables |
@@ -37,7 +37,6 @@ FILES_${PN}-dev = " \ | |||
37 | ${libdir}/libconnman-qt*${SOLIBSDEV} \ | 37 | ${libdir}/libconnman-qt*${SOLIBSDEV} \ |
38 | ${libdir}/libconnman-qt*.prl \ | 38 | ${libdir}/libconnman-qt*.prl \ |
39 | ${libdir}/pkgconfig/connman-qt*.pc \ | 39 | ${libdir}/pkgconfig/connman-qt*.pc \ |
40 | ${libdir}/connman-qt*.pc \ | ||
41 | " | 40 | " |
42 | FILES_${PN}-plugin = " \ | 41 | FILES_${PN}-plugin = " \ |
43 | ${PLUGINS_TARGET}/qmldir \ | 42 | ${PLUGINS_TARGET}/qmldir \ |
diff --git a/meta-oe/recipes-qt/libconnman-qt/libconnman-qte/plugin.pro-fix-build-with-custom-target-suffix.patch b/meta-oe/recipes-qt/libconnman-qt/libconnman-qte/plugin.pro-fix-build-with-custom-target-suffix.patch new file mode 100644 index 000000000..3ff68c8dc --- /dev/null +++ b/meta-oe/recipes-qt/libconnman-qt/libconnman-qte/plugin.pro-fix-build-with-custom-target-suffix.patch | |||
@@ -0,0 +1,42 @@ | |||
1 | Upstream-Status: Submitted [https://github.com/nemomobile/libconnman-qt/pull/105] | ||
2 | |||
3 | From 48da520b971af69d22e691a0ef6ff1c3ce901f0d Mon Sep 17 00:00:00 2001 | ||
4 | From: Andreas Oberritter <obi@opendreambox.org> | ||
5 | Date: Tue, 11 Mar 2014 21:55:37 +0100 | ||
6 | Subject: [PATCH] plugin.pro: fix build with custom target suffix | ||
7 | |||
8 | This went unnoticed because of a previously installed libconnman-qt4. | ||
9 | |||
10 | Signed-off-by: Andreas Oberritter <obi@opendreambox.org> | ||
11 | --- | ||
12 | plugin/plugin.pro | 8 ++++++-- | ||
13 | 1 file changed, 6 insertions(+), 2 deletions(-) | ||
14 | |||
15 | diff --git a/plugin/plugin.pro b/plugin/plugin.pro | ||
16 | index c9534cf..9cdaa63 100644 | ||
17 | --- a/plugin/plugin.pro | ||
18 | +++ b/plugin/plugin.pro | ||
19 | @@ -8,14 +8,18 @@ INCLUDEPATH += ../libconnman-qt | ||
20 | LIBS += -L../libconnman-qt | ||
21 | QT -= gui | ||
22 | |||
23 | +isEmpty(TARGET_SUFFIX) { | ||
24 | + TARGET_SUFFIX = qt$$QT_MAJOR_VERSION | ||
25 | +} | ||
26 | + | ||
27 | +LIBS += -l$$qtLibraryTarget(connman-$$TARGET_SUFFIX) | ||
28 | + | ||
29 | equals(QT_MAJOR_VERSION, 4): { | ||
30 | QT += declarative | ||
31 | - LIBS += -lconnman-qt4 | ||
32 | } | ||
33 | |||
34 | equals(QT_MAJOR_VERSION, 5): { | ||
35 | QT += qml | ||
36 | - LIBS += -lconnman-qt5 | ||
37 | OTHER_FILES += plugin.json qmldirs | ||
38 | } | ||
39 | |||
40 | -- | ||
41 | 1.8.3.2 | ||
42 | |||
diff --git a/meta-oe/recipes-qt/libconnman-qt/libconnman-qte_git.bb b/meta-oe/recipes-qt/libconnman-qt/libconnman-qte_git.bb index 7ee4bdb08..9d44957ac 100644 --- a/meta-oe/recipes-qt/libconnman-qt/libconnman-qte_git.bb +++ b/meta-oe/recipes-qt/libconnman-qt/libconnman-qte_git.bb | |||
@@ -1,3 +1,5 @@ | |||
1 | inherit qt4e | 1 | inherit qt4e |
2 | 2 | ||
3 | require libconnman-qt.inc | 3 | require libconnman-qt.inc |
4 | |||
5 | SRC_URI += "file://plugin.pro-fix-build-with-custom-target-suffix.patch" | ||