summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2022-09-07 08:55:40 -0700
committerKhem Raj <raj.khem@gmail.com>2022-09-07 16:44:54 -0700
commit7be157321702a2b10604e31bf31620cd8eaeac72 (patch)
tree3aece44e59bbecf8ee03b951b71e0b5c9759fd38
parent1274e2772ebbf04f6e6af6aec53f5d23ae259874 (diff)
downloadmeta-openembedded-7be157321702a2b10604e31bf31620cd8eaeac72.tar.gz
cockpit: Update to 276
Specify --with-admin-group and no error on xsltproc Signed-off-by: Khem Raj <raj.khem@gmail.com>
-rw-r--r--meta-webserver/recipes-webadmin/cockpit/cockpit_276.bb (renamed from meta-webserver/recipes-webadmin/cockpit/cockpit_220.bb)7
-rw-r--r--meta-webserver/recipes-webadmin/cockpit/files/0001-Warn-not-error-if-xsltproc-is-not-found.patch27
-rw-r--r--meta-webserver/recipes-webadmin/cockpit/files/0001-remove-tests-dep-on-gobject-intro.patch77
-rw-r--r--meta-webserver/recipes-webadmin/cockpit/files/0002-fix-makefile-use-copy-rule-for-unmodified-files.patch12
4 files changed, 66 insertions, 57 deletions
diff --git a/meta-webserver/recipes-webadmin/cockpit/cockpit_220.bb b/meta-webserver/recipes-webadmin/cockpit/cockpit_276.bb
index c08de8931..93198e356 100644
--- a/meta-webserver/recipes-webadmin/cockpit/cockpit_220.bb
+++ b/meta-webserver/recipes-webadmin/cockpit/cockpit_276.bb
@@ -8,10 +8,10 @@ SRC_URI += " \
8 https://github.com/cockpit-project/cockpit/releases/download/${PV}/cockpit-${PV}.tar.xz \ 8 https://github.com/cockpit-project/cockpit/releases/download/${PV}/cockpit-${PV}.tar.xz \
9 file://0001-remove-tests-dep-on-gobject-intro.patch \ 9 file://0001-remove-tests-dep-on-gobject-intro.patch \
10 file://0002-fix-makefile-use-copy-rule-for-unmodified-files.patch \ 10 file://0002-fix-makefile-use-copy-rule-for-unmodified-files.patch \
11 file://0001-Warn-not-error-if-xsltproc-is-not-found.patch \
11 file://cockpit.pam \ 12 file://cockpit.pam \
12 " 13 "
13SRC_URI[md5sum] = "beb88d8e70ee1da6ebd917c956217803" 14SRC_URI[sha256sum] = "dde91a157ee8514112334653fa2775a99d71bd1b604067a48eaf7411114d19de"
14SRC_URI[sha256sum] = "afc82acc8ef9d51e0f34265a07a2f059f5b71a1df721b299e657a40a098cbb7f"
15 15
16inherit gettext pkgconfig autotools systemd features_check 16inherit gettext pkgconfig autotools systemd features_check
17 17
@@ -30,6 +30,7 @@ EXTRA_AUTORECONF = "-I tools"
30EXTRA_OECONF = " \ 30EXTRA_OECONF = " \
31 --with-cockpit-user=${COCKPIT_USER_GROUP} \ 31 --with-cockpit-user=${COCKPIT_USER_GROUP} \
32 --with-cockpit-group=${COCKPIT_USER_GROUP} \ 32 --with-cockpit-group=${COCKPIT_USER_GROUP} \
33 --with-admin-group=${COCKPIT_USER_GROUP} \
33 --with-cockpit-ws-instance-user=${COCKPIT_WS_USER_GROUP} \ 34 --with-cockpit-ws-instance-user=${COCKPIT_WS_USER_GROUP} \
34 --with-cockpit-ws-instance-group=${COCKPIT_WS_USER_GROUP} \ 35 --with-cockpit-ws-instance-group=${COCKPIT_WS_USER_GROUP} \
35 --disable-doc \ 36 --disable-doc \
@@ -170,6 +171,8 @@ FILES:${PN} += " \
170 ${nonarch_libdir}/firewalld \ 171 ${nonarch_libdir}/firewalld \
171" 172"
172RDEPENDS:${PN} += "${PN}-bridge" 173RDEPENDS:${PN} += "${PN}-bridge"
174# Needs bash for /usr/libexec/cockpit-certificate-helper
175RDEPENDS:${PN} += "bash"
173 176
174do_install:append() { 177do_install:append() {
175 pkgdatadir=${datadir}/cockpit 178 pkgdatadir=${datadir}/cockpit
diff --git a/meta-webserver/recipes-webadmin/cockpit/files/0001-Warn-not-error-if-xsltproc-is-not-found.patch b/meta-webserver/recipes-webadmin/cockpit/files/0001-Warn-not-error-if-xsltproc-is-not-found.patch
new file mode 100644
index 000000000..b3b0988b1
--- /dev/null
+++ b/meta-webserver/recipes-webadmin/cockpit/files/0001-Warn-not-error-if-xsltproc-is-not-found.patch
@@ -0,0 +1,27 @@
1From 588bb5cb248aaeaf0fea33084229c99ad1574291 Mon Sep 17 00:00:00 2001
2From: Khem Raj <raj.khem@gmail.com>
3Date: Wed, 7 Sep 2022 11:12:28 -0700
4Subject: [PATCH] Warn not error if xsltproc is not found
5
6Upstream-Status: Inappropriate [oe-core specific]
7Signed-off-by: Khem Raj <raj.khem@gmail.com>
8---
9 configure.ac | 2 +-
10 1 file changed, 1 insertion(+), 1 deletion(-)
11
12diff --git a/configure.ac b/configure.ac
13index 7659f41..537203e 100644
14--- a/configure.ac
15+++ b/configure.ac
16@@ -177,7 +177,7 @@ AC_SUBST([systemdunitdir], [$systemdunitdir])
17 # package as xgettext, and we find them by PATH, so just check for the one.
18 AC_PATH_PROG([XGETTEXT], [xsltproc], [no])
19 if test "$XGETTEXT" = "no"; then
20- AC_MSG_ERROR([Please install gettext tools])
21+ AC_MSG_WARN([Please install gettext tools])
22 fi
23
24 # ssh-add
25--
262.37.3
27
diff --git a/meta-webserver/recipes-webadmin/cockpit/files/0001-remove-tests-dep-on-gobject-intro.patch b/meta-webserver/recipes-webadmin/cockpit/files/0001-remove-tests-dep-on-gobject-intro.patch
index 2242190a3..8f70fe943 100644
--- a/meta-webserver/recipes-webadmin/cockpit/files/0001-remove-tests-dep-on-gobject-intro.patch
+++ b/meta-webserver/recipes-webadmin/cockpit/files/0001-remove-tests-dep-on-gobject-intro.patch
@@ -7,71 +7,52 @@ Subject: [PATCH] remove tests dep on gobject-intro
7 src/ws/Makefile-ws.am | 54 --------------------------------------------------- 7 src/ws/Makefile-ws.am | 54 ---------------------------------------------------
8 1 file changed, 54 deletions(-) 8 1 file changed, 54 deletions(-)
9 9
10diff --git a/src/ws/Makefile-ws.am b/src/ws/Makefile-ws.am
11index 009130941..34e13d7fe 100644
12--- a/src/ws/Makefile-ws.am 10--- a/src/ws/Makefile-ws.am
13+++ b/src/ws/Makefile-ws.am 11+++ b/src/ws/Makefile-ws.am
14@@ -246,60 +246,6 @@ EXTRA_DIST += \ 12@@ -58,46 +58,6 @@ pam_cockpit_cert_so_LDFLAGS = -shared
13 pam_cockpit_cert_so_SOURCES = src/ws/pam_cockpit_cert.c
15 14
16 # ---------------------------------------------------------------------------------------------------- 15 # -----------------------------------------------------------------------------
17 16-# test-server: server for running the html/browser unit tests against
18-noinst_PROGRAMS += test-server 17-
19-check_PROGRAMS += test-server 18-check_PROGRAMS += test-server
20- 19-
21-GDBUS_CODEGEN_XML = $(srcdir)/src/ws/com.redhat.Cockpit.DBusTests.xml 20-test_server_CPPFLAGS = $(libcockpit_ws_a_CPPFLAGS) $(TEST_CPP)
21-test_server_LDADD = $(libcockpit_ws_a_LIBS) $(TEST_LIBS)
22-
23-test_server_SOURCES = \
24- src/ws/mock-service.c \
25- src/ws/mock-service.h \
26- src/ws/test-server.c \
27- $(NULL)
22- 28-
29-test_server_CPPFLAGS += -I$(top_builddir)/src/ws
30-nodist_test_server_SOURCES = $(GDBUS_CODEGEN_GENERATED)
31-
32-BUILT_SOURCES += $(GDBUS_CODEGEN_GENERATED)
33-CLEANFILES += $(GDBUS_CODEGEN_GENERATED)
23-GDBUS_CODEGEN_GENERATED = \ 34-GDBUS_CODEGEN_GENERATED = \
24- src/ws/mock-dbus-tests.h \ 35- src/ws/mock-dbus-tests.h \
25- src/ws/mock-dbus-tests.c \ 36- src/ws/mock-dbus-tests.c \
26- $(NULL) 37- $(NULL)
27- 38-
28-# FIXME: --header/--body and --output are only available from GLib 2.56. 39-EXTRA_DIST += $(GDBUS_CODEGEN_XML)
29-# just use --generate-c-code and a bit of dependency ugliness for now 40-GDBUS_CODEGEN_XML = $(srcdir)/src/ws/com.redhat.Cockpit.DBusTests.xml
41-
30-GDBUS_CODEGEN_INVOCATION = \ 42-GDBUS_CODEGEN_INVOCATION = \
31- $(AM_V_GEN) gdbus-codegen \ 43- $(AM_V_GEN) gdbus-codegen \
32- --interface-prefix com.redhat.Cockpit.DBusTests \ 44- --interface-prefix com.redhat.Cockpit.DBusTests \
33- --c-namespace Test \ 45- --c-namespace Test \
34- --c-generate-object-manager \ 46- --c-generate-object-manager \
35- --generate-c-code src/ws/mock-dbus-tests \
36- $(GDBUS_CODEGEN_XML)
37-
38-BUILT_SOURCES += $(GDBUS_CODEGEN_GENERATED)
39-CLEANFILES += $(GDBUS_CODEGEN_GENERATED)
40-EXTRA_DIST += $(GDBUS_CODEGEN_XML)
41-
42-src/ws/mock-dbus-tests.h: $(GDBUS_CODEGEN_XML)
43- $(GDBUS_CODEGEN_INVOCATION)
44-
45-src/ws/mock-dbus-tests.c: $(GDBUS_CODEGEN_XML) src/ws/mock-dbus-tests.h
46- $(GDBUS_CODEGEN_INVOCATION)
47-
48-test_server_SOURCES = \
49- src/ws/mock-service.c \
50- src/ws/mock-service.h \
51- src/ws/test-server.c \
52- $(NULL)
53-
54-nodist_test_server_SOURCES = \
55- $(GDBUS_CODEGEN_GENERATED) \
56- $(NULL) 47- $(NULL)
57- 48-
58-test_server_CFLAGS = \ 49-src/ws/mock-dbus-tests.h: $(GDBUS_CODEGEN_XML)
59- -I$(builddir)/src/ws \ 50- $(GDBUS_CODEGEN_INVOCATION) --header --output $@ $<
60- -I$(top_srcdir)/src/ws \
61- -DG_LOG_DOMAIN=\"test-server\" \
62- $(GIO_CFLAGS) \
63- $(COCKPIT_WS_CFLAGS) \
64- $(NULL)
65- 51-
66-test_server_LDADD = \ 52-src/ws/mock-dbus-tests.c: $(GDBUS_CODEGEN_XML)
67- $(libcockpit_ws_LIBS) \ 53- $(GDBUS_CODEGEN_INVOCATION) --body --output $@ $<
68- $(GIO_LIBS) \
69- -lpam \
70- $(NULL)
71- 54-
72 WS_CHECKS = \ 55-# -----------------------------------------------------------------------------
73 test-base64 \ 56 # Unit tests
74 test-creds \ 57
75-- 58 check_SCRIPTS += src/ws/mock-cat-with-init
762.11.0
77
diff --git a/meta-webserver/recipes-webadmin/cockpit/files/0002-fix-makefile-use-copy-rule-for-unmodified-files.patch b/meta-webserver/recipes-webadmin/cockpit/files/0002-fix-makefile-use-copy-rule-for-unmodified-files.patch
index a1ea9bcfd..48702c3d1 100644
--- a/meta-webserver/recipes-webadmin/cockpit/files/0002-fix-makefile-use-copy-rule-for-unmodified-files.patch
+++ b/meta-webserver/recipes-webadmin/cockpit/files/0002-fix-makefile-use-copy-rule-for-unmodified-files.patch
@@ -7,13 +7,11 @@ Subject: [PATCH] fix(makefile): use copy rule for unmodified files
7 pkg/Makefile.am | 27 +++++++++++++++++++++++++++ 7 pkg/Makefile.am | 27 +++++++++++++++++++++++++++
8 1 file changed, 27 insertions(+) 8 1 file changed, 27 insertions(+)
9 9
10diff --git a/pkg/Makefile.am b/pkg/Makefile.am
11index 192b785..03b9787 100644
12--- a/pkg/Makefile.am 10--- a/pkg/Makefile.am
13+++ b/pkg/Makefile.am 11+++ b/pkg/Makefile.am
14@@ -13,6 +13,33 @@ playground_DATA = \ 12@@ -7,6 +7,33 @@ TESTS += $(pkg_TESTS)
15 dist/playground/extra.de.po: pkg/playground/extra.de.po 13 %.metainfo.xml: %.metainfo.xml.in
16 $(COPY_RULE) 14 $(AM_V_GEN) mkdir -p $(dir $@) && msgfmt --xml -d $(top_srcdir)/po --template $< --output $@
17 15
18+dist/playground/hammer.gif: pkg/playground/hammer.gif 16+dist/playground/hammer.gif: pkg/playground/hammer.gif
19+ $(COPY_RULE) 17+ $(COPY_RULE)
@@ -43,5 +41,5 @@ index 192b785..03b9787 100644
43+ $(COPY_RULE) 41+ $(COPY_RULE)
44+ 42+
45 metainfodir = ${datarootdir}/metainfo 43 metainfodir = ${datarootdir}/metainfo
46 metainfo_DATA = pkg/sosreport/org.cockpit-project.cockpit-sosreport.metainfo.xml \ 44 nodist_metainfo_DATA = \
47 pkg/kdump/org.cockpit-project.cockpit-kdump.metainfo.xml \ 45 pkg/sosreport/org.cockpit-project.cockpit-sosreport.metainfo.xml \