summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMingli Yu <mingli.yu@windriver.com>2021-08-03 14:15:10 +0800
committerKhem Raj <raj.khem@gmail.com>2021-08-03 08:53:04 -0700
commit7badffb4789959cefa2ed2d610774142cafdca88 (patch)
tree7faacd2029b2cd6dde864e0e5418b458092d022c
parent069aacc9b32a559b7fd7d537a3b5b90a3acb3cbd (diff)
downloadmeta-openembedded-7badffb4789959cefa2ed2d610774142cafdca88.tar.gz
jemalloc: add new recipe
jemalloc is a general purpose malloc(3) implementation that emphasizes fragmentation avoidance and scalable concurrency support. Signed-off-by: Mingli Yu <mingli.yu@windriver.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
-rw-r--r--meta-oe/recipes-devtools/jemalloc/jemalloc_5.2.1.bb24
1 files changed, 24 insertions, 0 deletions
diff --git a/meta-oe/recipes-devtools/jemalloc/jemalloc_5.2.1.bb b/meta-oe/recipes-devtools/jemalloc/jemalloc_5.2.1.bb
new file mode 100644
index 000000000..4738f0e78
--- /dev/null
+++ b/meta-oe/recipes-devtools/jemalloc/jemalloc_5.2.1.bb
@@ -0,0 +1,24 @@
1# Copyright (C) 2021 Mingli Yu <mingli.yu@windriver.com>
2# Released under the MIT license (see COPYING.MIT for the terms)
3
4SUMMARY = "General-purpose scalable concurrent malloc implementation"
5
6DESCRIPTION = "jemalloc is a general purpose malloc(3) implementation that emphasizes \
7fragmentation avoidance and scalable concurrency support."
8
9HOMEPAGE = "https://github.com/jemalloc/jemalloc"
10LICENSE = "BSD"
11
12SECTION = "libs"
13
14LIC_FILES_CHKSUM = "file://README;md5=6900e4a158982e4c4715bf16aa54fa10"
15
16SRC_URI = "git://github.com/jemalloc/jemalloc.git"
17
18SRCREV = "ea6b3e973b477b8061e0076bb257dbd7f3faa756"
19
20S = "${WORKDIR}/git"
21
22inherit autotools
23
24EXTRA_AUTORECONF += "--exclude=autoheader"