summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorAnders Darander <anders@chargestorm.se>2011-08-17 14:25:34 +0000
committerKoen Kooi <koen@dominion.thruhere.net>2011-08-17 09:21:40 +0200
commit7b1ed1f94a4dd44053b2f73990a729cd5aaf8ab2 (patch)
tree55c9a01ccb01df026b94735a8d0b215f68dc92e1
parent1961c8925c9697ce0adf1e1924be261c13a7dbc3 (diff)
downloadmeta-openembedded-7b1ed1f94a4dd44053b2f73990a729cd5aaf8ab2.tar.gz
ckermit: update to version 9.0
The update changes the license from kermit to BSD. Remove the NOAPCS compile flag to make the new version compile cleanly. Signed-off-by: Anders Darander <anders@chargestorm.se> Signed-off-by: Koen Kooi <koen@dominion.thruhere.net>
-rw-r--r--meta-oe/recipes-support/ckermit/ckermit_211.bb98
-rw-r--r--meta-oe/recipes-support/ckermit/ckermit_301.bb58
2 files changed, 58 insertions, 98 deletions
diff --git a/meta-oe/recipes-support/ckermit/ckermit_211.bb b/meta-oe/recipes-support/ckermit/ckermit_211.bb
deleted file mode 100644
index 3715dcccc..000000000
--- a/meta-oe/recipes-support/ckermit/ckermit_211.bb
+++ /dev/null
@@ -1,98 +0,0 @@
1DESCRIPTION = "C-Kermit is a combined serial and network communication \
2software package offering a consistent, medium-independent, \
3cross-platform approach to connection establishment, terminal \
4sessions, file transfer, character-set translation, and automation \
5of communication tasks."
6HOMEPAGE = "http://www.columbia.edu/kermit/"
7SECTION = "console/network"
8LICENSE = "Kermit"
9LIC_FILES_CHKSUM = "file://COPYING.TXT;md5=17dabbd2543933464b6d32083c3a3596"
10SRC_URI = "ftp://kermit.columbia.edu/kermit/archives/cku${PV}.tar.gz;subdir=${BPN}-${PV}"
11PR = "r0"
12
13#
14# From http://www.columbia.edu/kermit/ck80.html#license
15#
16# "Free Unix Distributions: C-Kermit may be included in "free Unix"
17# distributions such as GNU/Linux, FreeBSD, NetBSD, and OpenBSD. See the
18# license for details."
19#
20# A distribution based on OpenEmbedded (OpenZaurus, OpenSimpad, etc.) is a
21# "free Unix" distribution, therefore we can include the package.
22#
23#
24# Please note that the license is not 100% free because it limits what you can
25# do:
26#
27# "The C-Kermit source code may not be changed without the consent of
28# the Kermit Project, which will not be unreasonably withheld (this is
29# simply a matter of keeping a consistent and supportable code base)."
30#
31# But we don't change the source code in any way, so we comply to the license.
32# So, essentially for us C-Kermit is free as in beer, but not in freedom.
33#
34# That is true for other distros. C-Kkermit is distributed by:
35#
36# Debian: http://packages.debian.org/unstable/comm/ckermit
37# Gentoo: http://mirror.pudas.net/gentoo-x86-portage/app-misc/ckermit/ckermit-8.0.211.ebuild
38# SuSE: http://www.novell.com/products/linuxpackages/enterpriseserver/s390/ckermit.html
39# Fedora Core: http://cvs.fedora.redhat.com/viewcvs/devel/ckermit/
40# PLD: http://cvs.pld.org.pl/SPECS/ckermit.spec
41#
42# and, according to the Kermit website http://www.columbia.edu/kermit/ck80.html also with
43#
44# Red Hat 9 (on earlier Red Hat's it was on the PowerTools CD)
45# HP-UX
46# FreeBSD
47# NetBSD
48# OpenBSD
49#
50# ... and probably other distros as well.
51#
52
53export CC2 = "${CC}"
54export BINDIR = "${bindir}"
55export MANDIR = "${mandir}/man1"
56export INFODIR = "${infodir}"
57
58# Additional flags. For uclibc we add -DNOARROWKEYS which stops ckermit
59# trying to look inside the stdio headers.
60CKERMIT_ADDITIONAL = ""
61CKERMIT_ADDITIONAL_libc-uclibc = "-DNOARROWKEYS"
62
63TARGET_CC_ARCH += "${LDFLAGS}"
64
65do_compile () {
66 # The original makefile doesn't differentiate between CC and CC_FOR_BUILD,
67 # so we build wart manually. Note that you need a ckwart.o with the proper
68 # timestamp to make this hack work:
69 ${BUILD_CC} -c ckwart.c
70 ${BUILD_CC} -o wart ckwart.o
71 ./wart ckcpro.w ckcpro.c
72
73 # read ${S}/ckccfg.txt to understand this :-)
74 oe_runmake wermit CFLAGS="${CFLAGS} -DLINUX -DCK_POSIX_SIG \
75 -DNOTCPOPTS -DLINUXFSSTND -DNOCOTFMC -DPOSIX -DUSE_STRERROR \
76 -DNOSYSLOG -DHAVE_PTMX -DNO_DNS_SRV -DNOGFTIMER \
77 -DNOB_50 -DNOB_75 -DNOB_134 -DNOB_150 -DNOB_200 \
78 -DNOB_1800 -DNOB_3600 -DNOB_7200 -DNOB_76K -DNOB_230K \
79 -DNOB_460K -DNOB_921K \
80 -DNOAPC -DNOCSETS -DNONET -DNOUNICODE -DNOHELP -DNODEBUG \
81 -DNOFRILLS -DNOFTP -DNODIAL -DNOPUSH -DNOIKSD -DNOHTTP -DNOFLOAT \
82 -DNOSERVER -DNOSEXP -DNORLOGIN -DNOOLDMODEMS -DNOSSH -DNOLISTEN \
83 -DNORESEND -DNOAUTODL -DNOSTREAMING -DNOHINTS -DNOCKXYZ -DNOLEARN \
84 -DNOMKDIR -DNOPERMS -DNOCKTIMERS -DNOCKREGEX -DNOREALPATH \
85 -DCK_SMALL -DNOLOGDIAL -DNORENAME -DNOWHATAMI \
86 ${CKERMIT_ADDITIONAL}"
87}
88
89do_install () {
90 install -d ${D}${BINDIR} ${D}${MANDIR} ${D}${INFODIR}
91 oe_runmake 'DESTDIR=${D}' 'MANDIR=${D}${MANDIR}' install
92 # Fix up dangling symlink
93 rm ${D}${BINDIR}/kermit-sshsub
94 (cd ${D}${BINDIR} && ln -s ${BINDIR}/kermit kermit-sshusb)
95}
96
97SRC_URI[md5sum] = "5767ec5e6ff0857cbfe2d3ec1ee0e2bc"
98SRC_URI[sha256sum] = "39e7cd4892502344a635952843487d9b4bfa98e59d1e1acad5ef8aa969abba93"
diff --git a/meta-oe/recipes-support/ckermit/ckermit_301.bb b/meta-oe/recipes-support/ckermit/ckermit_301.bb
new file mode 100644
index 000000000..c789ea5b1
--- /dev/null
+++ b/meta-oe/recipes-support/ckermit/ckermit_301.bb
@@ -0,0 +1,58 @@
1DESCRIPTION = "C-Kermit is a combined serial and network communication \
2software package offering a consistent, medium-independent, \
3cross-platform approach to connection establishment, terminal \
4sessions, file transfer, character-set translation, and automation \
5of communication tasks."
6HOMEPAGE = "http://www.columbia.edu/kermit/"
7SECTION = "console/network"
8LICENSE = "BSD-3-Clause"
9LIC_FILES_CHKSUM = "file://COPYING.TXT;md5=932ca542d6c6cb8a59a0bcd76ab67cc3"
10SRC_URI = "ftp://www.columbia.edu/kermit/archives/cku${PV}.tar.gz;subdir=${BPN}-${PV}"
11PR = "r0"
12
13export CC2 = "${CC}"
14export BINDIR = "${bindir}"
15export MANDIR = "${mandir}/man1"
16export INFODIR = "${infodir}"
17
18# Additional flags. For uclibc we add -DNOARROWKEYS which stops ckermit
19# trying to look inside the stdio headers.
20CKERMIT_ADDITIONAL = ""
21CKERMIT_ADDITIONAL_libc-uclibc = "-DNOARROWKEYS"
22
23TARGET_CC_ARCH += "${LDFLAGS}"
24
25do_compile () {
26 # The original makefile doesn't differentiate between CC and CC_FOR_BUILD,
27 # so we build wart manually. Note that you need a ckwart.o with the proper
28 # timestamp to make this hack work:
29 ${BUILD_CC} -c ckwart.c
30 ${BUILD_CC} -o wart ckwart.o
31 ./wart ckcpro.w ckcpro.c
32
33 # read ${S}/ckccfg.txt to understand this :-)
34 oe_runmake wermit CFLAGS="${CFLAGS} -DLINUX -DCK_POSIX_SIG \
35 -DNOTCPOPTS -DLINUXFSSTND -DNOCOTFMC -DPOSIX -DUSE_STRERROR \
36 -DNOSYSLOG -DHAVE_PTMX -DNO_DNS_SRV -DNOGFTIMER \
37 -DNOB_50 -DNOB_75 -DNOB_134 -DNOB_150 -DNOB_200 \
38 -DNOB_1800 -DNOB_3600 -DNOB_7200 -DNOB_76K -DNOB_230K \
39 -DNOB_460K -DNOB_921K \
40 -DNOCSETS -DNONET -DNOUNICODE -DNOHELP -DNODEBUG \
41 -DNOFRILLS -DNOFTP -DNODIAL -DNOPUSH -DNOIKSD -DNOHTTP -DNOFLOAT \
42 -DNOSERVER -DNOSEXP -DNORLOGIN -DNOOLDMODEMS -DNOSSH -DNOLISTEN \
43 -DNORESEND -DNOAUTODL -DNOSTREAMING -DNOHINTS -DNOCKXYZ -DNOLEARN \
44 -DNOMKDIR -DNOPERMS -DNOCKTIMERS -DNOCKREGEX -DNOREALPATH \
45 -DCK_SMALL -DNOLOGDIAL -DNORENAME -DNOWHATAMI \
46 ${CKERMIT_ADDITIONAL}"
47}
48
49do_install () {
50 install -d ${D}${BINDIR} ${D}${MANDIR} ${D}${INFODIR}
51 oe_runmake 'DESTDIR=${D}' install
52 # Fix up dangling symlink
53 rm ${D}${BINDIR}/kermit-sshsub
54 (cd ${D}${BINDIR} && ln -s ${BINDIR}/kermit kermit-sshusb)
55}
56
57SRC_URI[md5sum] = "59e80f909edf305933af8e0348dcc5d7"
58SRC_URI[sha256sum] = "9793eb125f8936b079c6d7e5c3d2ff885cfedc07f9d2dd1e7db928e3029a211a"