diff options
author | Khem Raj <raj.khem@gmail.com> | 2024-10-25 20:04:07 -0700 |
---|---|---|
committer | Khem Raj <raj.khem@gmail.com> | 2024-10-25 20:05:22 -0700 |
commit | 79b8b765106630ab11efa388750cc36ce8875496 (patch) | |
tree | c69055b6b0693b6654aa19aa9e15e4901035f72c | |
parent | f079c1b5c9ef9166ed066f1e6f4d8276affd3bb9 (diff) | |
download | meta-openembedded-79b8b765106630ab11efa388750cc36ce8875496.tar.gz |
python3-aioresponses: Add recipe
Signed-off-by: Khem Raj <raj.khem@gmail.com>
-rw-r--r-- | meta-python/recipes-devtools/python/python3-aioresponses_0.7.6.bb | 25 |
1 files changed, 25 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-aioresponses_0.7.6.bb b/meta-python/recipes-devtools/python/python3-aioresponses_0.7.6.bb new file mode 100644 index 000000000..a99c80f59 --- /dev/null +++ b/meta-python/recipes-devtools/python/python3-aioresponses_0.7.6.bb | |||
@@ -0,0 +1,25 @@ | |||
1 | SUMMARY = "Mock out requests made by ClientSession from aiohttp package" | ||
2 | HOMEPAGE = "https://github.com/pnuckowski/aioresponses" | ||
3 | LICENSE = "MIT" | ||
4 | LIC_FILES_CHKSUM = "file://LICENSE;md5=b22b40d5974300051216633098387c57" | ||
5 | |||
6 | SRC_URI[sha256sum] = "f795d9dbda2d61774840e7e32f5366f45752d1adc1b74c9362afd017296c7ee1" | ||
7 | |||
8 | DEPENDS += "python3-pbr-native" | ||
9 | |||
10 | inherit setuptools3 pypi | ||
11 | |||
12 | RDEPENDS:${PN} += "python3-aiohttp \ | ||
13 | python3-asyncio \ | ||
14 | python3-core \ | ||
15 | python3-json \ | ||
16 | python3-math \ | ||
17 | python3-multidict \ | ||
18 | python3-netclient \ | ||
19 | python3-packaging \ | ||
20 | python3-unittest \ | ||
21 | python3-yarl" | ||
22 | |||
23 | # optionally needs asynctest asynctest.case ddt but recipes do not exist for them | ||
24 | |||
25 | PYPI_PACKAGE = "aioresponses" | ||