diff options
author | Martin Jansa <Martin.Jansa@gmail.com> | 2015-10-13 12:43:09 +0200 |
---|---|---|
committer | Martin Jansa <Martin.Jansa@gmail.com> | 2015-10-23 12:53:22 +0200 |
commit | 796f9ba6a6e3ba9d315b62d8e9f7f0873fe95b7c (patch) | |
tree | 0f4447e09be8fa7febe3c9d8f88c1206503e5f16 | |
parent | 29e99a67da917efe3f7c41a4701fa78334ab4df5 (diff) | |
download | meta-openembedded-796f9ba6a6e3ba9d315b62d8e9f7f0873fe95b7c.tar.gz |
debootstrap: cleanup the recipe
* FILESEXTRAPATHS_prepend isn't needed
* ${PN}-${PV} -> ${BP}
* drop autotools, it doesn't use autotools, there is just a Makefile
* use SUMMARY instead of DESCRIPTION
Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
-rw-r--r-- | meta-oe/recipes-devtools/debootstrap/debootstrap_1.0.67.bb | 26 |
1 files changed, 18 insertions, 8 deletions
diff --git a/meta-oe/recipes-devtools/debootstrap/debootstrap_1.0.67.bb b/meta-oe/recipes-devtools/debootstrap/debootstrap_1.0.67.bb index 8e4a988e5..73dea9b82 100644 --- a/meta-oe/recipes-devtools/debootstrap/debootstrap_1.0.67.bb +++ b/meta-oe/recipes-devtools/debootstrap/debootstrap_1.0.67.bb | |||
@@ -1,12 +1,10 @@ | |||
1 | DESCRIPTION = "Install a Debian system into a subdirectory" | 1 | SUMMARY = "Install a Debian system into a subdirectory" |
2 | HOMEPAGE = "https://wiki.debian.org/Debootstrap" | 2 | HOMEPAGE = "https://wiki.debian.org/Debootstrap" |
3 | SECTION = "devel" | 3 | SECTION = "devel" |
4 | LICENSE = "debootstrap-custom-license" | 4 | LICENSE = "debootstrap-custom-license" |
5 | LIC_FILES_CHKSUM = "file://debian/copyright;md5=1e68ced6e1689d4cd9dac75ff5225608" | 5 | LIC_FILES_CHKSUM = "file://debian/copyright;md5=1e68ced6e1689d4cd9dac75ff5225608" |
6 | 6 | ||
7 | inherit autotools pkgconfig | 7 | inherit pkgconfig |
8 | |||
9 | FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:" | ||
10 | 8 | ||
11 | SRC_URI = "\ | 9 | SRC_URI = "\ |
12 | http://http.debian.net/debian/pool/main/d/debootstrap/debootstrap_1.0.67.tar.gz \ | 10 | http://http.debian.net/debian/pool/main/d/debootstrap/debootstrap_1.0.67.tar.gz \ |
@@ -16,9 +14,21 @@ SRC_URI = "\ | |||
16 | SRC_URI[md5sum] = "eacabfe2e45415af60b1d74c3a23418a" | 14 | SRC_URI[md5sum] = "eacabfe2e45415af60b1d74c3a23418a" |
17 | SRC_URI[sha256sum] = "0a12e0a2bbff185d47711a716b1f2734856100e8784361203e834fed0cffa51b" | 15 | SRC_URI[sha256sum] = "0a12e0a2bbff185d47711a716b1f2734856100e8784361203e834fed0cffa51b" |
18 | 16 | ||
19 | S = "${WORKDIR}/${PN}-${PV}" | 17 | S = "${WORKDIR}/${BP}" |
18 | |||
19 | # All Makefile does is creation of devices.tar.gz, which fails in OE build, we use | ||
20 | # static devices.tar.gz as work around | ||
21 | # | NOTE: make -j 8 -e MAKEFLAGS= | ||
22 | # | rm -rf dev | ||
23 | # | mkdir -p dev | ||
24 | # | chown 0:0 dev | ||
25 | # | chown: changing ownership of `dev': Operation not permitted | ||
26 | # | make: *** [devices.tar.gz] Error 1 | ||
27 | # | WARNING: exit code 1 from a shell command. | ||
28 | do_compile_prepend() { | ||
29 | cp ${WORKDIR}/devices.tar.gz ${B} | ||
30 | } | ||
20 | 31 | ||
21 | do_install_prepend() { | 32 | do_install() { |
22 | cp ${WORKDIR}/devices.tar.gz ${S} | 33 | oe_runmake 'DESTDIR=${D}' install |
23 | cd "${S}" | ||
24 | } | 34 | } |