summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2021-03-12 21:42:37 -0800
committerKhem Raj <raj.khem@gmail.com>2021-03-12 22:11:42 -0800
commit7698c5cf518bc4dbd7ca1b7e2435a21713d951fd (patch)
tree606d6145d65337803337e03963939c82a14382fa
parent797c3d1e0835df70647ce49ab5e51b09e31f98d0 (diff)
downloadmeta-openembedded-7698c5cf518bc4dbd7ca1b7e2435a21713d951fd.tar.gz
xrdp: Upgrade to 0.9.15
Remove upstreamed patches Add patch to support ppc64le Signed-off-by: Khem Raj <raj.khem@gmail.com>
-rw-r--r--meta-oe/recipes-support/xrdp/xrdp/0001-Fixed-compiler-warnings-about-snprintf-truncations.patch28
-rw-r--r--meta-oe/recipes-support/xrdp/xrdp/0001-arch-Define-NO_NEED_ALIGN-on-ppc64.patch22
-rw-r--r--meta-oe/recipes-support/xrdp/xrdp/0001-correct-the-location-of-errno.h.patch30
-rw-r--r--meta-oe/recipes-support/xrdp/xrdp/0001-riscv-doesn-t-require-pointers-to-be-aligned.patch28
-rw-r--r--meta-oe/recipes-support/xrdp/xrdp_0.9.15.bb (renamed from meta-oe/recipes-support/xrdp/xrdp_0.9.14.bb)6
5 files changed, 24 insertions, 90 deletions
diff --git a/meta-oe/recipes-support/xrdp/xrdp/0001-Fixed-compiler-warnings-about-snprintf-truncations.patch b/meta-oe/recipes-support/xrdp/xrdp/0001-Fixed-compiler-warnings-about-snprintf-truncations.patch
deleted file mode 100644
index 5b9315cfb..000000000
--- a/meta-oe/recipes-support/xrdp/xrdp/0001-Fixed-compiler-warnings-about-snprintf-truncations.patch
+++ /dev/null
@@ -1,28 +0,0 @@
1From 9de23a9199d26e64ab6b5be2bb74f260200b2dc5 Mon Sep 17 00:00:00 2001
2From: matt335672 <30179339+matt335672@users.noreply.github.com>
3Date: Fri, 21 Aug 2020 12:20:31 +0100
4Subject: [PATCH] Fixed compiler warnings about snprintf truncations
5
6Upstream-Status: Backport [https://github.com/neutrinolabs/xrdp/pull/1659]
7---
8 common/log.c | 4 +---
9 1 file changed, 1 insertion(+), 3 deletions(-)
10
11diff --git a/common/log.c b/common/log.c
12index 4a0bd2f3..8686789d 100644
13--- a/common/log.c
14+++ b/common/log.c
15@@ -555,9 +555,7 @@ log_message(const enum logLevels lvl, const char *msg, ...)
16 now_t = time(&now_t);
17 now = localtime(&now_t);
18
19- snprintf(buff, 21, "[%.4d%.2d%.2d-%.2d:%.2d:%.2d] ", now->tm_year + 1900,
20- now->tm_mon + 1, now->tm_mday, now->tm_hour, now->tm_min,
21- now->tm_sec);
22+ strftime(buff, 21, "[%Y%m%d-%H:%M:%S] ", now);
23
24 internal_log_lvl2str(lvl, buff + 20);
25
26--
272.29.2
28
diff --git a/meta-oe/recipes-support/xrdp/xrdp/0001-arch-Define-NO_NEED_ALIGN-on-ppc64.patch b/meta-oe/recipes-support/xrdp/xrdp/0001-arch-Define-NO_NEED_ALIGN-on-ppc64.patch
new file mode 100644
index 000000000..c06aa7b6c
--- /dev/null
+++ b/meta-oe/recipes-support/xrdp/xrdp/0001-arch-Define-NO_NEED_ALIGN-on-ppc64.patch
@@ -0,0 +1,22 @@
1From 5958db649855bfb2ada7c0ed22a00f839b9a1161 Mon Sep 17 00:00:00 2001
2From: Khem Raj <raj.khem@gmail.com>
3Date: Fri, 12 Mar 2021 21:40:35 -0800
4Subject: [PATCH] arch: Define NO_NEED_ALIGN on ppc64
5
6Upstream-Status: Pending
7Signed-off-by: Khem Raj <raj.khem@gmail.com>
8---
9 common/arch.h | 2 +-
10 1 file changed, 1 insertion(+), 1 deletion(-)
11
12--- a/common/arch.h
13+++ b/common/arch.h
14@@ -84,7 +84,7 @@ typedef int bool_t;
15 #define NEED_ALIGN
16 #elif defined(__x86__) || defined(__x86_64__) || \
17 defined(__AMD64__) || defined(_M_IX86) || defined (_M_AMD64) || \
18- defined(__i386__) || defined(__aarch64__) || \
19+ defined(__i386__) || defined(__aarch64__) || defined(__powerpc64__) || \
20 defined(__riscv)
21 #define NO_NEED_ALIGN
22 #else
diff --git a/meta-oe/recipes-support/xrdp/xrdp/0001-correct-the-location-of-errno.h.patch b/meta-oe/recipes-support/xrdp/xrdp/0001-correct-the-location-of-errno.h.patch
deleted file mode 100644
index b06077bf0..000000000
--- a/meta-oe/recipes-support/xrdp/xrdp/0001-correct-the-location-of-errno.h.patch
+++ /dev/null
@@ -1,30 +0,0 @@
1From c8d3df40ece7d659ccc8212b18de916d28f4398a Mon Sep 17 00:00:00 2001
2From: Khem Raj <raj.khem@gmail.com>
3Date: Tue, 22 Dec 2020 23:10:52 -0800
4Subject: [PATCH] correct the location of errno.h
5
6Fixes build on musl
7
8Upstream-Status: Submitted [https://github.com/neutrinolabs/xrdp/pull/1761]
9
10Signed-off-by: Khem Raj <raj.khem@gmail.com>
11---
12 sesman/chansrv/sound.c | 2 +-
13 1 file changed, 1 insertion(+), 1 deletion(-)
14
15diff --git a/sesman/chansrv/sound.c b/sesman/chansrv/sound.c
16index b0480d33..45e17307 100644
17--- a/sesman/chansrv/sound.c
18+++ b/sesman/chansrv/sound.c
19@@ -23,7 +23,7 @@
20 #include <stdio.h>
21 #include <sys/types.h>
22 #include <sys/socket.h>
23-#include <sys/errno.h>
24+#include <errno.h>
25 #include <signal.h>
26 #include <sys/un.h>
27
28--
292.29.2
30
diff --git a/meta-oe/recipes-support/xrdp/xrdp/0001-riscv-doesn-t-require-pointers-to-be-aligned.patch b/meta-oe/recipes-support/xrdp/xrdp/0001-riscv-doesn-t-require-pointers-to-be-aligned.patch
deleted file mode 100644
index 4cd26df04..000000000
--- a/meta-oe/recipes-support/xrdp/xrdp/0001-riscv-doesn-t-require-pointers-to-be-aligned.patch
+++ /dev/null
@@ -1,28 +0,0 @@
1From 229206aa5e55a6e26a074a54a1b50139ab794b36 Mon Sep 17 00:00:00 2001
2From: Khem Raj <raj.khem@gmail.com>
3Date: Tue, 22 Dec 2020 23:01:13 -0800
4Subject: [PATCH] riscv doesn't require pointers to be aligned
5
6Upstream-Status: Submitted [https://github.com/neutrinolabs/xrdp/pull/1761]
7Signed-off-by: Khem Raj <raj.khem@gmail.com>
8---
9 common/arch.h | 3 ++-
10 1 file changed, 2 insertions(+), 1 deletion(-)
11
12diff --git a/common/arch.h b/common/arch.h
13index ccccfa5a..8c2ac1a4 100644
14--- a/common/arch.h
15+++ b/common/arch.h
16@@ -84,7 +84,8 @@ typedef int bool_t;
17 #define NEED_ALIGN
18 #elif defined(__x86__) || defined(__x86_64__) || \
19 defined(__AMD64__) || defined(_M_IX86) || defined (_M_AMD64) || \
20- defined(__i386__) || defined(__aarch64__)
21+ defined(__i386__) || defined(__aarch64__) || \
22+ defined(__riscv)
23 #define NO_NEED_ALIGN
24 #else
25 #warning unknown arch
26--
272.29.2
28
diff --git a/meta-oe/recipes-support/xrdp/xrdp_0.9.14.bb b/meta-oe/recipes-support/xrdp/xrdp_0.9.15.bb
index 078e23c6e..039ba1a76 100644
--- a/meta-oe/recipes-support/xrdp/xrdp_0.9.14.bb
+++ b/meta-oe/recipes-support/xrdp/xrdp_0.9.15.bb
@@ -14,11 +14,9 @@ SRC_URI = "git://github.com/neutrinolabs/xrdp.git;branch=devel \
14 file://xrdp.sysconfig \ 14 file://xrdp.sysconfig \
15 file://0001-Added-req_distinguished_name-in-etc-xrdp-openssl.con.patch \ 15 file://0001-Added-req_distinguished_name-in-etc-xrdp-openssl.con.patch \
16 file://0001-Fix-the-compile-error.patch \ 16 file://0001-Fix-the-compile-error.patch \
17 file://0001-riscv-doesn-t-require-pointers-to-be-aligned.patch \ 17 file://0001-arch-Define-NO_NEED_ALIGN-on-ppc64.patch \
18 file://0001-correct-the-location-of-errno.h.patch \
19 file://0001-Fixed-compiler-warnings-about-snprintf-truncations.patch \
20 " 18 "
21SRCREV = "1469d659dbccd6d042ac44f0afc4e1309788dc9d" 19SRCREV = "f24b7b7988140b18202908654db3289659303772"
22 20
23S = "${WORKDIR}/git" 21S = "${WORKDIR}/git"
24 22