summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorYi Zhao <yi.zhao@windriver.com>2015-06-04 15:48:12 +0800
committerMartin Jansa <Martin.Jansa@gmail.com>2015-06-08 14:15:24 +0200
commit74f96955feca2301227b07e585fd47d26aab5e70 (patch)
tree78324eaddd1090a433e384ac35414760b33b1117
parent44791c221c7542d0c2301cd849afb188859f25e9 (diff)
downloadmeta-openembedded-74f96955feca2301227b07e585fd47d26aab5e70.tar.gz
nodejs: fix build failure for multilib
bitbake nodejs [snip] sed: can't read /buildarea2/build/tmp/work/core2-64-poky-linux/nodejs/0.12.4-r0/image/usr/lib64/node_modules/npm/bin/npm-cli.js: No such file or directory [snip] The node modules are not binary files. It doesn't make sense to install them to /usr/lib64. Use /usr/lib/node_modules instead of /usr/lib64/node_modules even on multilib. Signed-off-by: Yi Zhao <yi.zhao@windriver.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
-rw-r--r--meta-oe/recipes-devtools/nodejs/nodejs_0.12.4.bb9
1 files changed, 3 insertions, 6 deletions
diff --git a/meta-oe/recipes-devtools/nodejs/nodejs_0.12.4.bb b/meta-oe/recipes-devtools/nodejs/nodejs_0.12.4.bb
index 4e1ba1f72..81b8c0d23 100644
--- a/meta-oe/recipes-devtools/nodejs/nodejs_0.12.4.bb
+++ b/meta-oe/recipes-devtools/nodejs/nodejs_0.12.4.bb
@@ -61,20 +61,17 @@ do_install_append_class-native() {
61 # /usr/bin/npm is symlink to /usr/lib/node_modules/npm/bin/npm-cli.js 61 # /usr/bin/npm is symlink to /usr/lib/node_modules/npm/bin/npm-cli.js
62 # use sed on npm-cli.js because otherwise symlink is replaced with normal file and 62 # use sed on npm-cli.js because otherwise symlink is replaced with normal file and
63 # npm-cli.js continues to use old shebang 63 # npm-cli.js continues to use old shebang
64 sed "1s^.*^#\!/usr/bin/env node^g" -i ${D}${libdir}/node_modules/npm/bin/npm-cli.js 64 sed "1s^.*^#\!/usr/bin/env node^g" -i ${D}${exec_prefix}/lib/node_modules/npm/bin/npm-cli.js
65} 65}
66 66
67do_install_append_class-target() { 67do_install_append_class-target() {
68 sed "1s^.*^#\!${bindir}/env node^g" -i ${D}${libdir}/node_modules/npm/bin/npm-cli.js 68 sed "1s^.*^#\!${bindir}/env node^g" -i ${D}${exec_prefix}/lib/node_modules/npm/bin/npm-cli.js
69} 69}
70 70
71PACKAGES =+ "${PN}-npm" 71PACKAGES =+ "${PN}-npm"
72FILES_${PN}-npm = "${libdir}/node_modules ${bindir}/npm" 72FILES_${PN}-npm = "${exec_prefix}/lib/node_modules ${bindir}/npm"
73RDEPENDS_${PN}-npm = "bash python-shell python-datetime python-subprocess python-textutils" 73RDEPENDS_${PN}-npm = "bash python-shell python-datetime python-subprocess python-textutils"
74 74
75PACKAGES =+ "${PN}-dtrace"
76FILES_${PN}-dtrace = "${libdir}/dtrace"
77
78PACKAGES =+ "${PN}-systemtap" 75PACKAGES =+ "${PN}-systemtap"
79FILES_${PN}-systemtap = "${datadir}/systemtap" 76FILES_${PN}-systemtap = "${datadir}/systemtap"
80 77