diff options
author | Richard Leitner <dev@g0hl1n.net> | 2024-02-05 13:58:28 +0100 |
---|---|---|
committer | Khem Raj <raj.khem@gmail.com> | 2024-02-10 10:39:58 -0800 |
commit | 704b091001c7abc282ff6a29344357f26e321988 (patch) | |
tree | b8b37115f3c969a9c9edcab4b3134e3ac381c173 | |
parent | 057781a7331685e3d9b4a93be05a1d47f5d0ac27 (diff) | |
download | meta-openembedded-704b091001c7abc282ff6a29344357f26e321988.tar.gz |
python3-httpcore: add recipe for v1.0.2
A minimal low-level HTTP client.
This recipe is currently provided without trio support, as the author
has no use for it and it would require to add a new python3-trio recipe.
This recipe uses pypi as source:
https://pypi.org/project/httpcore
Signed-off-by: Richard Leitner <dev@g0hl1n.net>
Signed-off-by: Khem Raj <raj.khem@gmail.com>
-rw-r--r-- | meta-python/recipes-devtools/python/python3-httpcore_1.0.2.bb | 26 |
1 files changed, 26 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-httpcore_1.0.2.bb b/meta-python/recipes-devtools/python/python3-httpcore_1.0.2.bb new file mode 100644 index 000000000..3bfe5ed4a --- /dev/null +++ b/meta-python/recipes-devtools/python/python3-httpcore_1.0.2.bb | |||
@@ -0,0 +1,26 @@ | |||
1 | SUMMARY = "A minimal low-level HTTP client." | ||
2 | SECTION = "devel/python" | ||
3 | LICENSE = "BSD-3-Clause" | ||
4 | LIC_FILES_CHKSUM = "file://LICENSE.md;md5=1c1f23b073da202e1f4f9e426490210c" | ||
5 | |||
6 | inherit pypi python_hatchling | ||
7 | |||
8 | SRC_URI[sha256sum] = "9fc092e4799b26174648e54b74ed5f683132a464e95643b226e00c2ed2fa6535" | ||
9 | |||
10 | DEPENDS += "\ | ||
11 | python3-hatch-fancy-pypi-readme-native \ | ||
12 | " | ||
13 | |||
14 | PACKAGECONFIG ??= "" | ||
15 | PACKAGECONFIG[http2] = ",,,python3-h2" | ||
16 | PACKAGECONFIG[socks] = ",,,python3-socksio" | ||
17 | PACKAGECONFIG[asyncio] = ",,,python3-anyio" | ||
18 | # Don't provide "trio" PACKAGECONFIG as nothing provides "python3-trio" currently. | ||
19 | # If somebody needs this please feel free to add python3-trio and enable the | ||
20 | # packageconfig below: | ||
21 | #PACKAGECONFIG[trio] = ",,,python3-trio" | ||
22 | |||
23 | RDEPENDS:${PN} += "\ | ||
24 | python3-certifi \ | ||
25 | python3-h11 \ | ||
26 | " | ||