summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2024-03-25 17:56:27 -0700
committerKhem Raj <raj.khem@gmail.com>2024-03-25 18:52:52 -0700
commit6f4ed3a094e9fffb6ab1988d0f33df9430aad126 (patch)
treea909d01fcc9050968c612bacbba7591c4cf360e0
parentbaf8e1e39b23e9271b1b8da16714d5d0b2c91d5d (diff)
downloadmeta-openembedded-6f4ed3a094e9fffb6ab1988d0f33df9430aad126.tar.gz
uftrace: Fix build with musl >= 1.2.5
The famous basename API fallout Signed-off-by: Khem Raj <raj.khem@gmail.com>
-rw-r--r--meta-oe/recipes-devtools/uftrace/uftrace/0001-include-libgen.h-for-basename.patch34
-rw-r--r--meta-oe/recipes-devtools/uftrace/uftrace_0.15.2.bb3
2 files changed, 36 insertions, 1 deletions
diff --git a/meta-oe/recipes-devtools/uftrace/uftrace/0001-include-libgen.h-for-basename.patch b/meta-oe/recipes-devtools/uftrace/uftrace/0001-include-libgen.h-for-basename.patch
new file mode 100644
index 000000000..484400351
--- /dev/null
+++ b/meta-oe/recipes-devtools/uftrace/uftrace/0001-include-libgen.h-for-basename.patch
@@ -0,0 +1,34 @@
1From 8e4e5479cee153db7315d5134663fa87082b39fc Mon Sep 17 00:00:00 2001
2From: Khem Raj <raj.khem@gmail.com>
3Date: Mon, 25 Mar 2024 17:46:24 -0700
4Subject: [PATCH] include libgen.h for basename
5
6basename prototype has been removed from string.h from latest musl [1]
7compilers e.g. clang-18 flags the absense of prototype as error. therefore
8include libgen.h for providing it.
9
10[1] https://git.musl-libc.org/cgit/musl/commit/?id=725e17ed6dff4d0cd22487bb64470881e86a92e7
11
12Upstream-Status: Submitted [https://github.com/namhyung/uftrace/pull/1909]
13Signed-off-by: Khem Raj <raj.khem@gmail.com>
14---
15 utils/utils.h | 3 +++
16 1 file changed, 3 insertions(+)
17
18diff --git a/utils/utils.h b/utils/utils.h
19index 69a6072b..60265431 100644
20--- a/utils/utils.h
21+++ b/utils/utils.h
22@@ -11,6 +11,9 @@
23
24 #include <ctype.h>
25 #include <endian.h>
26+#ifndef __GLIBC__
27+#include <libgen.h>
28+#endif
29 #include <limits.h>
30 #include <signal.h>
31 #include <stdbool.h>
32--
332.44.0
34
diff --git a/meta-oe/recipes-devtools/uftrace/uftrace_0.15.2.bb b/meta-oe/recipes-devtools/uftrace/uftrace_0.15.2.bb
index ff04d40ea..60436025a 100644
--- a/meta-oe/recipes-devtools/uftrace/uftrace_0.15.2.bb
+++ b/meta-oe/recipes-devtools/uftrace/uftrace_0.15.2.bb
@@ -11,7 +11,8 @@ DEPENDS:append:libc-musl = " argp-standalone"
11inherit autotools 11inherit autotools
12 12
13SRCREV = "9d8657e90b918994d7d2bcf6dd2cc7354c35a1b4" 13SRCREV = "9d8657e90b918994d7d2bcf6dd2cc7354c35a1b4"
14SRC_URI = "git://github.com/namhyung/${BPN};branch=master;protocol=https" 14SRC_URI = "git://github.com/namhyung/${BPN};branch=master;protocol=https \
15 file://0001-include-libgen.h-for-basename.patch"
15S = "${WORKDIR}/git" 16S = "${WORKDIR}/git"
16 17
17LDFLAGS:append:libc-musl = " -largp" 18LDFLAGS:append:libc-musl = " -largp"