summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMartin Jansa <Martin.Jansa@gmail.com>2017-08-21 09:23:55 +0200
committerMartin Jansa <Martin.Jansa@gmail.com>2017-08-31 10:18:33 +0200
commit6e7c9636d276ac02f64aa48fb4fb36f9ee8f3076 (patch)
tree658dec61c0a1de40df08919102a3a0f46d25a71e
parentec9e5ed06256ad92c818474cdb490dc0d3a0d0a3 (diff)
downloadmeta-openembedded-6e7c9636d276ac02f64aa48fb4fb36f9ee8f3076.tar.gz
meta-ruby: remove this now pretty empty layer
Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
-rw-r--r--meta-ruby/COPYING.MIT17
-rw-r--r--meta-ruby/README16
-rw-r--r--meta-ruby/classes/ruby.bbclass131
-rw-r--r--meta-ruby/conf/layer.conf15
4 files changed, 0 insertions, 179 deletions
diff --git a/meta-ruby/COPYING.MIT b/meta-ruby/COPYING.MIT
deleted file mode 100644
index fb950dc69..000000000
--- a/meta-ruby/COPYING.MIT
+++ /dev/null
@@ -1,17 +0,0 @@
1Permission is hereby granted, free of charge, to any person obtaining a copy
2of this software and associated documentation files (the "Software"), to deal
3in the Software without restriction, including without limitation the rights
4to use, copy, modify, merge, publish, distribute, sublicense, and/or sell
5copies of the Software, and to permit persons to whom the Software is
6furnished to do so, subject to the following conditions:
7
8The above copyright notice and this permission notice shall be included in
9all copies or substantial portions of the Software.
10
11THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR
12IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY,
13FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT SHALL THE
14AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER
15LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING FROM,
16OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN
17THE SOFTWARE.
diff --git a/meta-ruby/README b/meta-ruby/README
deleted file mode 100644
index 08e0aa7eb..000000000
--- a/meta-ruby/README
+++ /dev/null
@@ -1,16 +0,0 @@
1This layer depends on:
2
3URI: git://github.com/openembedded/oe-core.git
4branch: master
5revision: HEAD
6
7URI: git://github.com/openembedded/meta-oe.git
8branch: master
9revision: HEAD
10
11Send pull requests to openembedded-devel@lists.openembedded.org with '[meta-ruby]' in the subject'
12
13When sending single patches, please using something like:
14'git send-email -M -1 --to openembedded-devel@lists.openembedded.org --subject-prefix=meta-ruby][PATCH'
15
16Layer maintainer: Armin Kuster <akuster808@gmail.com>
diff --git a/meta-ruby/classes/ruby.bbclass b/meta-ruby/classes/ruby.bbclass
deleted file mode 100644
index 1acf2e0bd..000000000
--- a/meta-ruby/classes/ruby.bbclass
+++ /dev/null
@@ -1,131 +0,0 @@
1BPV ?= "${PV}"
2
3DEPENDS += " \
4 ruby-native \
5"
6RDEPENDS_${PN} += " \
7 ruby \
8"
9
10def get_rubyversion(p):
11 import re
12 from os.path import isfile
13 import subprocess
14 found_version = "SOMETHING FAILED!"
15
16 cmd = "%s/ruby" % p
17
18 if not isfile(cmd):
19 return found_version
20
21 version = subprocess.Popen([cmd, "--version"], stdout=subprocess.PIPE).communicate()[0].decode("utf-8")
22
23 r = re.compile("ruby ([0-9]+\.[0-9]+\.[0-9]+)*")
24 m = r.match(version)
25 if m:
26 found_version = m.group(1)
27
28 return found_version
29
30def get_rubygemslocation(p):
31 import re
32 from os.path import isfile
33 import subprocess
34 found_loc = "SOMETHING FAILED!"
35
36 cmd = "%s/gem" % p
37
38 if not isfile(cmd):
39 return found_loc
40
41 loc = subprocess.Popen([cmd, "env"], stdout=subprocess.PIPE).communicate()[0].decode("utf-8")
42
43 r = re.compile(".*\- (/usr.*/ruby/gems/.*)")
44 for line in loc.split('\n'):
45 m = r.match(line)
46 if m:
47 found_loc = m.group(1)
48 break
49
50 return found_loc
51
52def get_rubygemsversion(p):
53 import re
54 from os.path import isfile
55 import subprocess
56 found_version = "SOMETHING FAILED!"
57
58 cmd = "%s/gem" % p
59
60 if not isfile(cmd):
61 return found_version
62
63 version = subprocess.Popen([cmd, "env", "gemdir"], stdout=subprocess.PIPE).communicate()[0].decode("utf-8")
64
65 r = re.compile(".*([0-9]+\.[0-9]+\.[0-9]+)$")
66 m = r.match(version)
67 if m:
68 found_version = m.group(1)
69
70 return found_version
71
72RUBY_VERSION ?= "${@get_rubyversion("${STAGING_BINDIR_NATIVE}")}"
73RUBY_GEM_DIRECTORY ?= "${@get_rubygemslocation("${STAGING_BINDIR_NATIVE}")}"
74RUBY_GEM_VERSION ?= "${@get_rubygemsversion("${STAGING_BINDIR_NATIVE}")}"
75
76export GEM_HOME = "${STAGING_DIR_NATIVE}/usr/lib/ruby/gems/${RUBY_GEM_VERSION}"
77
78RUBY_BUILD_GEMS ?= "${BPN}.gemspec"
79RUBY_INSTALL_GEMS ?= "${BPN}-${BPV}.gem"
80
81RUBY_COMPILE_FLAGS ?= 'LANG="en_US.UTF-8" LC_ALL="en_US.UTF-8"'
82
83ruby_do_compile() {
84 for gem in ${RUBY_BUILD_GEMS}; do
85 ${RUBY_COMPILE_FLAGS} gem build $gem
86 done
87}
88
89
90ruby_do_install() {
91 for gem in ${RUBY_INSTALL_GEMS}; do
92 gem install --ignore-dependencies --local --env-shebang --install-dir ${D}/${libdir}/ruby/gems/${RUBY_GEM_VERSION}/ $gem
93 done
94
95 # create symlink from the gems bin directory to /usr/bin
96 for i in ${D}/${libdir}/ruby/gems/${RUBY_GEM_VERSION}/bin/*; do
97 if [ -e "$i" ]; then
98 if [ ! -d ${D}/${bindir} ]; then mkdir -p ${D}/${bindir}; fi
99 b=`basename $i`
100 ln -sf ${libdir}/ruby/gems/${RUBY_GEM_VERSION}/bin/$b ${D}/${bindir}/$b
101 fi
102 done
103}
104
105EXPORT_FUNCTIONS do_compile do_install
106
107PACKAGES = "${PN}-dbg ${PN} ${PN}-doc ${PN}-dev"
108
109FILES_${PN}-dbg += " \
110 ${libdir}/ruby/gems/${RUBY_GEM_VERSION}/gems/*/*/.debug \
111 ${libdir}/ruby/gems/${RUBY_GEM_VERSION}/gems/*/*/*/.debug \
112 ${libdir}/ruby/gems/${RUBY_GEM_VERSION}/gems/*/*/*/*/.debug \
113 ${libdir}/ruby/gems/${RUBY_GEM_VERSION}/gems/*/*/*/*/*/.debug \
114 ${libdir}/ruby/gems/${RUBY_GEM_VERSION}/extensions/*/*/.debug \
115 ${libdir}/ruby/gems/${RUBY_GEM_VERSION}/extensions/*/*/*/.debug \
116 ${libdir}/ruby/gems/${RUBY_GEM_VERSION}/extensions/*/*/*/*/.debug \
117 ${libdir}/ruby/gems/${RUBY_GEM_VERSION}/extensions/*/*/*/*/*/.debug \
118 "
119
120FILES_${PN} += " \
121 ${libdir}/ruby/gems/${RUBY_GEM_VERSION}/gems \
122 ${libdir}/ruby/gems/${RUBY_GEM_VERSION}/cache \
123 ${libdir}/ruby/gems/${RUBY_GEM_VERSION}/bin \
124 ${libdir}/ruby/gems/${RUBY_GEM_VERSION}/specifications \
125 ${libdir}/ruby/gems/${RUBY_GEM_VERSION}/build_info \
126 ${libdir}/ruby/gems/${RUBY_GEM_VERSION}/extensions \
127 "
128
129FILES_${PN}-doc += " \
130 ${libdir}/ruby/gems/${RUBY_GEM_VERSION}/doc \
131 "
diff --git a/meta-ruby/conf/layer.conf b/meta-ruby/conf/layer.conf
deleted file mode 100644
index b526a5d39..000000000
--- a/meta-ruby/conf/layer.conf
+++ /dev/null
@@ -1,15 +0,0 @@
1# We have a conf and classes directory, append to BBPATH
2BBPATH .= ":${LAYERDIR}"
3
4# We have a recipes directory, add to BBFILES
5BBFILES += "${LAYERDIR}/recipes-*/*/*.bb ${LAYERDIR}/recipes-*/*/*.bbappend"
6
7BBFILE_COLLECTIONS += "ruby-layer"
8BBFILE_PATTERN_ruby-layer := "^${LAYERDIR}/"
9BBFILE_PRIORITY_ruby-layer = "7"
10
11# This should only be incremented on significant changes that will
12# cause compatibility issues with other layers
13LAYERVERSION_ruby-layer = "1"
14
15LAYERDEPENDS_ruby-layer = "core openembedded-layer"