summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denys@ti.com>2018-04-02 19:40:37 -0400
committerArmin Kuster <akuster808@gmail.com>2018-04-08 17:00:06 -0700
commit6d97746298a2189d0be0e2dfcb471c0242e5b90a (patch)
tree8eab3b6d34c3406d1fbaddcd48ce476e97ae057e
parente4e38487ff5656ecbb00811edc6d08c90f5d04c1 (diff)
downloadmeta-openembedded-6d97746298a2189d0be0e2dfcb471c0242e5b90a.tar.gz
lmbench: refresh local patches to avoid fuzz warnings
Signed-off-by: Denys Dmytriyenko <denys@ti.com> Signed-off-by: Armin Kuster <akuster808@gmail.com>
-rw-r--r--meta-oe/recipes-benchmark/lmbench/lmbench-3.0-a9/0001-Check-for-musl-define-guard-before-redefining-sockle.patch8
-rw-r--r--meta-oe/recipes-benchmark/lmbench/lmbench-3.0-a9/0001-lat_http.c-Add-printf-format.patch6
-rw-r--r--meta-oe/recipes-benchmark/lmbench/lmbench-3.0-a9/0002-build-Adjust-CFLAGS-LDFLAGS-to-append-values-passed-.patch9
-rw-r--r--meta-oe/recipes-benchmark/lmbench/lmbench-3.0-a9/fix-lmbench-memory-check-failure.patch53
-rw-r--r--meta-oe/recipes-benchmark/lmbench/lmbench-3.0-a9/lmbench_result_html_report.patch12
-rw-r--r--meta-oe/recipes-benchmark/lmbench/lmbench-3.0-a9/obey-ranlib.patch18
-rw-r--r--meta-oe/recipes-benchmark/lmbench/lmbench-3.0-a9/update-config-script.patch18
-rw-r--r--meta-oe/recipes-benchmark/lmbench/lmbench-3.0-a9/update-results-script.patch84
-rw-r--r--meta-oe/recipes-benchmark/lmbench/lmbench-3.0-a9/use-base_libdir-instead-of-hardcoded-lib.patch10
-rw-r--r--meta-oe/recipes-benchmark/lmbench/lmbench/0001-avoid-gcc-optimize-away-the-loops.patch9
-rw-r--r--meta-oe/recipes-benchmark/lmbench/lmbench/rename-line-binary.patch15
11 files changed, 144 insertions, 98 deletions
diff --git a/meta-oe/recipes-benchmark/lmbench/lmbench-3.0-a9/0001-Check-for-musl-define-guard-before-redefining-sockle.patch b/meta-oe/recipes-benchmark/lmbench/lmbench-3.0-a9/0001-Check-for-musl-define-guard-before-redefining-sockle.patch
index 20791bf239..d7169495fa 100644
--- a/meta-oe/recipes-benchmark/lmbench/lmbench-3.0-a9/0001-Check-for-musl-define-guard-before-redefining-sockle.patch
+++ b/meta-oe/recipes-benchmark/lmbench/lmbench-3.0-a9/0001-Check-for-musl-define-guard-before-redefining-sockle.patch
@@ -1,12 +1,13 @@
1From 31d58ed7e6552781f415501e96d7cc74f83b910d Mon Sep 17 00:00:00 2001 1From ac1657e11cbb0545bdf4d1124def8c013958ed7e Mon Sep 17 00:00:00 2001
2From: Khem Raj <raj.khem@gmail.com> 2From: Khem Raj <raj.khem@gmail.com>
3Date: Wed, 12 Jul 2017 18:08:51 -0700 3Date: Wed, 12 Jul 2017 18:08:51 -0700
4Subject: [PATCH 1/2] Check for musl define guard before redefining socklen_t 4Subject: [PATCH] Check for musl define guard before redefining socklen_t
5 5
6musl uses __DEFINED_socklen_t so check for that as well 6musl uses __DEFINED_socklen_t so check for that as well
7along with HAVE_socklen_t 7along with HAVE_socklen_t
8 8
9Signed-off-by: Khem Raj <raj.khem@gmail.com> 9Signed-off-by: Khem Raj <raj.khem@gmail.com>
10
10--- 11---
11 src/bench.h | 2 +- 12 src/bench.h | 2 +-
12 1 file changed, 1 insertion(+), 1 deletion(-) 13 1 file changed, 1 insertion(+), 1 deletion(-)
@@ -24,6 +25,3 @@ index 597d068..2ebdf5a 100644
24 typedef int socklen_t; 25 typedef int socklen_t;
25 #endif 26 #endif
26 27
27--
282.13.2
29
diff --git a/meta-oe/recipes-benchmark/lmbench/lmbench-3.0-a9/0001-lat_http.c-Add-printf-format.patch b/meta-oe/recipes-benchmark/lmbench/lmbench-3.0-a9/0001-lat_http.c-Add-printf-format.patch
index 18ed43d065..943b3ec889 100644
--- a/meta-oe/recipes-benchmark/lmbench/lmbench-3.0-a9/0001-lat_http.c-Add-printf-format.patch
+++ b/meta-oe/recipes-benchmark/lmbench/lmbench-3.0-a9/0001-lat_http.c-Add-printf-format.patch
@@ -1,9 +1,10 @@
1From 6faa6acdf20aa6f738eed1483b7dceed94286adb Mon Sep 17 00:00:00 2001 1From 7c05fa5353ad91acae6e5e8a01f65d54935ef778 Mon Sep 17 00:00:00 2001
2From: Khem Raj <raj.khem@gmail.com> 2From: Khem Raj <raj.khem@gmail.com>
3Date: Tue, 27 Jun 2017 14:39:10 -0700 3Date: Tue, 27 Jun 2017 14:39:10 -0700
4Subject: [PATCH] lat_http.c: Add printf format 4Subject: [PATCH] lat_http.c: Add printf format
5 5
6Signed-off-by: Khem Raj <raj.khem@gmail.com> 6Signed-off-by: Khem Raj <raj.khem@gmail.com>
7
7--- 8---
8 src/lat_http.c | 2 +- 9 src/lat_http.c | 2 +-
9 1 file changed, 1 insertion(+), 1 deletion(-) 10 1 file changed, 1 insertion(+), 1 deletion(-)
@@ -21,6 +22,3 @@ index c630d59..28d04f7 100644
21 } 22 }
22 write(sock, buf, strlen(buf)); 23 write(sock, buf, strlen(buf));
23 while ((n = read(sock, buf, XFERSIZE)) > 0) { 24 while ((n = read(sock, buf, XFERSIZE)) > 0) {
24--
252.13.2
26
diff --git a/meta-oe/recipes-benchmark/lmbench/lmbench-3.0-a9/0002-build-Adjust-CFLAGS-LDFLAGS-to-append-values-passed-.patch b/meta-oe/recipes-benchmark/lmbench/lmbench-3.0-a9/0002-build-Adjust-CFLAGS-LDFLAGS-to-append-values-passed-.patch
index d5c8f5f2f0..353d80b3b7 100644
--- a/meta-oe/recipes-benchmark/lmbench/lmbench-3.0-a9/0002-build-Adjust-CFLAGS-LDFLAGS-to-append-values-passed-.patch
+++ b/meta-oe/recipes-benchmark/lmbench/lmbench-3.0-a9/0002-build-Adjust-CFLAGS-LDFLAGS-to-append-values-passed-.patch
@@ -1,13 +1,13 @@
1From 76f3a9abc2ff96155425ef97d8c5520cfbc8fe6a Mon Sep 17 00:00:00 2001 1From b27c253bfb78fa3c5f416e6caee101098a4b58cc Mon Sep 17 00:00:00 2001
2From: Khem Raj <raj.khem@gmail.com> 2From: Khem Raj <raj.khem@gmail.com>
3Date: Wed, 12 Jul 2017 18:09:46 -0700 3Date: Wed, 12 Jul 2017 18:09:46 -0700
4Subject: [PATCH 2/2] build: Adjust CFLAGS/LDFLAGS to append values passed from 4Subject: [PATCH] build: Adjust CFLAGS/LDFLAGS to append values passed from env
5 env
6 5
7For musl we have to pass additional arguments via cflags and ldflags 6For musl we have to pass additional arguments via cflags and ldflags
8to link in librirpc, make room for those changes to take effect 7to link in librirpc, make room for those changes to take effect
9 8
10Signed-off-by: Khem Raj <raj.khem@gmail.com> 9Signed-off-by: Khem Raj <raj.khem@gmail.com>
10
11--- 11---
12 scripts/build | 2 +- 12 scripts/build | 2 +-
13 src/Makefile | 14 +++++++------- 13 src/Makefile | 14 +++++++-------
@@ -71,6 +71,3 @@ index d9efd54..96467d7 100644
71 71
72 72
73 tag: 73 tag:
74--
752.13.2
76
diff --git a/meta-oe/recipes-benchmark/lmbench/lmbench-3.0-a9/fix-lmbench-memory-check-failure.patch b/meta-oe/recipes-benchmark/lmbench/lmbench-3.0-a9/fix-lmbench-memory-check-failure.patch
index 549a114d13..cbab5c424e 100644
--- a/meta-oe/recipes-benchmark/lmbench/lmbench-3.0-a9/fix-lmbench-memory-check-failure.patch
+++ b/meta-oe/recipes-benchmark/lmbench/lmbench-3.0-a9/fix-lmbench-memory-check-failure.patch
@@ -1,4 +1,7 @@
1lmbench: Can't proceed on some targets 1From 65180976c9963432d166b47a0b692260a69c0d47 Mon Sep 17 00:00:00 2001
2From: Qingming Su <qingming.su@windriver.com>
3Date: Tue, 19 Aug 2014 05:16:17 -0400
4Subject: [PATCH] lmbench: Can't proceed on some targets
2 5
3lmbench can't proceed on some targets. The memory check fails because the 6lmbench can't proceed on some targets. The memory check fails because the
4memory latency of each page is longer then 10us, which is a time limit set 7memory latency of each page is longer then 10us, which is a time limit set
@@ -25,13 +28,19 @@ Upstream-status: inappropriate [ configuration ]
25 28
26Signed-off-by: Mark Hatle <mark.hatle@windriver.com> 29Signed-off-by: Mark Hatle <mark.hatle@windriver.com>
27 30
31---
32 scripts/config-run | 12 +++++++---
33 src/Makefile | 4 ++--
34 src/memsize.c | 66 +++++++++++++++++++++++++++++++++++-------------------
35 3 files changed, 54 insertions(+), 28 deletions(-)
36
28diff --git a/scripts/config-run b/scripts/config-run 37diff --git a/scripts/config-run b/scripts/config-run
29index e1f7b6d..31b9256 100755 38index 918cbdf..096ed12 100755
30--- a/scripts/config-run 39--- a/scripts/config-run
31+++ b/scripts/config-run 40+++ b/scripts/config-run
32@@ -214,6 +214,12 @@ The bigger the range, the more accurate the results, but larger sizes 41@@ -197,6 +197,12 @@ The bigger the range, the more accurate the results, but larger sizes
33 take somewhat longer to run the benchmark. 42 take somewhat longer to run the benchmark.
34 43
35 EOF 44 EOF
36+ 45+
37+# By default, use 512M memory as the upper limit for lmbench test 46+# By default, use 512M memory as the upper limit for lmbench test
@@ -40,12 +49,12 @@ index e1f7b6d..31b9256 100755
40+fi 49+fi
41+ 50+
42 echo $ECHON "MB [default $MB]: $ECHOC" 51 echo $ECHON "MB [default $MB]: $ECHOC"
43 #read TMP 52 read TMP
44 TMP="" 53 if [ X$TMP != X ]
45@@ -718,10 +724,10 @@ case $MAIL in 54@@ -687,10 +693,10 @@ case $MAIL in
46 ;; 55 ;;
47 esac 56 esac
48 57
49-INFO=`../scripts/info` 58-INFO=`../scripts/info`
50+INFO=`../scripts/hostinfo` 59+INFO=`../scripts/hostinfo`
51 if [ $MAIL = yes ] 60 if [ $MAIL = yes ]
@@ -54,8 +63,8 @@ index e1f7b6d..31b9256 100755
54+ then cp ../scripts/hostinfo-template $INFO 63+ then cp ../scripts/hostinfo-template $INFO
55 chmod +w $INFO 64 chmod +w $INFO
56 REUSE=no 65 REUSE=no
57 else 66 else
58@@ -765,7 +771,7 @@ EOF 67@@ -733,7 +739,7 @@ EOF
59 then EDITOR=$TMP 68 then EDITOR=$TMP
60 fi 69 fi
61 if [ X$EDITOR != "none" ] 70 if [ X$EDITOR != "none" ]
@@ -65,10 +74,10 @@ index e1f7b6d..31b9256 100755
65 fi 74 fi
66 fi 75 fi
67diff --git a/src/Makefile b/src/Makefile 76diff --git a/src/Makefile b/src/Makefile
68index d1f0dc6..5098998 100644 77index c7e4e3c..d9efd54 100644
69--- a/src/Makefile 78--- a/src/Makefile
70+++ b/src/Makefile 79+++ b/src/Makefile
71@@ -49,7 +49,7 @@ TARGET=`../scripts/target` 80@@ -50,7 +50,7 @@ TARGET=`../scripts/target`
72 BINDIR=../bin/$(OS) 81 BINDIR=../bin/$(OS)
73 CONFIG=../bin/$(OS)/`../scripts/config` 82 CONFIG=../bin/$(OS)/`../scripts/config`
74 UTILS=../scripts/target ../scripts/os ../scripts/gnu-os ../scripts/compiler \ 83 UTILS=../scripts/target ../scripts/os ../scripts/gnu-os ../scripts/compiler \
@@ -79,21 +88,21 @@ index d1f0dc6..5098998 100644
79 INSTALL=cp 88 INSTALL=cp
80@@ -240,7 +240,7 @@ $O/getopt.o : getopt.c $(INCS) 89@@ -240,7 +240,7 @@ $O/getopt.o : getopt.c $(INCS)
81 $(COMPILE) -c getopt.c -o $O/getopt.o 90 $(COMPILE) -c getopt.c -o $O/getopt.o
82 91
83 $(UTILS) : 92 $(UTILS) :
84- -cd ../scripts; make get 93- -cd ../scripts; make get
85+ -cd ../scripts; cp info hostinfo; cp info-template hostinfo-template 94+ -cd ../scripts; cp info hostinfo; cp info-template hostinfo-template
86 95
87 # Do not remove the next line, $(MAKE) depend needs it 96 # Do not remove the next line, $(MAKE) depend needs it
88 # MAKEDEPEND follows 97 # MAKEDEPEND follows
89diff --git a/src/memsize.c b/src/memsize.c 98diff --git a/src/memsize.c b/src/memsize.c
90index eb25a09..cf9fe0c 100644 99index eb25a09..82d7faf 100644
91--- a/src/memsize.c 100--- a/src/memsize.c
92+++ b/src/memsize.c 101+++ b/src/memsize.c
93@@ -14,9 +14,12 @@ char *id = "$Id$\n"; 102@@ -14,9 +14,12 @@ char *id = "$Id$\n";
94 103
95 #define CHK(x) if ((x) == -1) { perror("x"); exit(1); } 104 #define CHK(x) if ((x) == -1) { perror("x"); exit(1); }
96 105
97-#ifndef TOO_LONG 106-#ifndef TOO_LONG
98-#define TOO_LONG 10 /* usecs */ 107-#define TOO_LONG 10 /* usecs */
99-#endif 108-#endif
@@ -103,12 +112,12 @@ index eb25a09..cf9fe0c 100644
103+ 112+
104+#define MEMORY_SIZE_1MB (1024 * 1024) 113+#define MEMORY_SIZE_1MB (1024 * 1024)
105+#define MEMORY_SIZE_8MB (8 * 1024 * 1024) 114+#define MEMORY_SIZE_8MB (8 * 1024 * 1024)
106 115
107 int alarm_triggered = 0; 116 int alarm_triggered = 0;
108 117
109@@ -35,10 +38,10 @@ main(int ac, char **av) 118@@ -35,10 +38,10 @@ main(int ac, char **av)
110 size_t delta; 119 size_t delta;
111 120
112 if (ac == 2) { 121 if (ac == 2) {
113- max = size = bytes(av[1]) * 1024 * 1024; 122- max = size = bytes(av[1]) * 1024 * 1024;
114+ max = size = bytes(av[1]) * MEMORY_SIZE_1MB; 123+ max = size = bytes(av[1]) * MEMORY_SIZE_1MB;
@@ -170,7 +179,7 @@ index eb25a09..cf9fe0c 100644
170+ time_each_page = 1; 179+ time_each_page = 1;
171+ //Set the uper limit of time spending on one page 180+ //Set the uper limit of time spending on one page
172+ too_long = 10 * time_each_page; 181+ too_long = 10 * time_each_page;
173 182
174- range = 1024 * 1024; 183- range = 1024 * 1024;
175- incr = 1024 * 1024; 184- incr = 1024 * 1024;
176- touchRange(where, range, pagesize); 185- touchRange(where, range, pagesize);
diff --git a/meta-oe/recipes-benchmark/lmbench/lmbench-3.0-a9/lmbench_result_html_report.patch b/meta-oe/recipes-benchmark/lmbench/lmbench-3.0-a9/lmbench_result_html_report.patch
index cda2f0c6d1..30708c81db 100644
--- a/meta-oe/recipes-benchmark/lmbench/lmbench-3.0-a9/lmbench_result_html_report.patch
+++ b/meta-oe/recipes-benchmark/lmbench/lmbench-3.0-a9/lmbench_result_html_report.patch
@@ -1,4 +1,7 @@
1lmbench: Fix "make html" graph failure 1From b21ca9f3911628fb66f308c6916485bbbcfb29a4 Mon Sep 17 00:00:00 2001
2From: Lin Yu <lin.yu@windriver.com>
3Date: Tue, 19 Aug 2014 05:16:16 -0400
4Subject: [PATCH] lmbench: Fix "make html" graph failure
2 5
3The html-list perl script cannot parse the first line of the result 6The html-list perl script cannot parse the first line of the result
4files about the lmbench version. 7files about the lmbench version.
@@ -14,6 +17,11 @@ Upstream-status: inappropriate [ configuration ]
14 17
15Signed-off-by: Mark Hatle <mark.hatle@windriver.com> 18Signed-off-by: Mark Hatle <mark.hatle@windriver.com>
16 19
20---
21 results/Makefile | 1 +
22 scripts/html-list | 7 ++-----
23 2 files changed, 3 insertions(+), 5 deletions(-)
24
17diff --git a/results/Makefile b/results/Makefile 25diff --git a/results/Makefile b/results/Makefile
18index 0935376..1ef9a15 100644 26index 0935376..1ef9a15 100644
19--- a/results/Makefile 27--- a/results/Makefile
@@ -38,7 +46,7 @@ index 9850461..6383115 100755
38+<h2><a href=summary.out>Summary of results</a></h2> 46+<h2><a href=summary.out>Summary of results</a></h2>
39 <hr> 47 <hr>
40 EOF 48 EOF
41 49
42@@ -47,7 +47,7 @@ foreach $os (@os) { 50@@ -47,7 +47,7 @@ foreach $os (@os) {
43 open(F, $file); 51 open(F, $file);
44 $_ = <F>; 52 $_ = <F>;
diff --git a/meta-oe/recipes-benchmark/lmbench/lmbench-3.0-a9/obey-ranlib.patch b/meta-oe/recipes-benchmark/lmbench/lmbench-3.0-a9/obey-ranlib.patch
index 41a3b3205b..fa5e6dbda3 100644
--- a/meta-oe/recipes-benchmark/lmbench/lmbench-3.0-a9/obey-ranlib.patch
+++ b/meta-oe/recipes-benchmark/lmbench/lmbench-3.0-a9/obey-ranlib.patch
@@ -1,16 +1,22 @@
1From 182a5d3dba3f440bbf35551da6d21ab1c990eb58 Mon Sep 17 00:00:00 2001
2From: Noor Ahsan <noor_ahsan@mentor.com>
3Date: Mon, 29 Aug 2011 16:17:51 +0000
4Subject: [PATCH] lmbench: Add version 3.0-a9 (initial recipe)
5
1In some cases the host may have too old of a ranlib to work. Since it's 6In some cases the host may have too old of a ranlib to work. Since it's
2not exactly a great idea to not be using the cross ranlib anyhow, fix the 7not exactly a great idea to not be using the cross ranlib anyhow, fix the
3Makefile so we can override ranlib and then override it 8Makefile so we can override ranlib and then override it
4 9
5Upstream-Status: Inappropriate [build system specific change] 10Upstream-Status: Inappropriate [build system specific change]
11
6--- 12---
7 src/Makefile | 3 ++- 13 src/Makefile | 3 ++-
8 1 file changed, 2 insertions(+), 1 deletion(-) 14 1 file changed, 2 insertions(+), 1 deletion(-)
9 15
10Index: lmbench-3.0-a9/src/Makefile 16diff --git a/src/Makefile b/src/Makefile
11=================================================================== 17index 4962815..c7a8c79 100644
12--- lmbench-3.0-a9.orig/src/Makefile 18--- a/src/Makefile
13+++ lmbench-3.0-a9/src/Makefile 19+++ b/src/Makefile
14@@ -38,6 +38,7 @@ CC=`../scripts/compiler` 20@@ -38,6 +38,7 @@ CC=`../scripts/compiler`
15 MAKE=`../scripts/make` 21 MAKE=`../scripts/make`
16 AR=ar 22 AR=ar
@@ -19,7 +25,7 @@ Index: lmbench-3.0-a9/src/Makefile
19 25
20 # base of installation location 26 # base of installation location
21 BASE=/usr/local 27 BASE=/usr/local
22@@ -217,7 +218,7 @@ $O/lmbench : ../scripts/lmbench version. 28@@ -217,7 +218,7 @@ $O/lmbench : ../scripts/lmbench version.h
23 $O/lmbench.a: $(LIBOBJS) 29 $O/lmbench.a: $(LIBOBJS)
24 /bin/rm -f $O/lmbench.a 30 /bin/rm -f $O/lmbench.a
25 $(AR) $(ARCREATE) $O/lmbench.a $(LIBOBJS) 31 $(AR) $(ARCREATE) $O/lmbench.a $(LIBOBJS)
diff --git a/meta-oe/recipes-benchmark/lmbench/lmbench-3.0-a9/update-config-script.patch b/meta-oe/recipes-benchmark/lmbench/lmbench-3.0-a9/update-config-script.patch
index b46e09ad15..44bc7bbcde 100644
--- a/meta-oe/recipes-benchmark/lmbench/lmbench-3.0-a9/update-config-script.patch
+++ b/meta-oe/recipes-benchmark/lmbench/lmbench-3.0-a9/update-config-script.patch
@@ -1,8 +1,18 @@
1From aca1a59d888421c1fc553229b8049be47e8b3ddf Mon Sep 17 00:00:00 2001
2From: Chunrong Guo <b40290@freescale.com>
3Date: Fri, 1 Mar 2013 09:50:42 +0000
4Subject: [PATCH] lmbench: update config script
5
1Upstream-Status: Pending 6Upstream-Status: Pending
2Index: lmbench-3.0-a9/scripts/config 7
3=================================================================== 8---
4--- lmbench-3.0-a9/scripts/config 2000-01-31 18:29:31.000000000 -0600 9 scripts/config | 2 +-
5+++ lmbench-3.0-a9/scripts/config 2013-03-01 00:19:41.032984315 -0600 10 1 file changed, 1 insertion(+), 1 deletion(-)
11
12diff --git a/scripts/config b/scripts/config
13index b58cb60..25d9d77 100755
14--- a/scripts/config
15+++ b/scripts/config
6@@ -3,5 +3,5 @@ 16@@ -3,5 +3,5 @@
7 UNAME=`uname -n 2>/dev/null` 17 UNAME=`uname -n 2>/dev/null`
8 if [ X$UNAME = X ] 18 if [ X$UNAME = X ]
diff --git a/meta-oe/recipes-benchmark/lmbench/lmbench-3.0-a9/update-results-script.patch b/meta-oe/recipes-benchmark/lmbench/lmbench-3.0-a9/update-results-script.patch
index 894f146d42..31c4aecbbe 100644
--- a/meta-oe/recipes-benchmark/lmbench/lmbench-3.0-a9/update-results-script.patch
+++ b/meta-oe/recipes-benchmark/lmbench/lmbench-3.0-a9/update-results-script.patch
@@ -1,45 +1,24 @@
1From 4955021bc283be404df62b97b86af3943efd29de Mon Sep 17 00:00:00 2001
2From: Noor Ahsan <noor_ahsan@mentor.com>
3Date: Mon, 29 Aug 2011 16:17:51 +0000
4Subject: [PATCH] lmbench: Add version 3.0-a9 (initial recipe)
5
1Now that we have our binaries in /usr/bin rather than the normal 6Now that we have our binaries in /usr/bin rather than the normal
2lmbench hierarchy we need to update the scripts as well to behave well here. 7lmbench hierarchy we need to update the scripts as well to behave well here.
3 8
4Upstream-Status: Inappropriate [This is related to the OE-specific behavior 9Upstream-Status: Inappropriate [This is related to the OE-specific behavior
5of installing into /usr/bin, etc, rather than dumping everything into 10of installing into /usr/bin, etc, rather than dumping everything into
6/usr/share/lmbench or similar] 11/usr/share/lmbench or similar]
7 12
8Index: lmbench-3.0-a9/scripts/results 13---
9=================================================================== 14 scripts/config-run | 40 ++++++++++++++++++++--------------------
10--- lmbench-3.0-a9.orig/scripts/results 15 scripts/results | 8 +++-----
11+++ lmbench-3.0-a9/scripts/results 16 2 files changed, 23 insertions(+), 25 deletions(-)
12@@ -8,11 +8,11 @@ RESULTS=results/$OS 17
13 BASE=../$RESULTS/`uname -n` 18diff --git a/scripts/config-run b/scripts/config-run
14 EXT=0 19index a2d5ba4..918cbdf 100755
15 20--- a/scripts/config-run
16-if [ ! -f "../bin/$OS/$CONFIG" ] 21+++ b/scripts/config-run
17+if [ ! -f "$CONFIG" ]
18 then echo "No config file?"
19 exit 1
20 fi
21-. ../bin/$OS/$CONFIG
22+. $CONFIG
23
24 if [ ! -d ../$RESULTS ]
25 then mkdir -p ../$RESULTS
26@@ -23,11 +23,9 @@ do EXT=`expr $EXT + 1`
27 RESULTS=$BASE.$EXT
28 done
29
30-cd ../bin/$OS
31-PATH=.:${PATH}; export PATH
32 export SYNC_MAX
33 export OUTPUT
34-lmbench $CONFIG 2>../${RESULTS}
35+lmbench $CONFIG 2>${RESULTS}
36
37 if [ X$MAIL = Xyes ]
38 then echo Mailing results
39Index: lmbench-3.0-a9/scripts/config-run
40===================================================================
41--- lmbench-3.0-a9.orig/scripts/config-run
42+++ lmbench-3.0-a9/scripts/config-run
43@@ -132,20 +132,20 @@ export LMBENCH_SCHED 22@@ -132,20 +132,20 @@ export LMBENCH_SCHED
44 ############################################################################ 23 ############################################################################
45 echo $L; echo ""; 24 echo $L; echo "";
@@ -89,7 +68,7 @@ Index: lmbench-3.0-a9/scripts/config-run
89 if [ `expr $SYNC_MAX \* $MB` -gt `expr $TOTAL_MEM` ] 68 if [ `expr $SYNC_MAX \* $MB` -gt `expr $TOTAL_MEM` ]
90 then 69 then
91 MB=`expr $TOTAL_MEM / $SYNC_MAX` 70 MB=`expr $TOTAL_MEM / $SYNC_MAX`
92@@ -223,8 +223,8 @@ then echo Warning: you have only ${MB}MB 71@@ -223,8 +223,8 @@ then echo Warning: you have only ${MB}MB available memory.
93 fi 72 fi
94 73
95 echo "Hang on, we are calculating your cache line size." 74 echo "Hang on, we are calculating your cache line size."
@@ -158,3 +137,34 @@ Index: lmbench-3.0-a9/scripts/config-run
158 echo DISKS=\"$DISKS\" > $C 137 echo DISKS=\"$DISKS\" > $C
159 echo DISK_DESC=\"$DISK_DESC\" >> $C 138 echo DISK_DESC=\"$DISK_DESC\" >> $C
160 echo OUTPUT=$OUTPUT >> $C 139 echo OUTPUT=$OUTPUT >> $C
140diff --git a/scripts/results b/scripts/results
141index cd07c15..d5aa558 100755
142--- a/scripts/results
143+++ b/scripts/results
144@@ -8,11 +8,11 @@ RESULTS=results/$OS
145 BASE=../$RESULTS/`uname -n`
146 EXT=0
147
148-if [ ! -f "../bin/$OS/$CONFIG" ]
149+if [ ! -f "$CONFIG" ]
150 then echo "No config file?"
151 exit 1
152 fi
153-. ../bin/$OS/$CONFIG
154+. $CONFIG
155
156 if [ ! -d ../$RESULTS ]
157 then mkdir -p ../$RESULTS
158@@ -23,11 +23,9 @@ do EXT=`expr $EXT + 1`
159 RESULTS=$BASE.$EXT
160 done
161
162-cd ../bin/$OS
163-PATH=.:${PATH}; export PATH
164 export SYNC_MAX
165 export OUTPUT
166-lmbench $CONFIG 2>../${RESULTS}
167+lmbench $CONFIG 2>${RESULTS}
168
169 if [ X$MAIL = Xyes ]
170 then echo Mailing results
diff --git a/meta-oe/recipes-benchmark/lmbench/lmbench-3.0-a9/use-base_libdir-instead-of-hardcoded-lib.patch b/meta-oe/recipes-benchmark/lmbench/lmbench-3.0-a9/use-base_libdir-instead-of-hardcoded-lib.patch
index 3351ce8875..53ec7144af 100644
--- a/meta-oe/recipes-benchmark/lmbench/lmbench-3.0-a9/use-base_libdir-instead-of-hardcoded-lib.patch
+++ b/meta-oe/recipes-benchmark/lmbench/lmbench-3.0-a9/use-base_libdir-instead-of-hardcoded-lib.patch
@@ -1,4 +1,4 @@
1From 0d09e31970616e09beb7f238c2b59bfc541148fb Mon Sep 17 00:00:00 2001 1From 73fdc58ca4eb9e2f24d854b3af3a4e5daac5a33e Mon Sep 17 00:00:00 2001
2From: Ting Liu <b28495@freescale.com> 2From: Ting Liu <b28495@freescale.com>
3Date: Fri, 22 Nov 2013 15:20:08 +0800 3Date: Fri, 22 Nov 2013 15:20:08 +0800
4Subject: [PATCH] use base_libdir instead of hardcoded /lib 4Subject: [PATCH] use base_libdir instead of hardcoded /lib
@@ -6,9 +6,10 @@ Subject: [PATCH] use base_libdir instead of hardcoded /lib
6Upsteam Status: Inappropriate [configuration] 6Upsteam Status: Inappropriate [configuration]
7 7
8Signed-off-by: Ting Liu <b28495@freescale.com> 8Signed-off-by: Ting Liu <b28495@freescale.com>
9
9--- 10---
10 src/Makefile | 4 ++-- 11 src/Makefile | 4 ++--
11 1 files changed, 2 insertions(+), 2 deletions(-) 12 1 file changed, 2 insertions(+), 2 deletions(-)
12 13
13diff --git a/src/Makefile b/src/Makefile 14diff --git a/src/Makefile b/src/Makefile
14index c7a8c79..c7e4e3c 100644 15index c7a8c79..c7e4e3c 100644
@@ -27,6 +28,3 @@ index c7a8c79..c7e4e3c 100644
27 cd ../doc; env MAKEFLAGS="$(MAKEFLAGS)" make CC="${CC}" OS="${OS}" BASE="$(BASE)" install 28 cd ../doc; env MAKEFLAGS="$(MAKEFLAGS)" make CC="${CC}" OS="${OS}" BASE="$(BASE)" install
28 29
29 30
30--
311.7.5.4
32
diff --git a/meta-oe/recipes-benchmark/lmbench/lmbench/0001-avoid-gcc-optimize-away-the-loops.patch b/meta-oe/recipes-benchmark/lmbench/lmbench/0001-avoid-gcc-optimize-away-the-loops.patch
index 2d8a2468a9..b964bef1f0 100644
--- a/meta-oe/recipes-benchmark/lmbench/lmbench/0001-avoid-gcc-optimize-away-the-loops.patch
+++ b/meta-oe/recipes-benchmark/lmbench/lmbench/0001-avoid-gcc-optimize-away-the-loops.patch
@@ -1,4 +1,7 @@
1[PATCH] avoid gcc optimize-away the loops 1From 25738bb9c75f94b451201acfd6bcab13bdeee512 Mon Sep 17 00:00:00 2001
2From: Roy Li <rongqing.li@windriver.com>
3Date: Thu, 5 May 2016 09:52:01 +0800
4Subject: [PATCH] [PATCH] avoid gcc optimize-away the loops
2 5
3Upstream-Status: pending 6Upstream-Status: pending
4 7
@@ -15,6 +18,7 @@ and TEN is macro:
15 #define TEN(a) a a a a a a a a a a 18 #define TEN(a) a a a a a a a a a a
16 19
17Signed-off-by: Roy Li <rongqing.li@windriver.com> 20Signed-off-by: Roy Li <rongqing.li@windriver.com>
21
18--- 22---
19 src/lat_ops.c | 30 +++++++++++++++++++++++++----- 23 src/lat_ops.c | 30 +++++++++++++++++++++++++-----
20 1 file changed, 25 insertions(+), 5 deletions(-) 24 1 file changed, 25 insertions(+), 5 deletions(-)
@@ -74,6 +78,3 @@ index d343ff3..457072b 100644
74 } 78 }
75 use_int((int)r); 79 use_int((int)r);
76 } 80 }
77--
782.8.1
79
diff --git a/meta-oe/recipes-benchmark/lmbench/lmbench/rename-line-binary.patch b/meta-oe/recipes-benchmark/lmbench/lmbench/rename-line-binary.patch
index 9a405213ad..b42ee7d0fe 100644
--- a/meta-oe/recipes-benchmark/lmbench/lmbench/rename-line-binary.patch
+++ b/meta-oe/recipes-benchmark/lmbench/lmbench/rename-line-binary.patch
@@ -1,3 +1,8 @@
1From 16823f5c3d3d5adad0b70e9055c08cb4e18d255b Mon Sep 17 00:00:00 2001
2From: Noor Ahsan <noor_ahsan@mentor.com>
3Date: Mon, 29 Aug 2011 16:17:51 +0000
4Subject: [PATCH] lmbench: Add version 3.0-a9 (initial recipe)
5
1Both lmbench and util-linux-ng packages provide own /usr/bin/line binaries. 6Both lmbench and util-linux-ng packages provide own /usr/bin/line binaries.
2Even though the binaries name is the same, their functionality is different. 7Even though the binaries name is the same, their functionality is different.
3This patch renames lmbench's line binary as lm_line to avoid conflicts with 8This patch renames lmbench's line binary as lm_line to avoid conflicts with
@@ -6,8 +11,14 @@ instead of line.
6 11
7Upstream-Status: Inappropriate [build system specific change] 12Upstream-Status: Inappropriate [build system specific change]
8 13
9--- patches/scripts/config-run 2006-11-26 15:11:04.000000000 -0500 14---
10+++ patches/scripts/config-run 2011-04-01 09:35:50.000000000 -0400 15 scripts/config-run | 2 +-
16 1 file changed, 1 insertion(+), 1 deletion(-)
17
18diff --git a/scripts/config-run b/scripts/config-run
19index f620c15..a2d5ba4 100755
20--- a/scripts/config-run
21+++ b/scripts/config-run
11@@ -224,7 +224,7 @@ fi 22@@ -224,7 +224,7 @@ fi
12 23
13 echo "Hang on, we are calculating your cache line size." 24 echo "Hang on, we are calculating your cache line size."