diff options
author | Bill Randle <bill.randle@gmail.com> | 2017-12-07 21:45:43 -0800 |
---|---|---|
committer | Armin Kuster <akuster808@gmail.com> | 2017-12-22 19:43:53 -0800 |
commit | 6c917a37811e09ee74a3b730b31739609b0c9cb7 (patch) | |
tree | d9ad4433143803932f47ee79379032e2242b8881 | |
parent | a899912764d4a744f7ad20786b221e2c41076c2d (diff) | |
download | meta-openembedded-6c917a37811e09ee74a3b730b31739609b0c9cb7.tar.gz |
python-flask-wtf: move core of recipe to a .inc file
V2: add FILESEXTRAPATH_prepend to pick up common patch directory.
Signed-off-by: Bill Randle <bill.randle@gmail.com>
Signed-off-by: Armin Kuster <akuster808@gmail.com>
-rw-r--r-- | meta-python/recipes-devtools/python/python-flask-wtf.inc | 16 | ||||
-rw-r--r-- | meta-python/recipes-devtools/python/python-flask-wtf_0.12.bb | 17 |
2 files changed, 17 insertions, 16 deletions
diff --git a/meta-python/recipes-devtools/python/python-flask-wtf.inc b/meta-python/recipes-devtools/python/python-flask-wtf.inc new file mode 100644 index 0000000000..3a959aed73 --- /dev/null +++ b/meta-python/recipes-devtools/python/python-flask-wtf.inc | |||
@@ -0,0 +1,16 @@ | |||
1 | DESCRIPTION = "Simple integration of Flask and WTForms." | ||
2 | LICENSE = "BSD" | ||
3 | LIC_FILES_CHKSUM = "file://LICENSE;md5=507e8635f25a06dc4f041a3a1b3359b3" | ||
4 | |||
5 | SRC_URI[md5sum] = "c53a74e8ba481bf53405fd5efdf0339e" | ||
6 | SRC_URI[sha256sum] = "bd99316c97ed1d1cb90b8f0c242c86420a891a6a2058f20717e424bf5b0bb80e" | ||
7 | |||
8 | FILESEXTRAPATHS_prepend := "${THISDIR}/python-flask-wtf:" | ||
9 | SRC_URI += " file://import-simplejson-as-json.patch" | ||
10 | |||
11 | PYPI_PACKAGE = "Flask-WTF" | ||
12 | |||
13 | RDEPENDS_${PN} = "\ | ||
14 | ${PYTHON_PN}-wtforms \ | ||
15 | ${PYTHON_PN}-simplejson \ | ||
16 | " | ||
diff --git a/meta-python/recipes-devtools/python/python-flask-wtf_0.12.bb b/meta-python/recipes-devtools/python/python-flask-wtf_0.12.bb index 79afaf6595..dbf091bc0f 100644 --- a/meta-python/recipes-devtools/python/python-flask-wtf_0.12.bb +++ b/meta-python/recipes-devtools/python/python-flask-wtf_0.12.bb | |||
@@ -1,17 +1,2 @@ | |||
1 | DESCRIPTION = "Simple integration of Flask and WTForms." | ||
2 | LICENSE = "BSD" | ||
3 | LIC_FILES_CHKSUM = "file://LICENSE;md5=507e8635f25a06dc4f041a3a1b3359b3" | ||
4 | |||
5 | SRC_URI[md5sum] = "c53a74e8ba481bf53405fd5efdf0339e" | ||
6 | SRC_URI[sha256sum] = "bd99316c97ed1d1cb90b8f0c242c86420a891a6a2058f20717e424bf5b0bb80e" | ||
7 | |||
8 | SRC_URI += " file://import-simplejson-as-json.patch" | ||
9 | |||
10 | PYPI_PACKAGE = "Flask-WTF" | ||
11 | |||
12 | inherit pypi setuptools | 1 | inherit pypi setuptools |
13 | 2 | require python-flask-wtf.inc | |
14 | RDEPENDS_${PN} = "\ | ||
15 | python-wtforms \ | ||
16 | python-simplejson \ | ||
17 | " | ||