summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2019-02-03 23:11:48 -0800
committerKhem Raj <raj.khem@gmail.com>2019-02-04 10:11:36 -0800
commit6bcca16266dd9ec151f47da6783531da23918aa0 (patch)
treedb5cb47b78303b2b4977f62baef6fc1b3665fcb8
parentcfa4bb240f2e0237ce6962df4ddcb681979d07cf (diff)
downloadmeta-openembedded-6bcca16266dd9ec151f47da6783531da23918aa0.tar.gz
opencv: Upgrade to 3.4.5
Drop adding git revs to PV, its not needed since we are on release tag Drop upstreamed patches Signed-off-by: Khem Raj <raj.khem@gmail.com>
-rw-r--r--meta-oe/recipes-support/opencv/opencv/0001-Add-missing-multi-line-separator.patch36
-rw-r--r--meta-oe/recipes-support/opencv/opencv/0001-Check-for-clang-before-using-isystem.patch32
-rw-r--r--meta-oe/recipes-support/opencv/opencv_3.4.5.bb (renamed from meta-oe/recipes-support/opencv/opencv_3.4.3.bb)22
3 files changed, 11 insertions, 79 deletions
diff --git a/meta-oe/recipes-support/opencv/opencv/0001-Add-missing-multi-line-separator.patch b/meta-oe/recipes-support/opencv/opencv/0001-Add-missing-multi-line-separator.patch
deleted file mode 100644
index 513597b8c..000000000
--- a/meta-oe/recipes-support/opencv/opencv/0001-Add-missing-multi-line-separator.patch
+++ /dev/null
@@ -1,36 +0,0 @@
1From 60857229aab13ccc426572a43ab891409bb76ea4 Mon Sep 17 00:00:00 2001
2From: Khem Raj <raj.khem@gmail.com>
3Date: Sun, 9 Sep 2018 22:52:55 -0700
4Subject: [PATCH] Add missing multi-line separator
5
6Otherwise this fails to build ( found on mips )
7
8Fixes
9contrib/modules/surface_matching/src/hash_murmur86.hpp:97:15: error:
10expected constructor, destructor, or type conversion before '(' token
11 && defined(__GNUC__) && (__GNUC__>4 || (__GNUC__==4 &&
12__GNUC_MINOR__>=3))
13 ^
14
15Upstream-Status: Submitted [https://github.com/opencv/opencv_contrib/pull/1764]
16Signed-off-by: Khem Raj <raj.khem@gmail.com>
17---
18 modules/surface_matching/src/hash_murmur86.hpp | 2 +-
19 1 file changed, 1 insertion(+), 1 deletion(-)
20
21diff --git a/modules/surface_matching/src/hash_murmur86.hpp b/modules/surface_matching/src/hash_murmur86.hpp
22index 1edf6bf4..0477d37e 100644
23--- a/modules/surface_matching/src/hash_murmur86.hpp
24+++ b/modules/surface_matching/src/hash_murmur86.hpp
25@@ -93,7 +93,7 @@ void hashMurmurx86 ( const void * key, const int len, const uint seed, void * ou
26 /* Now find best way we can to READ_UINT32 */
27 #ifndef WORDS_BIGENDIAN
28 # define READ_UINT32(ptr) (*((uint32_t*)(ptr)))
29-#elif defined(WORDS_BIGENDIAN)
30+#elif defined(WORDS_BIGENDIAN) \
31 && defined(__GNUC__) && (__GNUC__>4 || (__GNUC__==4 && __GNUC_MINOR__>=3))
32 # define READ_UINT32(ptr) (__builtin_bswap32(*((uint32_t*)(ptr))))
33 #endif
34--
352.18.0
36
diff --git a/meta-oe/recipes-support/opencv/opencv/0001-Check-for-clang-before-using-isystem.patch b/meta-oe/recipes-support/opencv/opencv/0001-Check-for-clang-before-using-isystem.patch
deleted file mode 100644
index 319071a31..000000000
--- a/meta-oe/recipes-support/opencv/opencv/0001-Check-for-clang-before-using-isystem.patch
+++ /dev/null
@@ -1,32 +0,0 @@
1From fa76d8646bb2b9b514728eeef41afed7c43a36f2 Mon Sep 17 00:00:00 2001
2From: Khem Raj <raj.khem@gmail.com>
3Date: Tue, 11 Sep 2018 18:18:33 -0700
4Subject: [PATCH] Check for clang before using -isystem
5
6When cross compiling with clang, the internal C++ headers are not found
7when adding sysroot to -isystem, that is redundant anyway because it
8will look for headers insider --sysroot path with same quality as it
9would do with -isystem otherwise
10
11Upstream-Status: Submitted [https://github.com/opencv/opencv/pull/12504]
12Signed-off-by: Khem Raj <raj.khem@gmail.com>
13---
14 cmake/OpenCVUtils.cmake | 2 +-
15 1 file changed, 1 insertion(+), 1 deletion(-)
16
17diff --git a/cmake/OpenCVUtils.cmake b/cmake/OpenCVUtils.cmake
18index fae91c165f..60c20192dc 100644
19--- a/cmake/OpenCVUtils.cmake
20+++ b/cmake/OpenCVUtils.cmake
21@@ -259,7 +259,7 @@ function(ocv_include_directories)
22 ocv_is_opencv_directory(__is_opencv_dir "${dir}")
23 if(__is_opencv_dir)
24 list(APPEND __add_before "${dir}")
25- elseif(CV_GCC AND NOT CMAKE_CXX_COMPILER_VERSION VERSION_LESS "6.0" AND
26+ elseif(((CV_GCC AND NOT CMAKE_CXX_COMPILER_VERSION VERSION_LESS "6.0") OR CV_CLANG) AND
27 dir MATCHES "/usr/include$")
28 # workaround for GCC 6.x bug
29 else()
30--
312.18.0
32
diff --git a/meta-oe/recipes-support/opencv/opencv_3.4.3.bb b/meta-oe/recipes-support/opencv/opencv_3.4.5.bb
index 2b25e39dc..d299c599b 100644
--- a/meta-oe/recipes-support/opencv/opencv_3.4.3.bb
+++ b/meta-oe/recipes-support/opencv/opencv_3.4.5.bb
@@ -10,9 +10,9 @@ ARM_INSTRUCTION_SET_armv5 = "arm"
10 10
11DEPENDS = "libtool swig-native bzip2 zlib glib-2.0 libwebp" 11DEPENDS = "libtool swig-native bzip2 zlib glib-2.0 libwebp"
12 12
13SRCREV_opencv = "b38c50b3d0c31e82294315ec44b54b7ef559ef12" 13SRCREV_opencv = "8f1356c3c5b16721349582db461a2051653059e8"
14SRCREV_contrib = "1f6d6f06266e1ef336437ae5404bee1c65d42cda" 14SRCREV_contrib = "7292df62624ded8af8035231435dfd17c93e1a80"
15SRCREV_ipp = "bdb7bb85f34a8cb0d35e40a81f58da431aa1557a" 15SRCREV_ipp = "32e315a5b106a7b89dbed51c28f8120a48b368b4"
16SRCREV_boostdesc = "34e4206aef44d50e6bbcd0ab06354b52e7466d26" 16SRCREV_boostdesc = "34e4206aef44d50e6bbcd0ab06354b52e7466d26"
17SRCREV_vgg = "fccf7cd6a4b12079f73bbfb21745f9babcd4eb1d" 17SRCREV_vgg = "fccf7cd6a4b12079f73bbfb21745f9babcd4eb1d"
18SRC_URI[tinydnn.md5sum] = "adb1c512e09ca2c7a6faef36f9c53e59" 18SRC_URI[tinydnn.md5sum] = "adb1c512e09ca2c7a6faef36f9c53e59"
@@ -22,17 +22,17 @@ def ipp_filename(d):
22 import re 22 import re
23 arch = d.getVar('TARGET_ARCH') 23 arch = d.getVar('TARGET_ARCH')
24 if re.match("i.86$", arch): 24 if re.match("i.86$", arch):
25 return "ippicv_2017u3_lnx_ia32_general_20180518.tgz" 25 return "ippicv_2019_lnx_ia32_general_20180723.tgz"
26 else: 26 else:
27 return "ippicv_2017u3_lnx_intel64_general_20180518.tgz" 27 return "ippicv_2019_lnx_intel64_general_20180723.tgz"
28 28
29def ipp_md5sum(d): 29def ipp_md5sum(d):
30 import re 30 import re
31 arch = d.getVar('TARGET_ARCH') 31 arch = d.getVar('TARGET_ARCH')
32 if re.match("i.86$", arch): 32 if re.match("i.86$", arch):
33 return "ea72de74dae3c604eb6348395366e78e" 33 return "4f38432c30bfd6423164b7a24bbc98a0"
34 else: 34 else:
35 return "b7cc351267db2d34b9efa1cd22ff0572" 35 return "c0bd78adb4156bbf552c1dfe90599607"
36 36
37IPP_FILENAME = "${@ipp_filename(d)}" 37IPP_FILENAME = "${@ipp_filename(d)}"
38IPP_MD5 = "${@ipp_md5sum(d)}" 38IPP_MD5 = "${@ipp_md5sum(d)}"
@@ -40,21 +40,19 @@ IPP_MD5 = "${@ipp_md5sum(d)}"
40SRCREV_FORMAT = "opencv_contrib_ipp_boostdesc_vgg" 40SRCREV_FORMAT = "opencv_contrib_ipp_boostdesc_vgg"
41SRC_URI = "git://github.com/opencv/opencv.git;name=opencv \ 41SRC_URI = "git://github.com/opencv/opencv.git;name=opencv \
42 git://github.com/opencv/opencv_contrib.git;destsuffix=contrib;name=contrib \ 42 git://github.com/opencv/opencv_contrib.git;destsuffix=contrib;name=contrib \
43 git://github.com/opencv/opencv_3rdparty.git;branch=ippicv/master_20180518;destsuffix=ipp;name=ipp \ 43 git://github.com/opencv/opencv_3rdparty.git;branch=ippicv/master_20180723;destsuffix=ipp;name=ipp \
44 git://github.com/opencv/opencv_3rdparty.git;branch=contrib_xfeatures2d_boostdesc_20161012;destsuffix=boostdesc;name=boostdesc \ 44 git://github.com/opencv/opencv_3rdparty.git;branch=contrib_xfeatures2d_boostdesc_20161012;destsuffix=boostdesc;name=boostdesc \
45 git://github.com/opencv/opencv_3rdparty.git;branch=contrib_xfeatures2d_vgg_20160317;destsuffix=vgg;name=vgg \ 45 git://github.com/opencv/opencv_3rdparty.git;branch=contrib_xfeatures2d_vgg_20160317;destsuffix=vgg;name=vgg \
46 https://github.com/tiny-dnn/tiny-dnn/archive/v1.0.0a3.tar.gz;destsuffix=git/3rdparty/tinydnn/tiny-dnn-1.0.0a3;name=tinydnn;unpack=false \ 46 https://github.com/tiny-dnn/tiny-dnn/archive/v1.0.0a3.tar.gz;destsuffix=git/3rdparty/tinydnn/tiny-dnn-1.0.0a3;name=tinydnn;unpack=false \
47 file://0001-3rdparty-ippicv-Use-pre-downloaded-ipp.patch \ 47 file://0001-3rdparty-ippicv-Use-pre-downloaded-ipp.patch \
48 file://uselocalxfeatures.patch;patchdir=../contrib/ \ 48 file://uselocalxfeatures.patch;patchdir=../contrib/ \
49 file://0001-Add-missing-multi-line-separator.patch;patchdir=../contrib/ \
50 file://0002-Make-opencv-ts-create-share-library-intead-of-static.patch \ 49 file://0002-Make-opencv-ts-create-share-library-intead-of-static.patch \
51 file://0003-To-fix-errors-as-following.patch \ 50 file://0003-To-fix-errors-as-following.patch \
52 file://fixpkgconfig.patch \ 51 file://fixpkgconfig.patch \
53 file://0001-Temporarliy-work-around-deprecated-ffmpeg-RAW-functi.patch \ 52 file://0001-Temporarliy-work-around-deprecated-ffmpeg-RAW-functi.patch \
54 file://0001-Dont-use-isystem.patch \ 53 file://0001-Dont-use-isystem.patch \
55 file://0001-Check-for-clang-before-using-isystem.patch \
56" 54"
57PV = "3.4.3+git${SRCPV}" 55PV = "3.4.5"
58 56
59S = "${WORKDIR}/git" 57S = "${WORKDIR}/git"
60 58
@@ -180,6 +178,8 @@ SUMMARY_python3-opencv = "Python bindings to opencv"
180FILES_python3-opencv = "${PYTHON_SITEPACKAGES_DIR}/*" 178FILES_python3-opencv = "${PYTHON_SITEPACKAGES_DIR}/*"
181RDEPENDS_python3-opencv = "python3-core python3-numpy" 179RDEPENDS_python3-opencv = "python3-core python3-numpy"
182 180
181RDEPENDS_opencv-apps = "bash"
182
183do_install_append() { 183do_install_append() {
184 cp ${S}/include/opencv/*.h ${D}${includedir}/opencv/ 184 cp ${S}/include/opencv/*.h ${D}${includedir}/opencv/
185 sed -i '/blobtrack/d' ${D}${includedir}/opencv/cvaux.h 185 sed -i '/blobtrack/d' ${D}${includedir}/opencv/cvaux.h