summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMingli Yu <mingli.yu@windriver.com>2021-08-11 17:38:41 +0800
committerKhem Raj <raj.khem@gmail.com>2021-08-11 10:23:54 -0700
commit61638bdba3857825d1306caa67ee58b057d3bbdb (patch)
tree46f322757f0acfe371cc8baa0d4da5413f2a0e86
parent7a512dfc24256f86669cd2774191bb91a282b380 (diff)
downloadmeta-openembedded-61638bdba3857825d1306caa67ee58b057d3bbdb.tar.gz
jemalloc: add ptest support
Add ptest support. Signed-off-by: Mingli Yu <mingli.yu@windriver.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
-rw-r--r--meta-oe/recipes-devtools/jemalloc/files/run-ptest19
-rw-r--r--meta-oe/recipes-devtools/jemalloc/jemalloc_5.2.1.bb17
2 files changed, 35 insertions, 1 deletions
diff --git a/meta-oe/recipes-devtools/jemalloc/files/run-ptest b/meta-oe/recipes-devtools/jemalloc/files/run-ptest
new file mode 100644
index 000000000..ea9d80cbb
--- /dev/null
+++ b/meta-oe/recipes-devtools/jemalloc/files/run-ptest
@@ -0,0 +1,19 @@
1#!/bin/sh
2
3saved_dir=$PWD
4for dir in tests/* ; do
5 cd $dir
6 for atest in * ; do
7 if [ \( -x $atest \) -a \( -f $atest \) ] ; then
8 ./$atest > ${atest}.stdout 2> ${atest}.stderr
9 if [ $? = 0 ] ; then
10 echo "PASS: $dir $atest"
11 rm ${atest}.stdout ${atest}.stderr
12 else
13 echo "FAIL: ${dir}/${atest}"
14 fi
15 fi
16 done
17 cd $saved_dir
18done
19
diff --git a/meta-oe/recipes-devtools/jemalloc/jemalloc_5.2.1.bb b/meta-oe/recipes-devtools/jemalloc/jemalloc_5.2.1.bb
index b191f729a..b5d53bb11 100644
--- a/meta-oe/recipes-devtools/jemalloc/jemalloc_5.2.1.bb
+++ b/meta-oe/recipes-devtools/jemalloc/jemalloc_5.2.1.bb
@@ -15,14 +15,29 @@ LIC_FILES_CHKSUM = "file://README;md5=6900e4a158982e4c4715bf16aa54fa10"
15 15
16SRC_URI = "git://github.com/jemalloc/jemalloc.git \ 16SRC_URI = "git://github.com/jemalloc/jemalloc.git \
17 file://0001-Makefile.in-make-sure-doc-generated-before-install.patch \ 17 file://0001-Makefile.in-make-sure-doc-generated-before-install.patch \
18 file://run-ptest \
18" 19"
19 20
20SRCREV = "ea6b3e973b477b8061e0076bb257dbd7f3faa756" 21SRCREV = "ea6b3e973b477b8061e0076bb257dbd7f3faa756"
21 22
22S = "${WORKDIR}/git" 23S = "${WORKDIR}/git"
23 24
24inherit autotools 25inherit autotools ptest
25 26
26EXTRA_AUTORECONF += "--exclude=autoheader" 27EXTRA_AUTORECONF += "--exclude=autoheader"
27 28
28EXTRA_OECONF:append:libc-musl = " --with-jemalloc-prefix=je_" 29EXTRA_OECONF:append:libc-musl = " --with-jemalloc-prefix=je_"
30
31do_compile_ptest() {
32 oe_runmake tests
33}
34
35do_install_ptest() {
36 install -d ${D}${PTEST_PATH}/tests
37 subdirs="test/unit test/integration test/stress "
38 for tooltest in ${subdirs}
39 do
40 cp -r ${B}/${tooltest} ${D}${PTEST_PATH}/tests
41 done
42 find ${D}${PTEST_PATH}/tests \( -name "*.d" -o -name "*.o" \) -exec rm -f {} \;
43}