summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authoralperak <alperyasinak1@gmail.com>2024-03-08 22:55:04 +0300
committerKhem Raj <raj.khem@gmail.com>2024-03-09 12:35:15 -0800
commit5eb1fa3418e69c6cdeeca08f7f630e2897e690f8 (patch)
treea27dbfe9e07a72ea17784b7dba9578ef2e1b2a69
parent8c2117626556e0f84a41c8c7d4aa3b2410779ad9 (diff)
downloadmeta-openembedded-5eb1fa3418e69c6cdeeca08f7f630e2897e690f8.tar.gz
python3-wsproto: Add recipe
This package is a pure-Python implementation of a WebSocket protocol stack. It’s written from the ground up to be embeddable in whatever program you choose to use, ensuring that you can communicate via WebSockets, as defined in RFC6455, regardless of your programming paradigm. * Ptest and library example tested on qemux86-64 and qemuarm64 * Add ptest into PTESTS_FAST_META_PYTHON Ptest result: ============= qemux86-64: Testsuite summary TOTAL: 230 PASS: 230 SKIP: 0 XFAIL: 0 FAIL: 0 XPASS: 0 ERROR: 0 DURATION: 18 END: /usr/lib/python3-wsproto/ptest 2024-03-08T19:45 STOP: ptest-runner TOTAL: 1 FAIL: 0 qemuarm64: Testsuite summary TOTAL: 230 PASS: 230 SKIP: 0 XFAIL: 0 FAIL: 0 XPASS: 0 ERROR: 0 DURATION: 15 END: /usr/lib/python3-wsproto/ptest 2024-03-08T19:40 STOP: ptest-runner TOTAL: 1 FAIL: 0 Signed-off-by: alperak <alperyasinak1@gmail.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
-rw-r--r--meta-python/conf/include/ptest-packagelists-meta-python.inc1
-rw-r--r--meta-python/recipes-devtools/python/python3-wsproto/run-ptest3
-rw-r--r--meta-python/recipes-devtools/python/python3-wsproto_1.2.0.bb27
3 files changed, 31 insertions, 0 deletions
diff --git a/meta-python/conf/include/ptest-packagelists-meta-python.inc b/meta-python/conf/include/ptest-packagelists-meta-python.inc
index 584fa463e..447e0b938 100644
--- a/meta-python/conf/include/ptest-packagelists-meta-python.inc
+++ b/meta-python/conf/include/ptest-packagelists-meta-python.inc
@@ -72,6 +72,7 @@ PTESTS_FAST_META_PYTHON = "\
72 python3-unidiff \ 72 python3-unidiff \
73 python3-uritemplate \ 73 python3-uritemplate \
74 python3-wrapt \ 74 python3-wrapt \
75 python3-wsproto \
75 python3-xlrd \ 76 python3-xlrd \
76 python3-xmltodict \ 77 python3-xmltodict \
77 python3-xxhash \ 78 python3-xxhash \
diff --git a/meta-python/recipes-devtools/python/python3-wsproto/run-ptest b/meta-python/recipes-devtools/python/python3-wsproto/run-ptest
new file mode 100644
index 000000000..8d2017d39
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-wsproto/run-ptest
@@ -0,0 +1,3 @@
1#!/bin/sh
2
3pytest --automake
diff --git a/meta-python/recipes-devtools/python/python3-wsproto_1.2.0.bb b/meta-python/recipes-devtools/python/python3-wsproto_1.2.0.bb
new file mode 100644
index 000000000..09f5565a9
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-wsproto_1.2.0.bb
@@ -0,0 +1,27 @@
1SUMMARY = "WebSockets state-machine based protocol implementation"
2HOMEPAGE = "https://github.com/python-hyper/wsproto/"
3LICENSE = "MIT"
4LIC_FILES_CHKSUM = "file://LICENSE;md5=69fabf732409f4ac61875827b258caaf"
5
6inherit pypi setuptools3 ptest
7
8SRC_URI[sha256sum] = "ad565f26ecb92588a3e43bc3d96164de84cd9902482b130d0ddbaa9664a85065"
9
10SRC_URI += " \
11 file://run-ptest \
12"
13
14RDEPENDS:${PN}-ptest += " \
15 python3-pytest \
16 python3-unittest-automake-output \
17"
18
19do_install_ptest() {
20 install -d ${D}${PTEST_PATH}/tests
21 cp -rf ${S}/test/* ${D}${PTEST_PATH}/tests/
22}
23
24RDEPENDS:${PN} += " \
25 python3-h11 \
26 python3-netclient \
27"