summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorHongxu Jia <hongxu.jia@windriver.com>2018-07-16 15:31:42 +0800
committerKhem Raj <raj.khem@gmail.com>2018-07-16 18:42:41 -0700
commit5cf053a7f53333ec72a991351d2efabba75bdc9a (patch)
tree49ef70f9a9a63b5a4c21f4e89c39d8187bd45d65
parent50e8ed5fd4d09be1e89fb7fd0ba6b26c8be15699 (diff)
downloadmeta-openembedded-5cf053a7f53333ec72a991351d2efabba75bdc9a.tar.gz
polkit: 0.113 -> 0.115
- Rebase patches to 0.115 0001-make-netgroup-support-configurable.patch polkit-1_pam.patch - Add --disable-libelogind which OE does not have recipe libelogind Signed-off-by: Hongxu Jia <hongxu.jia@windriver.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
-rw-r--r--meta-oe/recipes-extended/polkit/polkit/0001-make-netgroup-support-configurable.patch56
-rw-r--r--meta-oe/recipes-extended/polkit/polkit/polkit-1_pam.patch18
-rw-r--r--meta-oe/recipes-extended/polkit/polkit_0.115.bb (renamed from meta-oe/recipes-extended/polkit/polkit_0.113.bb)10
3 files changed, 43 insertions, 41 deletions
diff --git a/meta-oe/recipes-extended/polkit/polkit/0001-make-netgroup-support-configurable.patch b/meta-oe/recipes-extended/polkit/polkit/0001-make-netgroup-support-configurable.patch
index 4e3af876e..3b0ef5e5a 100644
--- a/meta-oe/recipes-extended/polkit/polkit/0001-make-netgroup-support-configurable.patch
+++ b/meta-oe/recipes-extended/polkit/polkit/0001-make-netgroup-support-configurable.patch
@@ -12,16 +12,19 @@ Signed-off-by: Khem Raj <raj.khem@gmail.com>
12--- 12---
13Upstream-Status: Pending 13Upstream-Status: Pending
14 14
15Rebase to 0.115
16Signed-off-by: Hongxu Jia <hongxu.jia@windriver.com>
17---
15 configure.ac | 2 +- 18 configure.ac | 2 +-
16 src/polkitbackend/polkitbackendinteractiveauthority.c | 6 +++++- 19 src/polkitbackend/polkitbackendinteractiveauthority.c | 6 +++++-
17 src/polkitbackend/polkitbackendjsauthority.c | 5 ++--- 20 src/polkitbackend/polkitbackendjsauthority.cpp | 2 ++
18 3 files changed, 8 insertions(+), 5 deletions(-) 21 3 files changed, 8 insertions(+), 2 deletions(-)
19 22
20diff --git a/configure.ac b/configure.ac 23diff --git a/configure.ac b/configure.ac
21index 07982d1..21590b2 100644 24index 8b3e1b1..1c392df 100644
22--- a/configure.ac 25--- a/configure.ac
23+++ b/configure.ac 26+++ b/configure.ac
24@@ -158,7 +158,7 @@ AC_CHECK_LIB(expat,XML_ParserCreate,[EXPAT_LIBS="-lexpat"], 27@@ -99,7 +99,7 @@ AC_CHECK_LIB(expat,XML_ParserCreate,[EXPAT_LIBS="-lexpat"],
25 [AC_MSG_ERROR([Can't find expat library. Please install expat.])]) 28 [AC_MSG_ERROR([Can't find expat library. Please install expat.])])
26 AC_SUBST(EXPAT_LIBS) 29 AC_SUBST(EXPAT_LIBS)
27 30
@@ -31,10 +34,10 @@ index 07982d1..21590b2 100644
31 if test "x$GCC" = "xyes"; then 34 if test "x$GCC" = "xyes"; then
32 LDFLAGS="-Wl,--as-needed $LDFLAGS" 35 LDFLAGS="-Wl,--as-needed $LDFLAGS"
33diff --git a/src/polkitbackend/polkitbackendinteractiveauthority.c b/src/polkitbackend/polkitbackendinteractiveauthority.c 36diff --git a/src/polkitbackend/polkitbackendinteractiveauthority.c b/src/polkitbackend/polkitbackendinteractiveauthority.c
34index 7019356..cf39d77 100644 37index cb6fdab..de3f752 100644
35--- a/src/polkitbackend/polkitbackendinteractiveauthority.c 38--- a/src/polkitbackend/polkitbackendinteractiveauthority.c
36+++ b/src/polkitbackend/polkitbackendinteractiveauthority.c 39+++ b/src/polkitbackend/polkitbackendinteractiveauthority.c
37@@ -2213,7 +2213,7 @@ get_users_in_group (PolkitIdentity *group, 40@@ -2224,7 +2224,7 @@ get_users_in_group (PolkitIdentity *group,
38 out: 41 out:
39 return ret; 42 return ret;
40 } 43 }
@@ -43,7 +46,7 @@ index 7019356..cf39d77 100644
43 static GList * 46 static GList *
44 get_users_in_net_group (PolkitIdentity *group, 47 get_users_in_net_group (PolkitIdentity *group,
45 gboolean include_root) 48 gboolean include_root)
46@@ -2270,6 +2270,8 @@ get_users_in_net_group (PolkitIdentity *group, 49@@ -2285,6 +2285,8 @@ get_users_in_net_group (PolkitIdentity *group,
47 return ret; 50 return ret;
48 } 51 }
49 52
@@ -52,7 +55,7 @@ index 7019356..cf39d77 100644
52 /* ---------------------------------------------------------------------------------------------------- */ 55 /* ---------------------------------------------------------------------------------------------------- */
53 56
54 static void 57 static void
55@@ -2355,10 +2357,12 @@ authentication_agent_initiate_challenge (AuthenticationAgent *agent, 58@@ -2369,10 +2371,12 @@ authentication_agent_initiate_challenge (AuthenticationAgent *agent,
56 { 59 {
57 user_identities = g_list_concat (user_identities, get_users_in_group (identity, FALSE)); 60 user_identities = g_list_concat (user_identities, get_users_in_group (identity, FALSE));
58 } 61 }
@@ -65,43 +68,26 @@ index 7019356..cf39d77 100644
65 else 68 else
66 { 69 {
67 g_warning ("Unsupported identity"); 70 g_warning ("Unsupported identity");
68diff --git a/src/polkitbackend/polkitbackendjsauthority.c b/src/polkitbackend/polkitbackendjsauthority.c 71diff --git a/src/polkitbackend/polkitbackendjsauthority.cpp b/src/polkitbackend/polkitbackendjsauthority.cpp
69index 097dcc5..e59b3f7 100644 72index 517f3c6..6042dd2 100644
70--- a/src/polkitbackend/polkitbackendjsauthority.c 73--- a/src/polkitbackend/polkitbackendjsauthority.cpp
71+++ b/src/polkitbackend/polkitbackendjsauthority.c 74+++ b/src/polkitbackend/polkitbackendjsauthority.cpp
72@@ -1498,7 +1498,6 @@ js_polkit_spawn (JSContext *cx, 75@@ -1502,6 +1502,7 @@ js_polkit_user_is_in_netgroup (JSContext *cx,
73 76 user = JS_EncodeString (cx, args[0].toString());
74 /* ---------------------------------------------------------------------------------------------------- */ 77 netgroup = JS_EncodeString (cx, args[1].toString());
75
76-
77 static JSBool
78 js_polkit_user_is_in_netgroup (JSContext *cx,
79 unsigned argc,
80@@ -1518,6 +1517,7 @@ js_polkit_user_is_in_netgroup (JSContext *cx,
81 user = JS_EncodeString (cx, user_str);
82 netgroup = JS_EncodeString (cx, netgroup_str);
83 78
84+#if defined HAVE_INNETGR 79+#if defined HAVE_INNETGR
85 if (innetgr (netgroup, 80 if (innetgr (netgroup,
86 NULL, /* host */ 81 NULL, /* host */
87 user, 82 user,
88@@ -1525,6 +1525,7 @@ js_polkit_user_is_in_netgroup (JSContext *cx, 83@@ -1509,6 +1510,7 @@ js_polkit_user_is_in_netgroup (JSContext *cx,
89 { 84 {
90 is_in_netgroup = JS_TRUE; 85 is_in_netgroup = true;
91 } 86 }
92+#endif 87+#endif
93 88
94 JS_free (cx, netgroup); 89 JS_free (cx, netgroup);
95 JS_free (cx, user); 90 JS_free (cx, user);
96@@ -1536,8 +1537,6 @@ js_polkit_user_is_in_netgroup (JSContext *cx,
97 return ret;
98 }
99
100-
101-
102 /* ---------------------------------------------------------------------------------------------------- */
103
104 typedef struct
105-- 91--
1062.7.0 922.7.4
107 93
diff --git a/meta-oe/recipes-extended/polkit/polkit/polkit-1_pam.patch b/meta-oe/recipes-extended/polkit/polkit/polkit-1_pam.patch
index 74647efce..c491abf4a 100644
--- a/meta-oe/recipes-extended/polkit/polkit/polkit-1_pam.patch
+++ b/meta-oe/recipes-extended/polkit/polkit/polkit-1_pam.patch
@@ -4,9 +4,18 @@ Upstream-Status:Inappropriate [configuration]
4 4
5Signed-off-by: Xiaofeng Yan <xiaofeng.yan@windriver.com> 5Signed-off-by: Xiaofeng Yan <xiaofeng.yan@windriver.com>
6 6
7--- a/configure.ac 2011-03-04 02:26:20.000000000 +0800 7Upstream-Status: Inappropriate [oe specific]
8+++ b/configure.ac.new 2011-07-18 10:14:12.516818852 +0800 8Rebase to 0.115
9@@ -350,10 +350,10 @@ 9Signed-off-by: Hongxu Jia <hongxu.jia@windriver.com>
10---
11 configure.ac | 8 ++++----
12 1 file changed, 4 insertions(+), 4 deletions(-)
13
14diff --git a/configure.ac b/configure.ac
15index 36df239..8b3e1b1 100644
16--- a/configure.ac
17+++ b/configure.ac
18@@ -471,10 +471,10 @@ elif test x$with_os_type = xfreebsd -o x$with_os_type = xnetbsd; then
10 PAM_FILE_INCLUDE_PASSWORD=system 19 PAM_FILE_INCLUDE_PASSWORD=system
11 PAM_FILE_INCLUDE_SESSION=system 20 PAM_FILE_INCLUDE_SESSION=system
12 else 21 else
@@ -21,3 +30,6 @@ Signed-off-by: Xiaofeng Yan <xiaofeng.yan@windriver.com>
21 fi 30 fi
22 31
23 AC_SUBST(PAM_FILE_INCLUDE_AUTH) 32 AC_SUBST(PAM_FILE_INCLUDE_AUTH)
33--
342.7.4
35
diff --git a/meta-oe/recipes-extended/polkit/polkit_0.113.bb b/meta-oe/recipes-extended/polkit/polkit_0.115.bb
index f34928fe3..ad0f66a5e 100644
--- a/meta-oe/recipes-extended/polkit/polkit_0.113.bb
+++ b/meta-oe/recipes-extended/polkit/polkit_0.115.bb
@@ -24,10 +24,13 @@ SRC_URI = "http://www.freedesktop.org/software/polkit/releases/polkit-${PV}.tar.
24 file://0001-make-netgroup-support-configurable.patch \ 24 file://0001-make-netgroup-support-configurable.patch \
25 ${@bb.utils.contains('DISTRO_FEATURES', 'pam', '${PAM_SRC_URI}', '', d)} \ 25 ${@bb.utils.contains('DISTRO_FEATURES', 'pam', '${PAM_SRC_URI}', '', d)} \
26" 26"
27SRC_URI[md5sum] = "4b77776c9e4f897dcfe03b2c34198edf" 27SRC_URI[md5sum] = "f03b055d6ae5fc8eac76838c7d83d082"
28SRC_URI[sha256sum] = "e1c095093c654951f78f8618d427faf91cf62abdefed98de40ff65eca6413c81" 28SRC_URI[sha256sum] = "2f87ecdabfbd415c6306673ceadc59846f059b18ef2fce42bac63fe283f12131"
29 29
30EXTRA_OECONF = "--with-os-type=moblin --disable-man-pages" 30EXTRA_OECONF = "--with-os-type=moblin \
31 --disable-man-pages \
32 --disable-libelogind \
33 "
31 34
32do_compile_prepend () { 35do_compile_prepend () {
33 export GIR_EXTRA_LIBS_PATH="${B}/src/polkit/.libs" 36 export GIR_EXTRA_LIBS_PATH="${B}/src/polkit/.libs"
@@ -40,6 +43,7 @@ FILES_${PN}_append = " \
40 ${nonarch_libdir}/${BPN}-1 \ 43 ${nonarch_libdir}/${BPN}-1 \
41 ${datadir}/dbus-1 \ 44 ${datadir}/dbus-1 \
42 ${datadir}/${BPN}-1 \ 45 ${datadir}/${BPN}-1 \
46 ${datadir}/gettext \
43" 47"
44 48
45FILES_${PN}-examples = "${bindir}/*example*" 49FILES_${PN}-examples = "${bindir}/*example*"