summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMingli Yu <mingli.yu@windriver.com>2019-05-24 02:25:14 -0700
committerKhem Raj <raj.khem@gmail.com>2019-05-24 10:12:12 -0700
commit5c20a95fc5100e557c7b56340400d44b1f65d96b (patch)
treec2d725688b47b9772e5dc0e0c22f3389050c6dc9
parent12f4b040e35b7114a49b8c88f5a5b38b387b6928 (diff)
downloadmeta-openembedded-5c20a95fc5100e557c7b56340400d44b1f65d96b.tar.gz
kea: Upgrade to 1.5.0
* License-Update: below text added The ext/coroutine code is externally maintained and distributed under the Boost Software License, Version 1.0. (See its accompanying file LICENSE_1_0.txt.) * There is a new added logic in 1.5.0 to use AC_TRY_RUN to detect usable C++11 regex in below commit: 39ab2f5d15 [5680] Added sanitizeString() function to libutil Use AC_COMPILE_IFELSE instead to fix below do_configure error: | checking for usuable C++11 regex... configure: error: in '/builddir/upgrade1/tmp/work/core2-64-poky-linux/kea/1.5.0-r0/build': | configure: error: cannot run test program while cross compiling * Remove 0001-Fix-error-call-of-overloaded-distance-is-ambiguous.patch as the logic is already included in 1.5.0. Signed-off-by: Mingli Yu <mingli.yu@windriver.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
-rw-r--r--meta-networking/recipes-connectivity/kea/files/0001-Fix-error-call-of-overloaded-distance-is-ambiguous.patch89
-rw-r--r--meta-networking/recipes-connectivity/kea/files/0001-remove-AC_TRY_RUN.patch34
-rw-r--r--meta-networking/recipes-connectivity/kea/kea_1.5.0.bb (renamed from meta-networking/recipes-connectivity/kea/kea_1.4.0.bb)8
3 files changed, 38 insertions, 93 deletions
diff --git a/meta-networking/recipes-connectivity/kea/files/0001-Fix-error-call-of-overloaded-distance-is-ambiguous.patch b/meta-networking/recipes-connectivity/kea/files/0001-Fix-error-call-of-overloaded-distance-is-ambiguous.patch
deleted file mode 100644
index fb16ecbf9..000000000
--- a/meta-networking/recipes-connectivity/kea/files/0001-Fix-error-call-of-overloaded-distance-is-ambiguous.patch
+++ /dev/null
@@ -1,89 +0,0 @@
1From 8ea2ee451a1af7c5b5c8f4b36c1f77d44442064d Mon Sep 17 00:00:00 2001
2From: Khem Raj <raj.khem@gmail.com>
3Date: Fri, 7 Sep 2018 13:02:35 -0700
4Subject: [PATCH] Fix error: call of overloaded distance is ambiguous
5MIME-Version: 1.0
6Content-Type: text/plain; charset=UTF-8
7Content-Transfer-Encoding: 8bit
8
9The boost::iterators::distance function template is an adapted version
10of std::distance for the Boost iterator traversal in 2.68 it has started
11to fail with argument dependent lookup and compiler is erroring out
12
13with
14
15error: call of overloaded ‘distance'
16
17boost implementation of distance is protected against being found by ADL
18
19The way function is called in libdhcp means it will be found via ADL and
20all namespaces will be considered which is providing problematic since
21its getting it from both std:: and boost:: namespaces
22
23so let it not rely on ADL by qualifying then calls with std:: namespace
24
25Upstream-Status: Submitted [https://github.com/isc-projects/kea/pull/103]
26Signed-off-by: Khem Raj <raj.khem@gmail.com>
27---
28 src/lib/dhcp/libdhcp++.cc | 12 ++++++------
29 1 file changed, 6 insertions(+), 6 deletions(-)
30
31diff --git a/src/lib/dhcp/libdhcp++.cc b/src/lib/dhcp/libdhcp++.cc
32index 330c02b..ced705d 100644
33--- a/src/lib/dhcp/libdhcp++.cc
34+++ b/src/lib/dhcp/libdhcp++.cc
35@@ -419,14 +419,14 @@ size_t LibDHCP::unpackOptions6(const OptionBuffer& buf,
36 // We previously did the lookup only for dhcp6 option space, but with the
37 // addition of S46 options, we now do it for every space.
38 range = idx.equal_range(opt_type);
39- num_defs = distance(range.first, range.second);
40+ num_defs = std::distance(range.first, range.second);
41
42 // Standard option definitions do not include the definition for
43 // our option or we're searching for non-standard option. Try to
44 // find the definition among runtime option definitions.
45 if (num_defs == 0) {
46 range = runtime_idx.equal_range(opt_type);
47- num_defs = distance(range.first, range.second);
48+ num_defs = std::distance(range.first, range.second);
49 }
50
51 OptionPtr opt;
52@@ -538,14 +538,14 @@ size_t LibDHCP::unpackOptions4(const OptionBuffer& buf,
53 // may be standard options in other spaces (e.g. radius). So we now do
54 // the lookup for every space.
55 range = idx.equal_range(opt_type);
56- num_defs = distance(range.first, range.second);
57+ num_defs = std::distance(range.first, range.second);
58
59 // Standard option definitions do not include the definition for
60 // our option or we're searching for non-standard option. Try to
61 // find the definition among runtime option definitions.
62 if (num_defs == 0) {
63 range = runtime_idx.equal_range(opt_type);
64- num_defs = distance(range.first, range.second);
65+ num_defs = std::distance(range.first, range.second);
66 }
67
68 // Check if option unpacking must be deferred
69@@ -638,7 +638,7 @@ size_t LibDHCP::unpackVendorOptions6(const uint32_t vendor_id,
70 idx->equal_range(opt_type);
71 // Get the number of returned option definitions for the
72 // option code.
73- size_t num_defs = distance(range.first, range.second);
74+ size_t num_defs = std::distance(range.first, range.second);
75
76 if (num_defs > 1) {
77 // Multiple options of the same code are not supported
78@@ -746,7 +746,7 @@ size_t LibDHCP::unpackVendorOptions4(const uint32_t vendor_id, const OptionBuffe
79 idx->equal_range(opt_type);
80 // Get the number of returned option definitions for
81 // the option code.
82- size_t num_defs = distance(range.first, range.second);
83+ size_t num_defs = std::distance(range.first, range.second);
84
85 if (num_defs > 1) {
86 // Multiple options of the same code are not
87--
882.18.0
89
diff --git a/meta-networking/recipes-connectivity/kea/files/0001-remove-AC_TRY_RUN.patch b/meta-networking/recipes-connectivity/kea/files/0001-remove-AC_TRY_RUN.patch
new file mode 100644
index 000000000..d7ca9ff8f
--- /dev/null
+++ b/meta-networking/recipes-connectivity/kea/files/0001-remove-AC_TRY_RUN.patch
@@ -0,0 +1,34 @@
1From 9d6b8321c5b46199baca907f3d42bdcaaf1958a8 Mon Sep 17 00:00:00 2001
2From: Mingli Yu <mingli.yu@windriver.com>
3Date: Thu, 23 May 2019 23:59:42 -0700
4Subject: [PATCH] remove AC_TRY_RUN
5
6AC_TRY_RUN doesn't work in cross compile env,
7use AC_COMPILE_IFELSE instead to fix below configure
8error:
9 | checking for usuable C++11 regex... configure: error: in `/builddir/tmp/work/core2-64-poky-linux/kea/1.5.0-r0/build':
10 | configure: error: cannot run test program while cross compiling
11
12Upstream-Status: Inappropriate [oe specific]
13
14Signed-off-by: Mingli Yu <mingli.yu@windriver.com>
15---
16 configure.ac | 2 +-
17 1 file changed, 1 insertion(+), 1 deletion(-)
18
19diff --git a/configure.ac b/configure.ac
20index c880b77..dd40c7c 100644
21--- a/configure.ac
22+++ b/configure.ac
23@@ -580,7 +580,7 @@ AC_TRY_COMPILE([
24 AC_MSG_RESULT(no))
25
26 AC_MSG_CHECKING(for usuable C++11 regex)
27-AC_TRY_RUN([
28+AC_COMPILE_IFELSE([
29 #include <regex>
30 #include <iostream>
31 int main() {
32--
332.21.0
34
diff --git a/meta-networking/recipes-connectivity/kea/kea_1.4.0.bb b/meta-networking/recipes-connectivity/kea/kea_1.5.0.bb
index 67de07b31..9210ac1bc 100644
--- a/meta-networking/recipes-connectivity/kea/kea_1.4.0.bb
+++ b/meta-networking/recipes-connectivity/kea/kea_1.5.0.bb
@@ -3,20 +3,20 @@ DESCRIPTION = "Kea is the next generation of DHCP software developed by ISC. It
3HOMEPAGE = "http://kea.isc.org" 3HOMEPAGE = "http://kea.isc.org"
4SECTION = "connectivity" 4SECTION = "connectivity"
5LICENSE = "MPL-2.0 & Apache-2.0" 5LICENSE = "MPL-2.0 & Apache-2.0"
6LIC_FILES_CHKSUM = "file://COPYING;md5=1666a9c4bb55adbc8939d85643096bd3" 6LIC_FILES_CHKSUM = "file://COPYING;md5=2ed44ce4e0bbfdc1abfa6bf949b7ba3a"
7 7
8DEPENDS += "kea-native" 8DEPENDS += "kea-native"
9 9
10SRC_URI = "\ 10SRC_URI = "\
11 http://ftp.isc.org/isc/kea/${PV}/${BP}.tar.gz \ 11 http://ftp.isc.org/isc/kea/${PV}/${BP}.tar.gz \
12 file://0003-Makefile.am-update-hooksdir-for-lease_cmds.patch \ 12 file://0003-Makefile.am-update-hooksdir-for-lease_cmds.patch \
13 file://0001-Fix-error-call-of-overloaded-distance-is-ambiguous.patch \ 13 file://0001-remove-AC_TRY_RUN.patch \
14 file://kea-dhcp4.service \ 14 file://kea-dhcp4.service \
15 file://kea-dhcp6.service \ 15 file://kea-dhcp6.service \
16 file://kea-dhcp-ddns.service \ 16 file://kea-dhcp-ddns.service \
17" 17"
18SRC_URI[md5sum] = "26eedd749101642757d788431605aaa5" 18SRC_URI[md5sum] = "591d38e5fcc0251a8812e8bb1337578a"
19SRC_URI[sha256sum] = "c0f8ecb93657adfc5ab970c91706754e601084828493f053f159661d21b31128" 19SRC_URI[sha256sum] = "edce4fab68ca7af607cf7f5bc86596e04fe0ef4b8e88906e339cdefcf21daaec"
20 20
21inherit autotools systemd 21inherit autotools systemd
22 22